[UNOFFICIAL BUILD] /e/ r Sony Xperia Z3 Tablet Compact (scorpion, z3tc, z3tcw)

Hi Pete! Today I was able to reflash stock Android 6.0.1 and after that flash your /e/OS Version of 1.12.3

Wow! Flawlessly! Perfect! It’s fantastic! Never ever expected to have /e/ on this ancient (but still cool, best size ever and kust over 6mm thin) device.

I can also note that sideloading Magisk Stable version 26.1 works ‘out of the box’. Dammit. You nailed it!



@Taurus Dare to have a try …

@petefoth what are differences between z3tc variants

  • SGP621 / SGP641 (LTE)
  • SGP611 / SGP612 (wifi)

First I need to find out which one I should buy… or not buy, i.e. if the bootloader is unlockable or not. I don’t know if the JP models are unlockable. :wink:

I’m sorry but I have no idea. I know SGP611 is the WiFi version, and SGP621 is the LTE version (i.e. it has a SIM, and is phone as well as a tablet. I don’t know anything about the other model numbers

Apparently the SGP641 has different 4G bands from the 621, which probably means they’re marketed for different regions.

Expand the Network - Technology section at the top of this GSMarena(.)com spec table to see the bands.

I suppose the SGP612 model, although likely wifi only, could be marketed in a different region as well.

1 Like

I own the SGP621, that’s the SIM-version for Europe. It was definitely sold in Germany and should work on 4G throughout Europe. Other countries I don’t know.

So as used bands are modem dependent, i presume /e/ build should works as well

As long as the bootloader is unlockable. :wink:

1 Like

Still trying to find out if JP tablets have unlockable bootloader, but there seems to be little info on that.

On the up side, I own, and can recommend, M$ Surface Go2 tablet/PC… with Windows nuked and replaced with Linux Mint Cinnamon. :smile:
It works pretty well, though not perfectly, as a tablet, and is a full desktop OS. Very fast, too.

Here are the latest / last builds from me for these devices:

I have flashed the WiFi version on my test device, and it seems to run OK, though there is still no sign of GPS working. Not tested the LTE version at all.

Have fun, and good luck.

If anyone wants to take on the task of making future builds for these devices, details of how to do it are in this post


Hi Pete, can I just dirty flash this in recovery (PBRP)?

That should be OK. I clean flashed because my test device was running Los4microg, but there’s no reason why dirty flash ***shouldn’t *** work. I’ll keep my fingers crossed :wink:

Dirty flashed today from SD card, reflashed Magisk directly afterwards, rebooted and… Hell yeah! Works fantastic. GPS not tested since no app with GPS functionality on board anymore.

Everything seems to work with one exception: when I enable Tracking Control most apps refuse to connect to the internet. Strange, because other devices don’t have this behavior. Regardless if I release all blockers. When I disable TC apps have webaccess again.

But all the rest is great. Thanks Pete, it’s really an awesome job!

1 Like

I emailed Sony Developer World and asked about the Japan-market tablets. They replied:

It is only possible to unlock the bootloader for certain releases. The flag that enables/disables bootloader unlock is set at the factory according to the operator’s preferences and JP models could potentially not have unlockable bootloaders.

So best to avoid those, I guess.

Running V1.13 without any problems for some weeks now, thanks once again @petefoth
I even managed to complete a Seedvault backup for the first time! :slight_smile:

1 Like

No one who his this problem, that Tracking Control doesn’t work? See 2 posts above.

Hi @petefoth
First, Thanks a ton for all the work you’ve done on this build.
I’m trying to refresh my old tablet and I was hoping to install /e/ on it to replace the old Android 6.
Do you still take questions in case I run into some issue when flashing the device?

I do, but it’s also worth joing the XDA Forums thread for LineageOS on this device


People there have much more experience than me, and the first post has links to the recovery you will need

1 Like

Thank you for your reply. So far, I didn’t even manage to unlock the bootloader (as you mention in a post on the xda forum, it seems to be the hardest part). I found the right usb driver (it took quite a while), fastboot detect the device, but when sending the unlock command with the unlock code given by sony, I get a failed message. I’ll check on xda if they have a solution for this (service info says the device is unlockable).

Edit: Tried again this morning and it worked on 1st try…

1 Like

So. I managed to install PBRP Recovery and to boot into it. But I have no idea what to do.
In PBRP, I go to install, select the boot.img from the e-1.13-r-20230725-CUSTOM-z3tcw (that i unzipped into the device), I select System Image et Swipe to Flash but then if I want to reboot, I have a warning saying “no OS installed”.

I have no idea what I did wrong (or did not do).

Edit: My bad. I had used the file in the unzipped “e.1.13…” folder, when I had to use the zip file directly. I flashed it now, but for some reason, the battery wasn’t charging while plugged into the computer, so I turned it off and plugged it to the wall, waiting for it to charge a bit before turning it on again (it was litterally at 0%). I’ll update when I turn it back on)