[UNOFFICIAL BUILD] /e/ r Sony Xperia Z3 Tablet Compact (scorpion, z3tc, z3tcw)

Hi @petefoth
First, Thanks a ton for all the work you’ve done on this build.
I’m trying to refresh my old tablet and I was hoping to install /e/ on it to replace the old Android 6.
Do you still take questions in case I run into some issue when flashing the device?

I do, but it’s also worth joing the XDA Forums thread for LineageOS on this device


People there have much more experience than me, and the first post has links to the recovery you will need

1 Like

Thank you for your reply. So far, I didn’t even manage to unlock the bootloader (as you mention in a post on the xda forum, it seems to be the hardest part). I found the right usb driver (it took quite a while), fastboot detect the device, but when sending the unlock command with the unlock code given by sony, I get a failed message. I’ll check on xda if they have a solution for this (service info says the device is unlockable).

Edit: Tried again this morning and it worked on 1st try…

1 Like

So. I managed to install PBRP Recovery and to boot into it. But I have no idea what to do.
In PBRP, I go to install, select the boot.img from the e-1.13-r-20230725-CUSTOM-z3tcw (that i unzipped into the device), I select System Image et Swipe to Flash but then if I want to reboot, I have a warning saying “no OS installed”.

I have no idea what I did wrong (or did not do).

Edit: My bad. I had used the file in the unzipped “e.1.13…” folder, when I had to use the zip file directly. I flashed it now, but for some reason, the battery wasn’t charging while plugged into the computer, so I turned it off and plugged it to the wall, waiting for it to charge a bit before turning it on again (it was litterally at 0%). I’ll update when I turn it back on)

Are your instructions Copy the .zip … ?

not needed

don’t care about it


Yes, my bad. I edited my message to include the correction. I didn’t use TWRP since I installed PBRP directly with fastboot (petefoth mentioned that it was probably unnessary to install TWRP after all and they were right). I could load the zip file into the tablet internal memory while in PBRP and install it from there.

Thanks for your input.

So. I restarted it but I get the Sony splash screen (with green-red-green led sequence), then the /e/ loading screen. But then the screen stays black with an orange led. And I can tell the screen is on since backlighting turns on and off when pushing the power button. And if I hold the power button, I get the option to turn off or restart the device. Maybe I should try another OS, like Lineage, to see if it’s a software issue.

Edit: I went back into recovery, wiped cached data, rebooted and it worked fine.

Glad you got it sorted with help from @piero - sorry I didn’t reply, I was away from my computer.

I hope you enjoy the ROM on your tablet

WARNING: I have this ROM installed, rooted with Magisk 26.1

Magisk offers an upgrade to 26.3 - as soon as I install this (tried several times) it ends bootlooping ending in recovery. Dunno what to do but since the ROM development ends here anyway (with /e/) I just switched off Magisk-updating for now.

Hey @petefoth1 I just flashed another Z3TC with your unofficial /e/ build, thanks for that once again!
On the weird side: I had to flash your unofficial LOS 4microg first…
And I remembered that I had to do this once already on another unit.
Have 4 or 5 of these great devices running in my family now :slight_smile:

And also interesting: on this one the app icons stayed to be the ones from /e/ and not the ones from Trebuchet which I use on the tablet. Once again thank you for that to Pete…

Hi @MaxO @Infinity @petefoth
The specs for z3tc state:

USB microUSB 2.0 (MHL 3 TV-out), OTG, magnetic connector

Are any of you using MHL at all? Does it work?

In my lager family are quite a few SONY TVs and so far I keep older Samsung S2 on stock with KODI as an app install, hooked do these TVs, which works just great. And I still have one Z3TC on stock for the same reason.

If MHL would work on /e I’d switch the Z3TC now, but so far I never got any LOS working with MHL, in +6 years.

As you can see, I also would have to ask, what TVs you got it to work – if at all.

1 Like

Unfortunately I’ll not be able to help as I mostly use the Z3TC for reading comics. Never used a TV-output.

Sorry - I don’t know what MHL is - I can barely spell it :wink:

I hardly use my z3tcw - I really only have it to check that my unofficial builds (/e/OS, IodéOS, los4microg) will boot up. Sorry I can’t be more help

It’s a way of sharing/projecting your Android screen to a MHL-TV using a USB to HDMI cable. This has the benefit of no latency, like other WIFI based solutions.

And on top – maybe also not so well known – adds HDMI-CEC, which is when you use your TV remote to navigate e.g. a KODI box, the volume of an attached HIFI receiver or in this case, yes your Android OS(not in every aspect though).

(We managed to have someone, well +70yrs and without any internet, watch family photos just by putting the S2 into a docking station, during lock down times)

1 Like

One use case which gets overlooked, is MHL for Data-Recovery.

Using MHL on the TV and the TV remote, was the key to getting all family images and videos off the phone and receive a very important account info email.
Needless to say that screen did not respont to any thing.
(A bit of topic, I’m aware)

I was using MHL with the Z3TC in the past with an LG mini LED beamer, have to check the actual status though. Could take a little time, sorry…
Hopefully on the weekend!

1 Like

MHL doesnt work on my device unfortunately…

1 Like

Thanks @MaxO for testing