[UNOFFICIAL BUILD] Google / LG Nexus 5X (bullhead) for /e/OS-S

Google / LG Nexus 5X (bullhead) for /e/OS-S 1.17


Please see sources and install instructions including recovery here:

Use it at your own risk!
Please support the developer(

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Did make a R build too:

Hi. Thanks a lot for your work on these, and other builds. I couldn’t get my Nexus 5x to boot all the way though on R or S versions. It would restart just after the e logo was through loading after a minute or two. Normally this indicates a data partition clash, but i formatted data without making a difference. Any ideas?

Maybe you find something in the XDA forum:



You did this?

TWRP → Wipe → Format Data → Yes

Yes thats right. Tried dirty flash, boot, then factory reset in twrp, boot, then formatted data completely. Attempting boot each time. No luck. So tried format data and install the R version. Would crash just as it came to the first time setup screen. Could that app be the problem?

I would assume not.

Can you try latest 1.18R version please

Does Lineage OS Rom for Android 11 work?

Will try today and let you know. Currently running LOS17 with microg patched. Also nanodroid Patcher for sig spoofing support.

Tried the same thing on a different Nexus. Sideloaded the latest version of /e/R1.18 then formatted data but no boot. Got as far as screen saying Android is Starting, then it would always reboot. As a last resort i tried formatting in Fastboot. Took me to Twrp (3.7) and asked for password. On cancel it fornatted data and cache. So i think it has to do with encryption. Android 11&12 trying to auto-encrpyt data and not being supported or something.

does this work:

What worked for me:

  • in TWRP recovery, erase all except storage
  • flash lineage-18.1-20211123-UNOFFICIAL-bullhead.zip from link above
  • flash Magisk-v23.0.zip
  • boot phone, load Magisk, let phone reboot (note how storage is inaccessible)
  • boot TWRP recovery and flash [Magisk]_FUSE_DISABLER.zip
  • boot phone and storage now is accessible

if yes, replace the lineageOS ROM and try with the /e/OS ROM

I’ve tried installing the fuse_disable patch and magisk, over the top of /e/R1.18. still the same problem of not booting to the operating system and also after formatting data again. Haven’t tried the later versions of lineageOS as 17 works fine.

I mean to check if LineageOS 18.1 version works at all…

I found different sources for building a Q version. Can you try this one please


1 Like

Yes that one works just fine. Boots up and everything working fine including camera and fingerprint scanner. Good build. will let you know if i find anything not working. If you want to make a build for R S i can test those as well. Otherwise i will flash my other 5x as well. I also have 3x Nexus 6P which needs an /e/ build.

Unfortunately there are only Q sources for this build. So this will be the last build for Q until there are new or updated sources in XDA forum.
For angler (Nexus 6P) I tried some time ago to build Q as well as for R but did get errors. If there is much interested I could try again but would need help…

Ok well thank you very much for your work. The Q build for the 5x should last many years and I’m happy to have it.

Thanks great. Maybe there will be a R version sometime, will look at XDA forum from time to time.

@ronnz98 Are you keeping an eye on this device, as in new sources, other developer…
I got a X5 yesterday, in working order and I’m happy to test.

R&S versions seems not to work. T I couldn’t build.
Q works, but Q reached EOL so Q 1.17 will be last version.

I will look from time to time for this device if there are new or updated versions. Please feel free to test R or S version though…

Hello, first thanks for sharing your roms.
I wanted to know if it was possible to build the last version, or maybe with the lattest applounge, because we can only login anonymously.
I have a samsung galaxy s4 and the app lounge did not seem to work untill an update, and the system version didn’t seem to have changed. So maybe really only need a tweak ?
Also i wanted to know if it was possible to satisfy safetynet checks for banking applications in some ways ?