[UNOFFICIAL BUILD] Nothing Phone 2 (Pong) for /e/OS-T

Updated build using updated sources:

https://sourceforge.net/projects/eosbuildsronnz98/files/OtherSmartphones/e-1.18-t-20240103-UNOFFICIAL-Pong.zip/download

Which custom recovery did you use?

@ronnz98’s *zip contains the following images:

boot (101 MB), dtbo (25 MB), odm (1.8 MB), product (1.5 GB), recovery (105 MB), system (2.5 GB), system_ext (440 MB), vbmeta (8.2 kB), vbmeta_system (4.1 kB), vbmeta_vendor (4.1 kB), vendor (2.0 GB), vendor_boot (101 MB), vendor_dlkm (63 MB)

For a first clean install you need = download secure from here:

boot.img
dtbo.img
recovery.img
vbmeta.img
vendor_boot.img

Happy Flashing :crossed_fingers:

well @ronnz98 and @Xxpsilon , I got it installed…and wow was it a trip!

I can’t recount all of the procedures I went through, and certainly not in order…but I’d gotten my phone into an unbootable state…so the XDA thread had an EDL recovery tool that got me back to the stock ROM, which was an incredibly helpful starting point. (to directly answer your question @Xxpsilon , I’ve been using a combination of the /e/Recovery for ADB sideloading, and OrangeFox)

The “both slots” part confused me, since Slot A would boot the stock ROM and Slot B would boot loop, but I tried flashing the build to Slot B using the minimalist /e/ Recovery Environment linked in the thread.

…and it worked! /e/OS is working just wonderfully on the NP2!

…that might be a bit premature, I grant…it starts up and I was able to root it and install an app or two from App Lounge, and it hasn’t crashed or shown any other form of failure, so I’m in so-far-so-good territory, for certain.

The first thing I went to try was the “disco ball” on the back…and while i was hopeful as per @Xxpsilon’s indication that the NP1 glyphs function in /e/OS, I was unsurprised that the glyph on the NP2 do not function in /e/OS. I tried the app “Glyphith”, that’s supposed to manually enable the LEDs for the NP1 (the NP2 has a compatibility mode, if the custom ringtone tools from SebiAi are any indication), but no dice. I then got the Nothing Composer, and it’s not able to light up the glyphs, either.

So, please forgive my vanity in making that the first thing I tested in earnest, but it was a definite curiosity of mine. It’d clearly require some custom kernel tweaks so I’m certainly not holding my breath.

Switching gears, the interface as a whole is super fluid and responsive. The system boots incredibly quickly, no complaints anywhere there. The camera works like OpenCamera, so lens switching works well and the manual controls are what to expect…i had no issues of consequence (the app said there was an issue when switching lenses, then happily took photos from both).

I’m actually going to revisit spinning up my /e/Cloud VM and tying this phone to it to see how that works…I didn’t use the Murena account framework on the old phone, but it’s been over a year; I’m looking forward to giving it another go, and reporting back on that front.

Thank you again, so, so much, for your hard work on this! I’ve been waiting since release for such great news!

1 Like

NP1 Glyph interface - Settings for glyph lights only work for me after a restart. This is the same for LineageOS 20.0 and LineageOS-20.0-for-microG.


Clear Caches with this Cache Cleaner from F-Droid Store. After successful clean-up, restart yor system and try whether the Glyph interface can now be configured.

Great news! Since the sources are actively developed I would assume that newer version should hopefully fix current issues.

Thank you for the assist, @Xxpsilon !

I did as you said, and ran the cache cleaner, on all apps, and the phone has been rebooted no less than ten times. Unfortunately, neither Glyphith nor Composer will activate the glyphs at this stage, I’m afraid.

It’s a pity that the Glyph interface doesn’t work. The “disco ball” does offer an unusual appearance.

By the way: There is a clone of NP1: Unihertz ‘Luna’

It’s a pity that the Glyph interface doesn’t work. The “disco ball” does offer an unusual appearance.

I think it’ll get there. The telegram group for crDroid and Nameless AOSP both indicate that they can’t address the glyphs at the current stage. The Nothing Discord server indicates that the Glyph API is still not open and no SDK is provided.

One enterprising user went a bit further and did some decompiling of the official Nothing apps, and published their findings: https://github.com/rec0de/glyph-api. The most useful takeaway from that page is that, if I understand this right (software development isn’t exactly my specialty), there are some first party libraries and system apps that are integrated into the NothingOS stock ROM that, obviously, aren’t going to be present in /e/OS.

Perhaps Nothing will open up the Glyph API or an enterprising user will conjure up a flashable ZIP or a Magisk module for AOSP ROMs. deGoogled / FOSS Android builds for the NP2 are pretty new for the ecosystem, and it seems that even Nothing users are generally fine with the first party software that ships with the phone (in fairness, it’s probably the best stock ROM I’ve used aside from Nokia).

For now though, I’m just thrilled to no end that I can run /e/OS on my phone. The glyphs will come.

There is a clone of NP1: Unihertz ‘Luna

I keep forgetting about Unihertz! they really do make some of the most unique handsets and I probably should take a closer look at them next go-round. The question in the case of the Luna is whether their disco ball suffers from similar problems as the NP2. Amongst the reasons I was drawn to the NP2 was the ecosystem around it; the NP1 already had a good number of custom ROMs for it when I bought my NP2, but Unihertz has neither an XDA category nor an /e/OS port, even an unofficial one, for any of their handsets that I saw.

Unihertz LUNA with MediaTek’s Helio G99 SoC and UFS 2.2 memory is sufficiently fast. The IPS display is very large at 6.81 inches. When you hold the Unihertz Luna in your hand for the first time, you immediately notice that the smartphone is no lightweight. Quite the opposite: at 298 grams, it is also very heavy and bulky at 168 x 76.8 x 10.4 millimetres.

Yes, unfortunately there is no custom ROM for the LUNA yet, but when /e/OS-T GSI is released, it will get one more Google-free chance, but probably without an active rear LED light. But - if you now activate the rear LED light with music-accompanied lighting, the Unihertz Luna doesn’t look like a calm, relaxed moonlight (as the name would suggest), but more like a party iPhone on ecstasy. According to the manufacturer, the LED design is supposedly inspired by ancient oriental philosophy of the round sky - so the name “Luna” makes a little more sense. The loss of the light show will not be painful.

Love the discussion and rabbit trail as I do @Xxpsilon , I’ve got my first bug report for @ronnz98 : vibration doesn’t work. At all. I’ve tried all the settings, but vibration absolutely does not work in any context or capacity.

LMK how I can help solve this when you’ve got time,

Update for /e/OS-T 1.19:

e-1.19.1-t-20240110-UNOFFICIAL-Pong.zip
https://sourceforge.net/projects/eosbuildsronnz98/files/OtherSmartphones/e-1.19.1-t-20240110-UNOFFICIAL-Pong.zip/download

Flash went great; haven’t found any new issues in the build so far!

Vibration (and glyphs) still aren’t working though. Not sure if it helps, but I realized that vibration doesn’t work in OrangeFox, either…is it possible that the two are related?

Thanks again, and please DM me with a paypal/venmo/patreon account when you have a minute.

@voyager529 reports: ... (and glyphs) still aren’t working though.

crDroid Dev @DylanAkp reports:
08-02-2024 Added Glyphify (An alternative app to ParanoidGlyph ...

Yes but the crDroid version is Android 14 only… will be some time until /e/OS support Android 14 ( /e/OS-U ?)

OrangeFox Recovery Stable Releases 2024-02-13
OrangeFox-pong-stable@R11.1_1.zip

Update for /e/OS-T 1.20:

e-1.20-t-20240222-UNOFFICIAL-Pong.zip
https://sourceforge.net/projects/eosbuildsronnz98/files/OtherSmartphones/e-1.20-t-20240222-UNOFFICIAL-Pong.zip/download

Unfortunately the source for A13 seem not to be actively developed any more. The good news is the A14 (LOS21) is actively developed. I made a LOS21 which one can find on XDA. Will do a port when /e/OS-U is available

Huzzah!

I know this is an Unofficial build rather than a Custom build, but is there any chance that Dylan’s telephony fix is integrated into this release?

Yeah, if I get support how I can integrate it (sources and instructions) I can do another build.

1 Like

Updates for /e/OS-T 1.21:

e-1.21-t-20240403-UNOFFICIAL-Pong.zip
https://sourceforge.net/projects/eosbuildsronnz98/files/OtherSmartphones/e-1.21-t-20240403-UNOFFICIAL-Pong.zip/download