[UNOFFICIAL BUILD] Sony Xperia XZ1 Compact (lilac) e-1.3-q Post #212

@petefoth: Thank you for explanation. I can understand your decision. I will keep lilac for testing and backup but it won’t become a daily phone now.

1 Like

Belated acknowledgement, applying to all the unofficial builds I have posted in this thread:

/e/ OS on the Xperia XZ1 Compact is based the unofficial LineageOS 17.1 ROM made by XDA Contributors modpunk and derf elot

Xperia XA2 (H3113) does not have the Sony camera app.
Is it possible to get the app and install it?
Looking at your links, I guess not.

Not as far as I know - sorry. I believe it needs to be built-in with the ROM for a specific device, and can’t be installed like a normal app.

Ah well, had to ask!
I’ve got a fair few bookmarks on how to build e, including your fine beginners guide :grinning:
Slowly approaching the point where I might have a go…

1 Like

Here’s a new build based on the v0.15-q tag. I have done both a clean install and a dirty flash over my previous unofficial release, and it seems to be working OK in both cases, with one important exception:

  • The version of microG Services Core installed by defaul is /e/'s ‘No Exposure Notifications’ version. Unfortunately, the official way to enable Exposure Notifications, using Apps, does not work in this ROM: when you try to install the update, Apps will crash.

If you need the Exposure Notifications Framework, for use with a Covid contact-tracing app, then the following workaround, using NanoDroid is what I do, and it works fine for me:

  1. Download the file NanoDroid- from https://downloads.nanolx.org/NanoDroid/Stable/
  2. Download this .nanodroid-setup file from my eCloud account: https://ecloud.global/s/CoweRN5HLPfKkNp
  3. Copy both files to either internal or external storage on your phone, using adb push or whatever file transfer app you use. Make sure that the .nanodroid-setup file has the . character at the start.
  4. Install the ROM using TWRP. (I always copy it across using adb push ..., then use ‘Install’ in TWRP. Using adb sideload ... should work just as well)
  5. Then install the NanoDroid zip file using TWRP. I do this in the same operation as installing the ROM, but you can do it at any time afterwards.
  6. Reboot your phone, and check that you have the ‘Exposure Notifications’ version of microG.

Note that this .nanodroid-setup will also install F-Droid and Aurora Store as system apps. If you don’t want these, then edit the file before copying it to the phone

  • change the line nanodroid_play=21 to nanodroid_play=0
  • change the line nanodroid_fdroid=1 to nanodroid_fdroid=1

There is lots more information about setting up a NanoDroid installation here https://github.com/Nanolx/NanoDroid/blob/master/doc/AlterInstallation.md

My apologies for all this hassle - I"ve tried to work out why Apps is crashing but I can’t, so I can’t fix it. It’s working fine in the official v0.15-q releases for z3c and suzuran devices, and I have no idea why it’s not working for lilac.

So finally, here’s the new build. Have fun!

This ROM is based on the unofficial LineageOS 17.1 ROM made by XDA Contributors modpunk and derf elot

Release notes for /e/ v0.15-q are here

Here’s a new build based on the v0.16-q tag. I have ‘dirty flashed’ it over the v0-15 version, and basic tests indicate that it’s working OK. As always though, please backup your current setup before flashing, and use at your own risk.

Release notes are here

Updated version built from the v0.16.2-q tag

Thanks a lot for this information. I’m really disappointed because I’m not good enough to try without a real tuto and explanations.
But thanks a lot for devolopping these builds !!!

I have probably a stupid question since I don’t know anything about how to install /e/ on a device, do you think I can follow the instructions of another sony phone to try and install /e/ on my xperia XZ1 compact ?
Thanks a lot for everything you’ve done

Yes. I would suggest following the instructions from Lineage OS for installing on Sony Xperia Z3 Compact

  • Ignore the first section Special Requirements about installing and using FlashTool

  • Follow the sections Basic requirements and Unlocking the bootloader

  • Follow the section Installing a custom recovery using fastboot, but don’t use the lineage-17.1 recovery, usetwrp-3.3.1-z3c-20200212.img from https://androidfilehost.com/?fid=4349826312261722027 instead

  • Follow the section Installing LineageOS from recovery.

    • In step 3, the TWRP commands are Wipe then Format data. You will be prompted to type yes in a terminal. Do that, then press the blue tick in the right hand corner. After formatting is complete, use the Back button to return to the main TWRP screen
    • In step 5, the TWRP commands from the main menu are Advanced then adb Sideload
  • When the sideload is complete I suggest that you also copy the ROM zip file across to the device (preferably to an external SD card which will not be erased in a Format data operation), so that, if you ever need to re-install you can do so using the TWRP ‘Install’ command instead of adb sideload. This can be useful if you need to reinstall when you don’t have acccess to a PC, or the PC has not been 'authorised` for debugging (as happens after a fresh install or factory reset).

    To copy the ROM to external SD card, the command (from the PC) is
    adb push e-0.16.2-q-20210425-UNOFFICIAL-lilac.zip /external_sd/

    To copy to the internal storage, the command is
    adb push e-0.16.2-q-20210425-UNOFFICIAL-lilac.zip /sdcard/

Thank you very much. I’ll try it then :wink:

1 Like

Everything went well until I had to boot in recovery mode. I tried it, the phone vibrated but nothing happened and now I have just a black screen and nothing.
Do you have any idea how I can go further ?
Thanks again

Sounds like the TWRP recovery image isn’t installed properly. Try reinstalling it from ‘fastboot flash recovery .img’. Then either fastboot boot recovery’ or hokd Power and volume down key till the phone buzzes. If it seems to be completely dead, hard reboot as follows: press and hold Volume key (in the middle, not up or down) and power key.After 10 secons phone will buxx once. Carry on holding tge keys and in a few seconds it will byzz three times. The phone is niw powered off

I got it to turn on normally again. Then I tried to reinstall TWRP. After telling me that it’s finished I try again the recovery mode but it does the same. It vibrates and then nothing else.
I’m really not good so here is my question. After the vibrating when I press the buttons to be in recovery mode should it be showing something on the phone or should it stayed black and the next command are to be written in the terminal on my computer ?
I’m sorry for all those questions

I think I know what has happened, and it’s my fault - sorry!

You should see first the TWRP Splash screen, then, when TWRP has finished loading, you should see the TWRP Main menu. Your screen should definitely not just be black. The reason it is black is that the link I gave you was to the TWRP image for the wrong phone, the Z3 Compact.

The correct version can be found at https://androidfilehost.com/?fid=4349826312261733451 and is called twrp-3.3.1-0-lilac-android10-1.img

No problems. I’m sorry for having given you the wrong link! With a bit of luck, and the correct TWRP image, you should soon have things working :slight_smile:

It worked. I thought it was weird I had the Z3c so I tried to find the good link but I didn’t find anything.
Thank you very much. I’m so happy. I will let you know my experience with my xperia xz1 compact !
Thanks a lot

1 Like

Hi, everything looks great except that my sim card is not recognized.
Is it normal or should it work without any problems ?

I’m correcting what I said, it recognizes it because it asks for my pin code but I have no signal at all