[UNOFFICIAL BUILD] Sony Xperia XZ1 Compact (lilac) e-1.3-q Post #212

Not normal :slight_smile:
Try Settings : System : Advanced : Reset options : Reset Wi-Fi, mobile & Bluetooth

It doesn’t work. But for a split second I see the name of my phone provider which I didn’t see before but then it’s back with no signal

Then I’m fresh out of ideas to make it work - sorry.
If it were my phone, I would try the following to see whether the problem lies with your specific device or SIM, whether it is specific to /e/, or to the LineageOS ROM on which the /e/ ROM is based. I would try

  1. Install the latest unofficial LineageOS 17.1 ROM, made by a developer known as Flamefire. It is available here https://androidfilehost.com/?fid=2188818919693787165.
  2. If that works and your SIM is recognised, then the problem is with this /e/ ROM. I would then try the previous /e/ ROM available here e-0.15-q-20210316-UNOFFICIAL-lilac.zip
  3. If 1. doesn’t work, then it may either be something in the latest LineageOS - you could try downloading an LOS ROM such as this one lineage-17.1-20210217-UNOFFICIAL-lilac.zip
  4. Or it may be he problem is with LOS, in which case try a different ROM such as the Pixel Epxerience Plus ROM made by Shank03 PixelExperience_Plus_lilac-10.0-NOVEMBER-UNOFFICIAL.zip

If none of the above work, then it’s either your phone or your SIM. Unlikely of the were working with the stock software from Sony, but it is possible.

I know this is a lot of hassle for you, and I’m really sorry. If you can try some of the above steps, it will give me more of a clue - which I don’t have at the moment - about what the problem is and how it might be fixed.

(Just so that you know, I will be away on vacation next week, with limited internet access and no access to my build machine, so if I can’t find something that works by Sunday, you may need to reflash the stock Sony software or be without a phone for a while longer :frowning:)

My sim works fine on my Samsung S7 which is on /e/.
It’s a pre-installed phone I bought from /e/ a year and a half ago.
Maybe I did something when the phone first boot under /e/ because I think I remember a window asking me if I wanted to improve the network ? (Réseau in french). But I’m not sure

And if I try to reinstall /e/, will I have to do everything again or can I just do the steps from " Installing LineageOS from recovery" ?
Because if it just this step, there is no problem.
And I have no idea how to reflash the stock Sony software
Thanks again for everything.
Have a good vacation and don’t worry I have a phone, this phone is not my main phone at the moment but I wish it will be again soon :wink:

Maybe worth trying factory reset (or Wipe in TWRP which is the same) and not agreeing to that window?

No need to repeat the earlier stuff - once you have a working recovery you can flash any ROM you like :slight_smile:

It’s in the first section Special Requirements on the LOS Page about installing and using XperiFirm and FlashTool. (But remember to look for software for the XZ1 Compact, not the Z3 Compact :wink: )

I will have a good vacation and I wont worry :slight_smile:

You may have done this already, but I would telephone the carrier support (with the device trying to transmit). They should be able to give you a very good clue why they cannot serve you (as you are indicating that you have “almost contact”!).

I’ve tried everything you’ve said.
With the different versions of lineageOS en /e/ the phone knows there is a sim but there is a cross on the icon for service and it says no service.
I also have this on the notifications with the logo of the sim:
Sony Modem
Status : 0
Config : amss_fog_lilac_tar.mbn
Cust ID : 384

Under Pixel there is no sim card at all.

And the window I told you about it’s :
Your device will reboot to optimize your network provider

And I don’t have a choice, either I turn off manually my phone or I press Ok and it does it but there is no other options and I can’t get the window to disappear except if I turn off my phone.

It’s been a while since I’ve used my sim card in that phone but it was working really well at the time. And the sim works very well in my Samsung S7 under /e/

OK that is normal, and isn’t a problem

Then, as @aibd says, maybe time to contact your SIM provider.
Also, maybe try a SIM from a different network.
After that, I really am out of ideas - sorry!

Ok thanks.
Maybe I have an idea for my problem. Correct me if I’m wrong.
I installed LineageOS 16 and my SIM card is working fine on it. So my conclusion is that I was not under Android Q but Pie on my Sony.
But I don’t understand anything with flashtool I don’t know how to install it on Linux.
I have a backup in .ad of my Sony but I don’t know if I can just use this and not flashtool to reinstall stock ROM

@petefoth Hi Pete. With regard to @Xyguma’s wish to return to stock do you know if newflasher is good for lilac?
Thanks, Chris.

I’m afraid I don’t know. I’ve only ever used FlashTool, and that’s not working now on my Mac anymore because 32 bit Mono no longer works.
According to this post in the LOS Unofficial ROM Thread on XDA, it should work

OK, Thanks.Shame about your mac.
I’ve seen reports on xda also of people using newflasher successfully.
Reassuring, thanks.

@petefoth do you think it’s possible my sim didn’t work because I was on Android 9 before flashing ?

I really don’t think so. Android 9 was the latest Sony stock firmware, and I’m pretty sure I flashed a Q (Android 10, LOS 17.1) ROM on top of that, so I don’t see why it would be a problem. The XDA thread for the unofficial LOS ROM says it should be flashed over firmware build which is Android 9 (pie). Flashing over Android 8 (oreo) might have caused problems but you didn’t do that.

Have you tried installing the LOS 18.1 ROM from the XDA thread? That’s Android 11, R. The only problem with trying that is that I don’t know how easy it is to go back to Android 10 / Q / LOS 17 from there, without reflashing the stock ROM first

Apart from that I really am out of ideas - sorry

Ah ok.
Well maybe I was under Android 8, it seems strange but maybe it’s this, since LineageOS16 works fine for me.
I could stay with it but I really prefer /e/.
Thanks for everything

I found something and it’s working I’ve got signal.
I found this apparently there is a bug. My prefered network was set on 4G, you have to set it on 3G reboot your phone and put it back on 4G and it worked.
Thanks a lot to everyone. I’m going to start using my phone with /e/ !!

Good find - well done!

Here’s a new build based on the v0.17.1-q tag. It’s had only very basic testing - it boots and runs. As always, use at your own risk

No release notes for the v0.17-q tag but release notes for v0.17-nougat are here

  • Xperia XZ1C lilac

The functionality to enable Exposure Notifications in MicroG does not work. If you want / need to enable this, then please install this .apk file https://ecloud.global/s/WGf4kCnnSeaKixT

I just joined the forum to deliver a big Thank You to you, @petefoth. I’m so glad I found this thread and your work. I’ve been wanting to de-google my Androids forever, but didn’t have the courage to try a custom ROM installation. Turns out it was easier than I thought; now I’m running e-0.17-q-20210612 on my 6-month-old XZ1c…and with the actual Sony camera software intact, no less.

I do have probably the same LTE problem as @Xyguma, though. I start with no connection, toggle to 3G to get the connection (although “4G” is displayed in the notification area…possibly meaning “3G+”?), then toggling to LTE, “LTE” returns to the notification area…at which point I don’t necessarily have an actual connection. I’m using a U.S. MVNO that runs on AT&T.

I’m doing a test right now: I inserted a (defunct) T-mobile SIM, which triggered a network reconfig/optimization and restart. (By the way, the VoLTE setting gets added to the Network menu automatically when using a T-mobile, or T-mobile-based MVNO SIM. The VoLTE setting is not present when using an AT&T-based SIM. This is expected behavior.)

Following that, I powered down, inserted the AT&T SIM again, restarted, triggered another network reconfig, and selected LTE Preferred. The connection seems to be stable now; I’ll monitor it for a while and then report back here.

Can you clarify for me: Will I need to reinstall the OS to get any system/security updates? If so, is there an easy way to keep all my installed applications (from F-Droid) and settings intact?

Thanks again for your excellent work, Pete!
Edit: And to the entire /e/ team, of course.

1 Like