[UNOFFICIAL BUILD] Sony Xperia Z5 Compact (suzuran)

And another, based on the v0.12-nougat tag which appeared yesterday :slight_smile: It runs on my device but apart from that, is untested. As always, use at your own risk


1 Like

Hey @petefoth,

I just updated my phone with your e-0.11 build. Will test it out all this week.
Where would be an appropiate place to start tracking what is working and what is not for each build, as asked by @withane:

Thanks for all the builds!

It would be great to have a document to track what is and is not working in each build for a particular device. However creating and maintaining such a document would

  1. be pretty much a full time job
  2. duplicate information stored and maintained in other places (such as the gitlab issue tracker)

I know that over in the XDA Forums, ROM developers and maintainers have either a list of what is and is not working (as in the first post in this thread) or, for more mature ROMs (where most things are presumed to be working), a ‘Known Issues’ list and a (Change Log’ (as in the first and second posts in this thread). Even that will require a considerable effort to maintain and, realistically, isn’t ever going to happen for /e/ on a ‘per-device’ basis. Of course if someone had the time to volunteer to maintain such a list for a specific device, that would be great :wink:

The easiest way to get a picture of the status for a particular device, is to

  1. look at the release notes for the relevant Release number or tag for the source (so for this release the v0.12-nougat release or tag
  2. look at the open issues list, maybe filtering for your specific device (though that probably won’t help a great deal for unofficial builds / devices that are not officially supported)
  3. Search in these forums for recent posts mentioning your device. Especially the comments to the 'UNOFFICIAL BUILD] thread which may highlight any problems.

I make builds when I have some spare time, and when there have been some changes worth picking up since my previous build. But I don’t ever get round to flashing and running most of the builds I make. The exception is builds for the Z5 Compact, which was my ‘daily driver’ and is now my backup phone. I will usually at least flash the build - usually a dirty flash so that I don’t lose my apps and data - and check that the phone at least powers up. I really don’t have the time - nor the interest if I’m honest - to spend on testing my builds and documenting the results. I spent much of my working life doing stuff like that, and now I’m too busy enjoying my retirement :slight_smile:

At present I’m not even running /e/ on my daily driver (Xperia XZ1 Compact) since there is no up-to-date working build for that device, and I am not currently able to build one.

1 Like

I’m using this release (e-0.11-n-20201001-UNOFFICIAL-suzuran.zip) in my backup phone which doesn’t get used very often. I was using it today, and I noticed that when I make or receive a call, the screen goes blank, and becomes unresponsive, until the other party ends the call. I’ve tried using the default Dialer app and Simple Dialer, with the same response.

I’m not sure whether this is a problem with the /e/ software, or with my device. Can I ask anyone else using this build (or any others) whether they are encountering any problems?

Thanks in anticipation


Tried dirty flashing previous release e-0.11-n-20200930-UNOFFICIAL-suzuran.zip (v0.11-nougat) - same problem
Factory reset - screen doesn’t blank until the call is connected, but still the same when it does :frowning:

So it looks like it’s my hardware, but I would still be grateful if any users of this build (or earlier) can tell me whether incoming and outgoing calls work for you.

A new up-to-date unofficial Q-build for Sony Experia S5 Compact (suzuran)

Many thnx to @petefoth who was willing to test this build.
So this build is tested, but as always, make a backup and enjoy.
Please share your experience.

Here’s a slightly more recent unofficial Q build. Probably not much difference in functionality from @itsclarence’s build. Built from the v0.12-q tag / release
I have fired it up and it seems to work but, as always, use at your own risk

1 Like

Here’s av version 0.13 Q build. I’ve dirty flashed it on my device, and everything seems to work but, as always, use at your own risk.

Note that the version of microG installed does not include the Exposure Notifications API

1 Like

Update Tue 8 December 2020

Here’s another one - this time built from the official v0.13-q tag
I haven’t flashed this one yet, but it should be at least as good as the last one :slight_smile: It’s still at your own risk though!

Here’s a new build based on the v1-q branch. I have successfully flashed it and it seem to run OK, but it is essentially untested. As always, use at your own risk

Old link removed

Note that the version of microG installed does not include the Exposure Notifications API. The Exposure Notifications API can be installed from ‘Apps’, as described in this post

Thank you @petefoth for the build!
I just installed the build e-0.13-q-20201208 on my phone and it is refreshing. It was actually my first attempt to install a custom firmware.
Hopefully it will work so well that it can become my main phone in a few weeks when I need to return my company phone!
Once again, thank you and all other contributors for your effort!

Glad you like it :slight_smile:
I’m working on a v0.14-q build but currently having problems building. I hope it will be along shortly

And here it is: a new unofficial build based on the recent v0.14-q tag

I’ve flashed it, and fired it up: everything seems to work, though I haven’t tested making and receiving calls as the device I have for testing is a bit broken :frowning:

Dirty flash should work, but I recommend backing up your data partition just in case

Have fun, but at your own risk, as always



I upgraded my phone to 0.14-q the other day. It seems to work. Thank you!

1 Like

I was so happy to find out, that I could possibly get my sister’s old phone to work.

0.14-q does not work for me.
The phone app crashes, but the call goes out anyway, so I can’t hang up.
I get a pop-up (of the crash) that comes up again and again, even if I dismiss it.
I can only close the popup without it appearing again, if the other person hangs up.

0.13-q seems to work, but:
If the phone is off, I plug in the charger, the battery charging indicator stays red.
I mean, the end of the charge cycle is not shown or heard, only if I push the power button can I see how it is doing.
After fully charging it, when the phone is turned on, I get the green light, while charging.

Something wasn’t quite right with USB file transfer, but it works now with debian 10.
(It wouldn’t connect or the file manager was giving me errors. Just rebooted my PC and it’s fine now.)

This is a known bug: issue #2391 affecting several devices, including this one. The easy workaround is to install ‘Simple Phone’ dialer app from f_Droid, and set is at the default phone app.

I hope the issue gets fixed soon, but I find the phone works fine with ‘Simple Phone’ installed

Thanks @petefoth for the continual builds!

I upgraded to 0.14-q from 0.11 yesterday, and installed the Dialer app by Tibor Kaputa to workaround the known bug.

One issue I had was that Signal, which I use for SMS, kept crashing after the flash. I uninstalled and reinstalled the app, which worked, but I also realized that I had lost all my contacts some time during it all. So just a reminder to backup before you update!

1 Like

There’s a new unofficial build available

Changes include

  • Android security patch level: 5 February 2021
  • An FM radio app has appeared: it seems to run, but I can’t hear anything :slight_smile:

I have flashed it and tested it a bit:

  • it makes and receives calls with the Simple Dialer app - the built-in ‘Phone’ dailer crashes. This is a known bug #2391
  • it sends and receives SMS and email.

But please use at your own risk, as always!

1 Like

No more unofficial builds for this device…

… because it is now officially supported. :slight_smile:

e-0.15-q build, along with installation instructions is available here


Belated acknowledgement, which applies to all of the unofficial ROMs posted by me in this thread:

/e/ OS on the Xperia Z5 Compact is based on the unofficial LineageOS 17.1 ROM made by Bernhard Thoben (Professor-Berni on github)

Edit: And now the Android 11 / R build is official. The most recent version at the moment is v-0.19-r, but v0.20-r should be available this week


There is now an unofficial Android 11 / R build for suzuran: see this post

I have just made an up-to-date unofficial LineageOS for Microg build for suzuran. Available in this folder on AndroidFileHost

If you are clean flashing, checkout the Post-install section of the LineageOS for Microg front page

This build should dirty flash OK over earlier versions, but I have no idea what will happen if you dirty flash over an /e/OS installation :slight_smile: