[UNOFFICIAL BUILD] Unofficial /e/ Builds for Lineage Supported Phones

I’m just building a Pie image myself to see if it works.

1 Like

Mine has worked on Pie. This is what I used.

sudo docker run \
-v “/srv/e/src:/srv/src:delegated” \
-v “/srv/e/zips:/srv/zips:delegated” \
-v “/srv/e/logs:/srv/logs:delegated” \
-v “/srv/e/ccache:/srv/ccache:delegated” \
-e “BRANCH_NAME=v1-pie” \
-e “DEVICE_LIST=dipper” \
-e “CUSTOM_PACKAGES=‘MuPDF GmsCore GsfProxy FakeStore com.google.android.maps.jar Telegram Signal Mail BlissLauncher BlissIconPack MozillaNlpBackend OpenWeatherMapWeatherProvider AccountManager MagicEarth OpenCamera eDrive Weather Notes Tasks NominatimNlpBackend Light DroidGuard OpenKeychain Message Browser BrowserWebView Apps LibreOfficeViewer’” \
-e “SIGNATURE_SPOOFING=restricted” \
-e “OTA_URL=https://ota.ecloud.global/api” \
-e “REPO=https://gitlab.e.foundation/e/os/android.git” \

1 Like

Hi @Deano good to hear that the build you made worked.

1 Like

Testing on a xperia xa2 ultra H3223-discovery. I was able to get past set up but i cannot activate anything while the setup runs for instance. if i set up screen lock it crashes the system or ive i log into eelo it takes forever and will cause my system to reset itself. I was able to boot into the rom and it looks brilliant it just crashes a lot which was expected. i tried to launch the messaging app and it crashed my system. how would i send you system data to help catch these bugs?

Its not ZOOL its Z00L, maybe thats why your build failed, my nougat and oreo builds already availiable here in this topic.
espresso3g have only marshmallow support, /e/ based on nougat and higher.
For sumire ill try to build and will let you know about result.

I updated oreo build, you can find it here in this topic, pie build failed, tried few times. Try to not setup screen lock and login /e/ at first setup screen, try to use you phone without it and add it later from settings menu if you really need it, also the problem can be with your firmware if you flash oreo rom, and your stock rom was pie, maybe you should try flash your oreo stock rom if it is availiable, cause i dont know how it works with sony devices.

well i cant help you with it, im only put device codename in docker script and it build rom automatically, as this build not official one, there is no any support, i dont own these devices, so all testing for it is on you side, you can try use mine, build your own, or wait for official one.

This is the log output I get when trying to build Z00L (using zeros) with docker

javadoc: warning - Class android.support.annotation.RestrictTo not found.
javadoc: error - In doclet class com.google.doclava.Doclava, method start has thrown an exception java.lang.reflect.InvocationTargetException
at com.sun.tools.javadoc.ExecutableMemberDocImpl.position(ExecutableMemberDocImpl.java:283)
at com.google.doclava.Converter.convertParameters(Converter.java:236)
at com.google.doclava.Converter.access$700(Converter.java:46)

at com.sun.tools.javadoc.Main.main(Main.java:54)
1 error
ninja: build stopped: subcommand failed.
build/core/ninja.mk:151: recipe for target ‘ninja_wrapper’ failed

i dont think error here, need full log, and what your pc specs and linux distro?

so my pie and oreo surime builds failed after repo sync, so there no support, nougat finished successfull just right now and then i found it is officially supported https://gitlab.e.foundation/e/wiki/en/wikis/device/sumire/info, so i just wasted time for building it.

Brilliant. I followed the install instructions for the sumire and I am now the proud owner of a bricked Sony Z5 :frowning:

Just installed the pie build on a 2016 Google Pixel (sailfish) – seem to work flawlessly so far. Well done!

Is it possible to create a rom / e / fo the galaxy tab 2 10.1 espressowifi p5110 please

I would like to point out that all is OK now and I have e running on a Sony Xperia Z5 (sumire)

1 Like

Feedback: Tested the Oreo build for Nexus Player ‘fugu’. It works ok, however certain apps are not really needed for android tv in my opinion. i.e. Magic earth, torch, mail (didn’t try), message, open camera. And the built in browser loads but pops up an error which prevents you from using it. The /e/ appstore is not really optimized for the TV remote you’d need a mouse at the very least to browse it. But its great to have the option for the Nexus Player.

1 Like

On Xda exists an unofficial Lineage for my wileyfox swift 2x marmite (at the moment i use crdroid pie on it)
https://forum.xda-developers.com/swift-2/development/rom-lineageos-16-0-wileyfox-swift-2-t3906452 is it able to create an /e7 build for that phone?
unfortunately i am not able to this on my own because i am not fit enough in edv things

1 Like

OMG! The official e ROMs won’t work on the Pixel XL (marlin). But your p build for it does!!! Now my only question is whether there is a way to now get it to update/upgrade from the official e “repository?” I understand OTA is disabled. But is there some way to enable it?

@Unknown ive flashed your unofficial build for essential phone , pie. It is working fine, and i havent comes across any bugs. Will you be updating the builds?

Btw, the essential has also started to recieve official lineageOS builds recently.

1 Like

I’m working on a GSI Image, this will make compatible most devices shipped with Oreo and/or Pie.
For more informations please see this post:

I installed this on my Google Nexus 9 Flounder and it’s working great! Could you provide a build guide @Unknown as I would like to be able to build updated versions myself?

1 Like