[UNOFFICIAL BUILD] Unofficial Pie Build for Samsung Galaxy S7 (herolte)

Long press is not enough: it comes back.
MicroG is active and messaging works.

I’m not sure which version I installed but I understand that the one from Signal website or the one from G Play is not the same. One uses G services / microG and the other one doesn’t. The one using microG probably dosen’t get this annoying notification.

I tried first to uninstall and reinstall from Aurora and now it works now :slight_smile: Thanks for your support.

Another weird issue:

Onelogin Protect (an OTP application) says it won’t work because my phone is rooted.
Maybe they mean that I have a custom ROM (I also had a warning by What’s App) but it was working on the official build.

I tried to type “su” from a terminal emulator and I don’t think I’m root.

Any idea?

you device is pre rooted, but only available for ADB if activated. you can check in developer options.

But anyway, this massages does coming from custom rom, not from root. A lot of (banking) apps won’t work because of custom rom. The issue is the unlocked bootloader. And you can’t relock the bootloader

New version with security patch on August

With a new branch 0.11 with few fixes and improvements, like it’s written here : https://gitlab.e.foundation/e/os/releases/-/releases/v0.11-pie

Just installed this morning, seems to be ok for now


New version with security patch on September

The branch is now 0.12 with those improvments : https://gitlab.e.foundation/e/os/releases/-/tags/v0.12-pie

!!! WARNING !!!
There is an UI “improvment” which can be… annoying. This is discuss here : Status bar issue

@LaurentG, thank you for staying on the ball and providing continuous /e/ OS 9-pie updates.

But why microG Services Core version could not be upgraded to the current version (error message in TWRP), I could not find out yet.

With version /e/ OS e-0.12-o-2020093076269-dev-herolte it worked. Also Warn App StopCovid France runs …

I really don’t know, I’m just a builder wich few commands…
Infortunately, I did not take take time to go deeper un code so I can’t help you :confused:
May be @harvey186 ?

The new microG sources with the tracking (spying) feature is not implemented in the eOS sources for pie and q right now

#99 Your “news” to be an old hat.

Note by the way: Austria’s Corona-Warning-App works with /e/ OS.

yes, because it’s not using the play service modification



Oh, and why does the Austrian ‘Stopp Corona’ app not work on a /e/ OS 0.12-nougart with microG Services Core version ???

not sure, because I don’t use it.

Yeah? The reason is simply that the app ‘Stop Corona’ does not work:

Hi @LaurentG, my comment was not a criticism of your unofficial 9-pie build, but just a hint that my microG ‘pachting’ did not work, although it does work on the official /e/ OS e-12-oreo.

Well, now I’ve made another attempt which was successful.

First of all: I noticed on your build that the function ‘Erease all data (factory reset)’ does not work, i.e. the tap on the button ‘Erase everything’ shows no reaction - the function is not executed.


The starting point was a new fresh installation of your /e/ OS e-0.12-p-20201001-UNOFFICIAL-herolte with the old version microG Services Core version

I was able to upgrade to the current version microG Services Core version by manually. So now ‘StopCovid France’ also works on a /e/ OS 9-Pie ROM.

1 Like

Again, unfortunately, I can’t do anything with “bugs” of this version… What I will try to do is to make sure that this is a “general” bug (with version 0.12 of /e/) and not only with MY version of /e/

As far as I know, that’s on all eOS versions not working and s kniwn issue since 2 years.
We always telling to use the TWRP factory reset.

The version comes from e-manifest. The builder has no access to change it.
Only power builder are able to change it.

Again, my motivation to give you feedback was the recognition of your work.

The official ROM e-0.12-o-2020093076269-dev-herolte can be used in practice Galaxy S7 also runs excellently with LOS 17.1 including microG Services Core v0.2.12.20331 and receives monthly updates. From my point of view everything is okay.

But it’s not ungoogled. And that’s why we are here and not at LOS forum :wink:

/e/ OS is so dependent on LineageOS that LOS is always and everywhere an item.