Unsupported app! in App Lounge

Hi!

There is [at least one] app in the App lounge, for which :
1/ N/A button instead of download
2/ error message coming when selecting N/A button : " Unsupported app ! The app TCL E-ticket is currently unsupported. This is because the app is not yet widely released, or there is some other error "

In this case :
1/ How is it possible to know more precisely about what went wrong ? (does it come from the app developper ? MicroG services ?) (In this particular case, I downloaded Aurora store in my previous -google android- phone and the app was also not there, but only in the app store)
2/ Is it possible that in the future the app will be available ? How can we be informed ? Can we contribute to make the app available ?

I read that it was possible that some app couldn’t run proprely with /e/os :
https://community.e.foundation/t/list-apps-that-work-or-do-not-work-with-microg/21151
Is it still up-to-date with the App Lounge ? (for example Strava is available in the App Lounge and work, whereas it is in the section “not working with microG”)

Thanks for your help,

Phone : PH4
/e/os version : 1.2-20220726206059, Android 11

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I cannot explain your experience but I was able to download and open the app

That’s cool, the app works !
What smartphone do you have ?
What is your /e/os version ?

Thank you for your help !

My guess is that this is a bug with TCL (or with /e/, idk). You probably cannot see in this image but App Lounge is trying to download edit, actually spending time resolving them (I saw this “resolving” behaviour more clearly later on another search) all TCL apps.

I managed to get the “top” one with my old Samsung A3 (2016)

  • 1.2-beta.2-q-20220714203648-dev-a3xelte

That’s quite fun that all the tcl apps are trying to download at the same time !
From my side it’s a bit diffrent, the app does not appear, I must look up the tcl site and click on the download button which redirect me to the app lounge.

So it must not come from the app version, as it is the same one for both of us

Thanks for your help :slight_smile:

… that is strange … if I go to https://www.tcl.fr/ I am only directed to Google and itunes.

Do you really need the app anyway? Does the system not work ok in the Browser?

ah, new “unsupported” dialog. Introduced with Issue 178: Show alert dialog for unsupported apps (!115) · Merge requests · e / os / App Lounge · GitLab - checkUnsupportedApplication() was looking for if

(!fusedApp.isFree && fusedApp.price.isBlank()) and changed later to (!fusedApp.filterLevel.isUnFiltered())

I think you @luc_pcm run on newer app-lounge code than @aibd - and isUnFiltered() is tripping up on the App. Maybe worth a bugrep if it should not be filtered

2 Likes

Thank you Aibd, unfortunately, i believe tcl offers this functionality only with the application (no web app).

Ok thank you very much tcecyk, the bug is now reported in the gitlab here.

1 Like

my way of thinking in this is - the filter function is doing what it is supposed to do but is overly strict. TCL ticket seems to have paid functions (well, transport tickets), but is not a paid app.

I really haven’t looked into all details of what the Code tries to achieve (isFree / price.isBlank) vs isUnFiltered - maybe you can go in more depth and report back?

This explanation sounds good, because you are wright we can purchase the ticket directly on the app.
I will try to look at the code to precise the report, but I am a basic user, I don’t even know if I will be able to read it :sweat_smile:.
Is there a documentation or something to start ?

documentation for this is the merge request and its discussion, commit messages and function headers - probably the latter explain most. See the introduced enumeration for filtered apps that explains why “N/A” would be shown - issue_5720: create new enum class - FilterLevel (030e8f46) · Commits · e / os / App Lounge · GitLab

if we detect that the app is not downloadable for a region, we use [UI] level filter

this is what you see with N/A

now I’m unsure if the geo-restriction is enforced by the google-play remote and would otherwise be unexplained to the user why it is failing (so better show N/A) or it has legal reasons to not circumvent them, the MR doesn’t explain the reason, some issue links are internal.

1 Like

Ok so some restriction on the App makes it unavailble for users and this restriction could be lifted for the app
Thank you for your help !

but if the geo-restriction is enforced by the remote (Google Play), the code wouldn’t be able to do something about it but better warn the user. I think the georestriction hinges on the google account that you got assigned from a pool.

I think you could try to log out (in the App Lounge Settings) and relogin (and again possibly) until the app is offered to you?

Perhaps a stupid question but if the issue is that the apps is geo-restricted… Did you have enabled hide-ip function for advanced privacy which coule make you appear in another country?

Your are wright : my position was fake, my ip adresse also, and trackers blocked in app Lounge (default settings)
I’ve all turned to enabled,but the result is still the same

Ok thank you for the tips.
I relog out and signed in one time with my real google account,and with an other randomly attributed and each time it fails ! (And also on aurora store to compare)
I try also tried with my old smartphone [honor 9 lite - android 9] (connection on aurora store with the same google account) this time it works.
As the version is the same (v4.1.1(41)), I guess wether the issue come from a phone setting whether form the android version ?

So some more information, i looked up to the app description. Thé description is quite similar. The last update for both of them is on 25/11/2022
There is juste the config file which seems to be a bit diffrent (on x in the name and some kB of diffrence). May be because of the android version ? Can it be responsible ?
As the description also list some phone on which the app doesn’t work, it may also come form there ? (The NFC is availab’e and the FP4 is not on the list,but maybe it should be ? :slight_smile: )


(config file difference is fine, that’s a profile for the devices screen resolution)

It was easy to debug cleanapk responses, as the api was quite simple and required no auth.

To see the google play server response for the tcl eticket app would maybe explain why it is filtered. I guess the app-lounge developers have something setup for themselves to debug and make sense of a response.

You mean a bugreport file or something even different, specific for the App Lounge ?