Unsupported ZTE Z851 -- how can/should I 'test' /e/ on this device?

Hello everyone,

I have a ZTE Z851 from which I’d like to test /e/. Issue is, the Z851 is not currently supported. That’s okay, I’d like to experiment.

What is the normal procedure for testing /e/ on unsupported devices?

Build it for your own. There are some howto’s for building unsupported devices here in forum

Two methods :

  • Building the image yourself using the official script if your device is officially supported by LineageOS or this one if not

  • Using the GSI (Generic System Image) if your device is Treble-Enabled (shipped with Oréo or Pie) : GSI for not yet supported treble phones

GSI is no good idea, because it’s not a full e GSI. It’s only LineageGSI with e apps. The apply-patches.sh never works fine

So please don’t confuse other users

And regarding building, it’s unsupported, that’s what I have had answered him before

It’s a full ROM, Phie used /e/ repo instead of Lineage’s one to build the GSI. And the only problem is that the repo including apply-patches.sh isn’t linked in the manifest, I asked Phie to fix.

And GSI is built using a script like Unknown’s one but instead of using device specific sources it use generic sources.

A lot of people have tried to build the gsi but the patches are never applied.
Do you have build it with full patches applied ?

Ask Phie to know how did it, that’s not my work. As I know, he don’t used the phhusson script but the script from another person, script which use phhusson patches.

I have tried it and it does NOT work. So please don’t promote something you haven’t tried.

You have tried with your phone WHICH ISN’T COMPATIBLE, you also tried with others GSI which doesn’t work as well. The GSI is working for at least 5 different devices (see the XDA Thread) and the only bug found is impossibility to add a Google Account.

I din’t talk about where itvis work or not. I’m talking about it is real e-OS or not. I’m talking about building a full/real e-GSI and that’s what I have done. I have tried to build the GSI, but applying the patches never work !

So, I know what I’m talking about.

Try building for your own and you will see, no patches applied !!!

Phie’s method uses the official /e/ repo located on /e/ gitlab. Patches are applied because if they’re not applied, GSI won’t work on ANY device, there is only a mistake in the tutorial he gave.

Phie don’t uses the method by Phhusson but method by AndyYan which both two are applying phhusson’s patches.

For me that’s a real /e/ ROM except the fact that not all apps are included (like MuPDF or OpenOffice)

PS: I already tried, got error when applying patches but I was using Phhusson’s script so maybe AndyYan’s one is better, I don’t have tried.

I’m stopping here, because you won’t understand.
The e patches does have nothing to do with the e apps.

I’m still please you nit to promote something you never have tried for your own successfull. Thanks