Update from eOS R 0.23 to 1.3 leaves me in bootloader

I just tried to update my OnePlus 6 from (R) 0.23 to 1.3, following these instructions
Yet, when rebooting, the device gets into fastboot mode and I don’t seem to be able to boot the system. (The system seems updated at that point, as it says 1.3)
I luckily managed to get back into the 0.23 system, by booting in twrp, not doing anything there, and rebooting.
Any idea how I can update? Should I use ADB sideload?

most probably update the recovery

Ok, …which needs to be done via adb sideload? I won’t erase my data right…?

no sideload, just flash the boot partition with fastboot and a current recovery image for your device. I presume you’re on dev - /e/ image ROM download

See docs at

fastboot flash boot recoveryfilename.img

(dont own a enchilada myself, expected this to be “flash recovery” instead of boot partition. Please read the docs)

it will not alter userdata. Caveat being: as it is a a/b slot device, fastboot itself needs do be current to choose the active slot or - if you booted 0.23 earlier - the other slot, see docs

My idea is this being an outdated recovery.

While in fastboot, I ran

fastboot flash boot recovery-e-1.3-r-20220824212931-dev-enchilada.img

which flashed it to slot boot_b (since there’s no double underscore, my understanding from the “tip” in the doc is that I don’t have an outdated fastboot release, so it should be ok)
As explained there too, I also copied one slot to the other with
adb sideload copy-partitions-20210323_1922.zip
(I assume it copied b to a, as b is the active slot…?)
Stll the same issue, and now I can’t boot into my old system because TWRP has gone… :~/
I still can boot into recovery. Hopefully I can still save my system!?

Can you reflash twrp? Save your data while you can. Copypartition either over wrote 0.23 with 1.3 or the other direction depending on last selected slot

I folowed OnePlus 6 (enchilada) and managed to run TWRP with
fastboot boot twrp.img
but when I write it to disc (Advanced > Flash Current TWRP), and reboot, I only get to see the TWRP welcome screen, it doesn’t boot into it.
I didn’t disable the default data encryption, so I think I won’t be able to save my data if I can’t boot into the system anymore.
I’ve backups of most stuff, but it’d be quite a task to restore my system the way I want it…

I think it copied 1.3 over 0.23, because it says 1.3 in the /e/ recovery.
I tried all other versions, with no luck, only 0.23 is working, so I got back into my system…

1 Like

So, still curious if there is a way to update my system.
Also, I’m not sure if I understand the difference between the recovery system and the main system. When I update the system from within the OS, I expect I’m updating the main system. However, it seems to have the same effect with sending another recovery version with fastboot…?
If there actually is a “main system”, other than “recovery” can it also be manually downloaded? I only see the /dev repository with recovery images…

you can enable Seedvault to at least have a quicker recovery on a fresh+empty userdata when things go south - [HOWTO] use Seedvault early to understand Android backup - in the thread is a GUI way too.

I’m not sure my initial suggestion was good - If the boot from a 1.3 slot made it to the /e/ logo, then I think it’s not failing due to the boot/recovery image but some userdata “state”. If you had adb debug enabled while on 0.23 you could see logoutput then.