Updates on upcoming builds

…in addition to that useful hints from BigFarb: if you use Windows, you have to install the appropriate USB drivers first. From Linux it should work out of the box.

If you tried to boot from both slots about three times and always get this error someone else has to help you as I am also not really advanced in these issues … at all :smiley:
Apparantly, it sometimes helps to try booting from the same slot several times but that is the last thing that I know could work

1 Like

Sorry, I wrote it too quickly.

Now it restarted!

Thank you very much for your patience and help!

Just one last question, what about the current slot A? how to remove the corrupted file?




No need to remove manually - it will be overwritten with the next (hopefully functional) update…


Ok, I guess I will now look on the forum before installing an update!

1 Like

you’ll better do … :wink:

Which version are you at right now @PierryvesPadey ? So “before” the update

Now I have: 0.11-2020082870302

You had to try multiple times? This is important info for others, they sometimes stop after one try, what i totally understand :slight_smile:

Currently there are three different versions of the 0.12 build at:
I do not know which one is suggested if you look for updates on your phone, so OTA, but this morning I succesfully updated from 0.12-20200930… to the newest 0.12-20201029… an it worked perfectly smooth.

Yes, I had to try 2 or 3 times and then it worked, I don’t know why obviously!

1 Like

I am now a bit reluctant to retry in a short term perspective. Or I would like at least to get the slot A repeared in case It fails again!

Theoretically, every update you now install over the air will be installed into slot a and you should be able to return to slot b in case the update is broken. But I totally feel you for not being too fond to try it!

1 Like

Does it work that way? Isn’t it necessary to install microG as a system app? An OTA will also most likely wipe that installation, right?

It works, but of course as soon as you get an OTA update, it puts you back into the old version.

Will it be possible to disable the Contact tracing application ?

You do not have to deactivate a Contact Tracing Application. The misunderstanding is probably a result of some shrill forum members trying to stir up fear.

Even if the API is installed, you still have to install an app separately for anything to happen.

Furthermore, /e/ has a nice specialty in store for the paranoid: even the Contact Tracing feature of microG has to be installed separately in the future.

For details see this interview: https://community.e.foundation/t/microg-what-you-need-to-know-a-conversation-with-its-developer-marvin-wissfeld/


Some pictures …

I am still digging to find out why OTA update stopped working after my manual update from eOS preinstalled to oreo e-0.12-o-2020093076269-dev-herolte

adb logcat shows this kind of error messages:

11-08 18:35:43.310 4821 4821 W RecoverySystem: !!! REBOOTING TO INSTALL /data/lineageos_updates/e-0.12-o-2020093076269-dev-herolte.zip !!!
11-08 18:35:44.324 5063 5063 I /system/bin/uncrypt: received command: [–update_package=@/cache/recovery/block.map
11-08 18:35:44.324 5063 5063 I /system/bin/uncrypt: --locale=fr-FR
11-08 18:35:44.324 5063 5063 I /system/bin/uncrypt: ] (59)
11-08 18:35:44.327 5063 5063 E /system/bin/uncrypt: failed to set bootloader message: failed to find /misc partition

This is related to these gitlab issues I presume:

This will be a blocking point for people reluctant to use TWRP on a Chritmas gift :slight_smile:

Is there going to be a P-0.12 update on the FP3 stable channel? I am still on 0.11-20200831170821, i.e. from 2½ months ago.