USB interface not working (whyred)

Hi, I’ve been trying to connect my phone to my PC to backup files, and the notification regarding changing the mode to file transfer is not there. Also in “connected devices” settings, it shows not connected. Same for OTG: The device does not detect the connected pendrive.

Now I am using Wifi FTP server application to take out files from the phone, which is slow because I have to take out a 10 GB nandroid backup. Doing so because SIM cards of my phone are not working so reverting back to previous ROM for now.

Anybody else experiencing this issue?

Sorry, don’t know about that issue.
Short better workaround:
Start TWRP. When in twrp your device should shown in PC file explore and you can copy & past your files from phone to pc

Hi, welcome in our forum and sorry for the inconvenience.

Did you try to wipe cache, data, system and internal storage in order to flash /e/ again ? Maybe the SIM card will magically shows up.

What was your previous ROM ?

  1. Which Xiamoi model is involved?
  2. Which mobile phone operating system are we talking about?
  3. Which PC operating system are we talking about?
  4. Since when do “inconveniences” occur?

It was PixelExperience based on Android 9, and the /e/ ROM I was trying to flash was Android 8.1 based. Saw this post that tells the same thing I was experiencing: Redmi Note 5 pro - Camera not working and Sim card not getting detected , plus the USB issue. Unfortunately, clearing cache, data and system didn’t help

Apologies for being unclear,

  • I am talking about Redmi Note 5 Pro (code name: whyred),
  • trying out /e/ OS based on Android 8,
  • and trying to connect to a Windows 8.1 PC
  • inconvenience occour since installation (clean install)

Downgrading from Pie to oreo on a Whyred which has Anti Roll Back will cause issues. Not sure there are reliable methods to avoid issues when downgrading Xiaomi devices.

same think for me : i would try /e/ ROM on my redmi not 5 (whyred) but i can’t transfer anything through USB, only charge = is there a fix ??

Edit = solved

1/ from TWRP i’ve flashed official MIUI ROM which is under android 8.1 (

2/ After i’ve flashed TWRP v3.2 (for OREO and finally flash /e/ rom…now my phone can connect to PC

I have fixed this issue with an different wire

solved => i’ve edited my post

I’m a little confused. How could you flash all without working USB connection :thinking:

USB interface worked only under TWRP not under /e/ ROM