USB-Verbindung scheitert bislang

Auf dem Tablet Samsung Galaxy Tab 2 10.1 GT-P5110 läuft ein /e/OS 7.1.2 EspressoWifi, auf dem Rechner ein Ubuntu 20.04.4 LTS.
Nach dem Einstecken des USB-Kabels erscheint kein Icon.

Hat Jemand eine Idee ?
Beste Grüße Anno

Vergiss es. USB zwischen Android und Linux ist ziemlich aussichtslos. Das Problem tritt auch zwischen Android und Windows auf, eine ordnungsgemässe USB-Verbindung mit eigenem Laufwerk usw. ist es ja auch dort nicht, aber Windows löst es irgendwie, Linux nicht.

Es gibt unter Linux spezielle Software, die man probieren kann, einiges davon habe ich in diesem thread erwähnt. Aber so richtig funktioniert das alles nicht.

Unter Linux, ich hab’s gestern schon gesagt, ist ein FTP-Server auf dem Gerät eine schlaue Idee. FTP-Clients gibt unter Linux etliche, z.B. filezilla. Dazu braucht es dann nicht einmal mehr ein Kabel.

Andere Tablets/Smartphones funktionieren fehlerlos via LineageOS und Android per USB-Kabel mit Ubuntu.

Wenn Du Dein Tablet mit dem PC verbunden hast und die Benachrichtigungsleiste nach unten scrollst, erscheint da was mit USB?

2 Likes

IIRC ist die Standardeinstellung, dass per USB nur geladen wird.

Die Standardeinstellung kann unter den Entwickleroptionen umgestellt werden, sodass immer gleich “Daten übertragen” aktiv ist.

So war das zumindest bei meinem Gigaset GS290…

Wäre dann eben noch die Frage, ob Dein Ubuntu das MTP (MediaTransportProtokoll) beherrscht …
(aber wenn das bei anderen funktioniert, gehe ich mal davon aus)

Viel Erfolg!

-==[Schubsi]==-

1 Like

Deshalb habe ich erst einmal gefragt, ob es zu einer Reaktion des Gerätes kommt bei einer Verbindung. Im zweiten Schritt hätte ich dann ebenfalls die feste Zuteilung und Festeinstellung “Dateiübertragung” in den Entwickleroptionen empfohlen, zumal das auf einigen Geräten bei der ersten Verbindung ausgegraut ist.

1 Like

Ich habe auf “Linux Mint Mate” installiert (als sudo su [sudo mach mich zum su])
apt install adb fastboot android-tools-adb android-tools-fastboot -y
Dazu noch in Android die Entwickleroptionen aktiviert und dort als USB-Standard "Daten übertragen.

Damit hat bisher noch jedes Android per USB connected.

3 Likes

da das Ubuntu bisher mehrere Phones und Tablets USB-mäßig erkannt hat, war ich einigermaßen optimistisch, dass dies bei /e/OS nicht anders sein kann.
die Suche nach USB unter Einstellungen ergab nichts.
@Stefan76:
Nach dem Einstecken des USB-Kabels passiert auf Tablet und Ubuntu nichts.

erscheint da was mit USB?

Leider nein.

@schubsi:

Standardeinstellung kann unter den Entwickleroptionen umgestellt werden

wo genau ? Finde nichts in den Einstellungen.

MTP:
$ dpkg --list | grep mtp
ii  libmtp-common                         1.1.17-3                              all          Media Transfer Protocol (MTP) common files
ii  libmtp-runtime                        1.1.17-3                              amd64        Media Transfer Protocol (MTP) runtime tools
ii  libmtp9:amd64                         1.1.17-3                              amd64        Media Transfer Protocol (MTP) library
ii  libnet-smtp-ssl-perl                  1.04-1                                all          Perl module providing SSL support to Net::SMTP

@db91595:
> apt install adb fastboot android-tools-adb android-tools-fastboot -y
brachte keine Besserung.

Erst einmal, hast Du ein anderes USB Kabel ausprobiert? Nicht, dass wir jetzt mit Kanonen auf Spatzen schießen… :wink:

Um diese Einstellung zu aktivieren, musst Du auf Deinem Tabet die Entwickleroption aktivieren.

  • 7 mal auf Build-Nummer drücken. Evtl. mit Deinem Passwort/Muster bestätigen
  • unter System erscheint die Auswahlmöglichkeit “Entwickleroptionen”
  • scroll herunter bis zu dem Punkt “Standard-USB-Konfiguration”
  • drück da drauf und wähle “Dateiübertragung”
  • verbinde Dein Tablet neu mit dem Ubuntu System, nun sollte es als Gerät auf dem Ubuntu Rechner angezeigt werden.
1 Like

Vergiss es. USB zwischen Android und Linux ist ziemlich aussichtslos. Das Problem tritt auch zwischen Android und Windows auf, eine ordnungsgemässe USB-Verbindung mit eigenem Laufwerk usw. ist es ja auch dort nicht, aber Windows löst es irgendwie, Linux nicht.

Hmmm, merkwürdige Aussage von Dir.

Dock

Mein GS290 angezeigt in meinem Ubuntu Dock als “Gerät” (Out of the box)

gs290

Mein GS290 angezeigt in meinem Ubuntu File Manager als “Gerät” (Out of the box)

mfg

Stefan

3 Likes

Ich neige nicht dazu, Linux mit Ubuntu oder irgendeinem Desktop Environment (KDE, Gnome, …) zu verwechseln, wo halt irgendwas sofort geht und das ist dann die Lösung. Ich hab ein sehr schlankes Arch, bei mir mountet sich nichts automatisch.

Wenn ich einen USB-Stick einstecke, dann will ich den nach zwei Sekunden im /dev-Verzeichnis sehen und selber mounten (und später wieder unmounten) können. Ebenso würde ich das von einem Mobiltelefon erwarten. Meine Blackberrys haben das (trotz verschiedener Betriebssysteme) alle so gemacht und zwar völlig problemlos. Mein FP3 macht das nicht, auch nicht mit zusätzlichen Entwickleroptionen usw.

Und wie gesagt, die USB-Verbindung ist auch unter Windows nicht gewöhnlich, ein reguläres Laufwerk mit Buchstabe gibt’s auch dort nicht. Man kann zwar im Explorer Dateien auf diesen merkwürdigen Eintrag draufziehen, aber beispielsweise auf der Kommandozeile keinen copy-Befehl fomulieren.

Mich würde mal interessieren, ob auf Ubuntu bei Verbindungsherstellung ein neues Gerät im /dev auftaucht, es muß ja ein sdb* oder sdc* sein, und ob man dieses regulär mounten kann. Wenn ja, wäre mal zu analysieren, wie das geht.

1 Like

Andere HD mit Linux Mint Debian Edition 5 (brandneu).
Altes Homtom S16 per USB. Screen von oben nach unten ziehen. "USB - Für weitere Optionen tippen.
Auf Dateiübertragung an tippen. In Linux erscheint im Dateiexplorer unter Geräte “S16”.
S16 antippen und rechts sieht man “Interner gemeinsamer Speicher”. usw.
Anderes USB-Kabel in “SM G970F” zeigt jetzt unter “Geräte” dieses Phone …

Die meisten USB-Probleme werden von defekten USB-Kabeln verursacht oder verschmutzten USB-Buchsen oder Buchsen mit Wackelkontakt.

Bei meinem PC ist 1 USB-Buchse defekt. Diese wird von mir nicht mehr benutzt. Reparatur ist mir
zu aufwendig. Schließlich sind da noch einige unbenutzt.

1 Like

Nicht mehr, in der Anfangszeit von Android gab’s das. Hier ist eine plausible Erklärung …

“For information; Android now uses MTP rather than direct mass storage, because the internal storage layout of devices is now EXT4 rather than FAT32. And Windows or macOS can’t mount drives formatted as EXT4, not without installing third-party software. EXT4 is native to the Linux kernel that Android uses.”

MTP funktioniert auf Windows meist einfach fröhlich vor sich hin, und wenn dreist mal nicht (ist ja Windows), kann man es meist relativ leicht reparieren.

3 Likes

Du könntest Dir mal jmtpfs ansehen:

FUSE based filesystem for accessing MTP devices
jmtpfs is a FUSE and libmtp-based filesystem for accessing MTP (Media Transfer Protocol) devices. It was specifically designed for exchanging files between Linux (and Mac OS X) systems and newer Android devices that support MTP but not USB Mass Storage.
The goal is to create a well-behaved filesystem, allowing tools like find and rsync to work as expected. To enable certain Android apps to detect and use the transferred files, MTP file types are set automatically based on
file contents using libmagic.

Gibt es für Ubuntu als Paket “jmtpfs”. Bei Arch fehlt mir die Erfahrung.

~$ mkdir mtp-dir
~$ jmtpfs mtp-dir
Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
Android device detected, assigning default bug flags
~$ ls mtp-dir/
'Interner gemeinsamer Speicher'  'SD-Karte von SanDisk'

Edit:
Hier der Eintag für /etc/fstab um mount/umount nutzen zu können: Add instructions for usage with /etc/fstab

2 Likes

Vielleicht solltest du mal unter dem Dateipfad /media (und dann vermutlich dein Benutzername) schauen.
Da sollte dein Tablet sofern es eingehängt ist, auf jeden Fall angezeigt werden. Anderfalls könntest du versuchen, es mit Gnome-Disk-Utility (erscheint bei Ubuntu unter den Programmen als “Laufwerke”) einzuhängen.

@Stefan76:
Das USB-Kabel ist eine Spezialversion, habe nur eins.
USB-Kabel
Es ist jedoch unverdächtig, da erst vor einer Woche das /e/OS mittels diese USB-Kabels installiert wurde.
Zuvor funktionierte es unter Android einwandfrei.
Nach Aktivierung der Entwickleropionen erscheint dort der Menüpunk USB-Konfiguration auswählen mit folgenden Optionen:

  • wird aufgeladen
  • MTP
  • PTP
  • RNDIS
  • Audioquelle
  • Midi

Getestet habe ich MTP und PTP - ohne Erfolg.

Mir lässt Dein Problem keine Ruhe und habe mal bisschen nachgeforscht. Vielleicht bietet mein Link eine Lösung für Dich:

1 Like

Ich bin nicht der, der’s braucht. Ich bin nur der, der gesagt hat, einfach sei es nicht. Und das bleibt es auch mit jmtpfs - nicht einfach - mit einer gewöhnlichen USB-Verbindung hat das nichts zu tun.

@Anno69
“Galaxy Tab 2 10.1 GT-P5110 läuft ein /e/OS 7.1.2 EspressoWifi”
Kann? es sein “falsche” ROM?
In Smartphone Selector finde ich dein Device nicht.
Wo hast du deine ROM her (Link)?
Und ist deine Device-Model Bezeichnung korrekt?

1 Like

Inoffiziell vielleicht …

1 Like