Week 03 2024: Development and Testing Updates

You can refer this guide for gitlab access.


Hi Manoj,

Thanks for your weekly reports, which help understand what is going on “behind the scene”.

In that regards, I’m surprised that my FP3, bought on Murena, is still stuck on stable-s and not even planned for the OTA upgrade. Can you ask the team for mire info on that concern ?

Thanks and again, even without, I’m more than happy after all thoses years with eOS !

Here are some Infos:

1 Like

@solanum Thanks for your kind answer. I did see this information as well ; this is why, after several month of “to be planned”, I was looking for detailed informations via @Manoj ; if he had any.

Are there no tablets officially supported yet?

(I’m almost to 100% in moving off my iPhone to my /e phone and just started looking into a tablet to look at switching off the iPad too. :slight_smile:


We do support a few tablets as of now. You can set the filter to tablet and view them here


Hah; the filter on that table doesn’t work at all on either of the browsers I use on the laptop and I hadn’t tried it on my phone. :slight_smile:


Works fine on my Windows 11 Pro 23H2 desktop with

  • Firefox 121.0.1
  • Vivaldi 6.5.3206.55
  • Edge 120.0.2210.133

Could you share browser and OS details, so that this can possibly be examined by the team?
What does “doesn’t work at all” mean? Can the search options be made visible at least? (Doesn’t work if e.g. all JavaScript is blocked.)

That probably wouldn’t be a good use of anyone’s time; I run an older MacOS (though my Firefox is current) with a lot of content filtering. My experience is not going to be normal. :slight_smile:

(My /e/os phone is the only device I have that renders any Discourse site usably, for example. On my Mac, this site just shows the “e” at the top of the page and the text of the current post; none of the buttons or nav features are visible at all. And that’s in Safari with JS enabled; I haven’t even bothered to try it in Firefox with noscript.)

It’s really not worth trying to replicate most web site display issues I have. :slight_smile:

Thanks, though.

Hi @Manoj,
What is the meaning of the FP4 1.19.1 build for t-stable here? Does that mean we can have an upgrade OTA with 1.19.1 or should we wait for 1.20 as you said on this post?

The meaning is that you could install this build manually using the instructions given at https://doc.e.foundation/devices/FP4/install (which links to the download page).

No. This download page doesn’t indicate OTA upgrades to new Android versions. OTA upgrades, once available, arrive via the updater.

Thanks @AnotherElk, but still I don’t understand why the build is available for manual installation if the official message is to wait for 1.20 because all tests have not been made yet.


Ah, I see, this isn’t about OTA upgrades at all. I wondered, as an OTA upgrade to T isn’t even mentioned yet for the Fairphone 4.

Indeed. @Manoj … is 1.19.1-t-20240109372021-stable-FP4 an intentional release?
(The “S stable” link in https://doc.e.foundation/devices/FP4/install would need to be updated in this case, too.)


Let me check with the team and get back if the fixes and testing was completed ahead of time.

1 Like

FP4 Users Pl DO NOT DOWNLOAD the stable /e/OS T v1.19.1 build showing up on the updater or images server.
There is an issue due to which the build is showing up. I am checking with the team to remove this build from the server.
Pl wait for further updates regarding this build for the FP4

21 Jan Update
The build was visible for a short period due to an incorrect publish. The build has now been removed.
We will release the /e/OS T stable build for FP4 along with v1.20 as previously announced.
The ETA is February mid


Unfortunately I have already installed doe 19.1 on my FP4…but so far it works? What kind of problems should I expect? And then I have another concern…the calendar works so far, but every time I click on the search it closes…this has been the case for several versions…is this known? Will this be corrected? FYI…on the Samsung S7 the same calendar does not cause any problems.

The team had not merged their fixes to the v1.19.1 FP4 stable T build. Which effectively means the code base should be the same as the previous build. As mentioned earlier, there was an error on the server publish, which resulted in the build being displayed as available. Now the team has removed the image for v1.19.1. Sorry for the confusion. We will merge the changes and publish the v1.20 FP4 stable T build post a successful testing.


Thank you.
Are you aware of the problem with the calendar?

Is this issue similar to what has been reported here
Pl note this thread will be closed you can share your comments in the next update thread or on the link shared in the above statement

1 Like