Week 04 : 2021 : Development and Testing Updates

  • Last week we missed releasing the New Devices or the Upgrade Devices. The builds and documents were in place but the links to the images were not added

  • My apologies for the delay

  • This issue has been rectified and the links should be available now. Note the Mi Note 2 Scorpio build is still broken…Have asked the team to fix it.
    Update - the Mi Note 2 scorpio build image should be available now.

  • Please note for device upgrades you need to flash the Stock ROM for Android 10 first before you flash the /e/ OS Q build …this has been added to the documentation but is yet to be published.

  • The list of new devices being added and existing devices being upgraded this week is given here

New devices

Coming on Android Q
Xiaomi Redmi Note 6 Pro (twolip)
Xiaomi Redmi 7 (onclite)
Xiaomi Mi 6X (wayne)
Xiaomi Mi A2 (jasmine_sprout)

Devices to receive OS upgrades

to Android Q
OnePlus 5 (cheeseburger)
OnePlus 5T (dumpling)
Xiaomi Mi 8 (dipper)
Xiaomi ‘Mi 6’ (sagit)
Xiaomi ‘Mi Note 3’ (jason)
Xiaomi Redmi Note 5 Pro (whyred)
Motorola Moto G 2015 (osprey)
Motorola Moto G4 Play (harpia)
Motorola Moto X Play (lux)

Devices Dropped from official support list
Samsung Galaxy S6 -zerofltexx
Samsung Galaxy S6 edge - zeroltexx

(User can still build these devices as their code will reside on the servers. They have been dropped as the builds had stability issues. That being said we will continue evaluating all these devices and if future builds look stable then the devices will be back in the supported list.)

Build v0.14 -

What is in this build :
- UI changes across default applications.
- MicroG version updated to v0.2.16.204713
- Maps updated to v7.1.21.1.3613AA78.047032E6
- OpenKeyChain updated to v5.5
- Q security patches for January 2021
- Pie security patches for Jan 2021
- Misc LOS code updates
- Read the release note.

Important notification for MicroG

The new microG version add some improvement in the Exposure Notification API. Unfortunately, the update we shared on Apps doesn’t apply automatically. To apply it manually, you have to:

  1. Open Apps
  2. In Search tab, search for microg
  3. Tap on Update

If you apply the v0.14 update before having update microG, microG EN will be uninstalled. In case it happens, follow these steps:

  1. From your device, download and install manually microG EN version:

Be sure we will do our best to avoid this inconvenience in the future!

Issues in v0.14
We will remove the v0.14 build for the a5y17lte.
Will revert to v0.13 for the Samsung A5 (a5y17lte) to avoid issues to users. Need to figure out what happened as this build was tested.

  • The LeEco s2 build v0.14 build will be released shortly.

Fix for v0.14 update not applying on the GS290

  1. Requirements: fastboot
  2. Download the last recovery version: recovery.img (sha256sum)
  3. Reboot your device into bootloader adb reboot booloader
  4. Once in the bootloader, flash the new recoveryfastboot flash recovery recovery-e-0.14-q-2021012698290-dev-GS290.img
  5. Once done, reboot your devicefastboot reboot
  6. Now the update will apply without any issue

New Devices and Upgrades
Still to be released for this week.

Will update as more inputs come in

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

9 Likes

I am a little bit confused:
Is 0.14 released or not? On twitter it is announced (https://twitter.com/e_mydata/status/1354485167960829952, but the updater doesn’t offer it.

Edit: twitter was faster than the updater, but now it shows up.

Yeah, q0.14 shows up as OTA. I’m a bit worried: after my last OTA I was forced to reinstall from scratch… Has anyone been the brave?

Yes, I was brave and so far everything went well on my FP3.

6 Likes

Can confirm everything works smoothly on my FP3.

I only had to manually reinstall the exposure notification API, as indicated in the release notes. Didn’t loose any recorded encounters in the process.

2 Likes

On my a5y17lte I ran into a boot loop. The device restarts even before the /e/ logo appears …

Update: I manually flashed e-0.13-p* without wiping anything and have my old system back without the need of reinstalling everything …

Hi @weichselbaumj did you try to manually flash the 0.14

Hi @Manoj, I just tried it with adb sideload, same result (boot loop). Maybe it would work with complete reset incl. wipe, but due to lack of time I’m currently not able to test it.

The 0.14 has been pulled for the a5y17lte has been pulled from the servers.

Is this update just for die FP3? Because my FP3+ doesn’t show any new version in the system updates.

The same build goes out for the FP3 and FP3+. Will ask the team to check on the FP3+

2 Likes

V0.14 installed on moto G7 and all good. I did notice the update message displays you are installing v0.13 Jan 26th 2020. The same happened for the December update it listed 0.12 instead of 0.13. Bit confusing to see.

On a separate issue Aurora App store has stopped working in the last few days. I uninstalled and reinstalled and it is stuck on the login successful screen. This is not related to v0.14 update.

Update: Go to Settings, Network and Enable custom tokenizer in Aurora Store app. Exit the app and you should be able to connect.

This fixed the issue.

1 Like

After the install what version do you see when you go to system updates

Are you on the dev or the stable build ? You can check what the version details say under System Updates in Settings

Hi Manoj,

This version looks fine once installed. It was more the install confirmation message displays v0.13 is about to be installed instead of saying v0.14.

Screenshot_20210128-112221_Updater

1 Like

All good on my FP3 as well.
The UI consistency is not working though.
The Files app is dark theme but the header and nav bar are light.
The calendar used to be dark theme and is now light.
Contacts and phone remained in the light theme.

In system updates it just says this:
Screenshot_20210128-123812_Updater

Under About this Phone it says:
e_FP3-userdebug 10 QQ3A.200805.001 eng.root.20201214.232210 dev-keys,stable-release

This is the stable build. The release to the stable channel will happen next week . To read about the differences between the builds check the document here.

2 Likes

The message “Install update” shows /e/OS 0.13 26.01.2021 on FP3 for me too.Screenshot_20210128-134101_Updater
EDIT: but after install, the system is q0.14. :wink:

3 Likes

What is the status of Xiaomi Redmi Note 8t? I understood earlier that it was supposed to receive officially supported version.

Any update on this device?