Week 23 : 2021 : Development and Testing Updates

Testing of v0.17 : In progress.

List of items resolved and being tested

  • Issues during testing -
    Builds failed - Investigation still in progress for some devices like mata

  • microG - issue was resolved with a fix…there are a few updates to microG as part of v0.17. Users will get the updated version once v0.17 is released.

10 June Update We are planning to release v0.17 for all users later today.
Nougat builds have been published, Oreo builds being released, Pie and Q to follow.

11 June Update v0.17 has been released for all dev users. All supported OS builds have been released -
Which means you should be able to receive the v0.17 nougat, Oreo, Pie and Q build as applicable for your device.
In case your device has not received the build pl let us know.
Stable builds of v0.17 will be released early next week.

To understand difference between various /e/ builds check this guide

OS OTA Upgrade: Delayed

Testing has been delayed by a month. As we are working on adding location specific firmware to the build.

New Device addition : Delayed
As we have a backlog of devices from week 21, 22 I am holding the release of Week 23. No point in adding to the backlog as there are devices from the previous week still in the queue.

The reason is we need to add the device specific files to the /e/ build system. Our ROM Maintainers do not have this access as yet to do this themselves. There were some modification to the build system which was due last week on Friday. Do not have an update if they went through.
The developer who was assigned to work with the Maintainers was busy with the next task in this list.

  • Devices planned for release : LG G4 (h810_usu) , LG G4 (h811) , LG G4 (h812_usu) , LG G4 (h815) , LG G4 (h815_usu) , LG G4 (vs986_usu), Samsung J5 (j5y17lte)

Teracube 2e encryption: In progress

Developer is still working on this.

  • 9 June Update The encryption post install on the 2e is solved as per an update I got yesterday. Will share more details on this.

Recommendations for preinstalled /e/ phones
A post with recommendations for Preinstalled /e/OS phones has been added to the forum. This list is specific for US and Canada.

All points will be updated during the course of this week.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


I’ve built and am using v.17 on mata. The first build failed and gave me a vendor error. Added ( -e “INCLUDED_PROPRIETARY=true” ) to the script and build completed. Thanks to everyone at /e/ for the work they are doing.


Thanks, sharing this info with the build team

Is the “chrome invalid certificate” issue solved when using web logins like in Amazon Alexa app? Also, some apps come back with error after fully displaying what they are supposed to (like Wells Fargo banking app, Amazon shopping and eBay app)

Yes! :+1:
I was patiently waiting for this update…


Confirmed working.
These apps are now working on version 0.17 using Galaxy S9+

Great job!

1 Like

Thanks for the update. There were some fixes made to microG as part of v0.17. That being said it is an ongoing battle. Based on user feedback and testing we will be undertaking more bug fixes.


Excuse me, but what about jfltexx ?
there is no more mention of that efficient and last self reparable Samsung device in the official supported list.

EDIT : i have found the 0.17 build manually writing the adresse: /https://images.ecloud.global/dev/jfltexx/
but it disappear from the official device list for a couple of month.


There is no official serranoltexx since e-0.13-n in December 2020


I received a notification that there was an update (0.17), so I downloaded and installed it.
However I got stuck in TWRP, every time I tried to Decrypt Data it failed.

Failed to decrypt data.
Unable to decrypt with default password. You may need to perform a Format Data.

After giving up on the password it seems the process continued (it happened so quickly I couldn’t catch the processes). It almost looked like it was loading a recovery or back up, so I thought I would end up back with the stock ROM, but to my surprise the update worked and the phone booted into /e/ and under System updates it says 0.17.

Just thought I’d share my experience and hopefully you can help me confirm that the update was a success and I have nothing to be concerned about :slightly_smiling_face:

Any news on the arrival of Q for sailfish?

Update on FP3 went smoothly. Thanks!


Moto G7+ update to 0.17q was smooth as can be.

For anybody to confirm that you would need to say which device you have exactly :wink: .

From your description of the process I don’t see anything wrong concerning the update.

  • TWRP tries to decrypt an encrypted data partition … that’s normal.
  • The data partition isn’t involved in an OS update, so you can cancel the decryption attempt at the password prompt or TWRP doesn’t even manage to decrypt because TWRP doesn’t support decryption on every device … no issue for the update here either.
  • After that TWRP would usually run the OS update … this seems to have worked for you.

Define quickly.
TWRP will give status messages, they will include something like “patching system image unconditionally” as far as I’ve seen, and this process will run for a moment … but how much time this would need exactly might heavily depend on the device, and whether this could be called quickly then might depend on individual perception :wink: .

The version 0.17 is not available for my FP3, today I have the version 0.16 (Android 10), nothing happens when I search for new updates

1 Like

“released for all”
Does that mean for “stable” release channel or for “testing”. (also no update to 0.17 on my FF3 stable)


The update was published on the dev-channel. If you purchased your Fairphone via the store or used the easy installer you would be on the stable channel and receive the update in a couple of days.


Updated and added details in the initial post


Ran system update on my Samsung Galaxy A5 and it went smoothly and extremely quickly. Took maybe a total of 15 minutes to download and install. Only been using /e/ for about 2 weeks now but everything has been great so far.

Thank you for your response @AnotherElk.

Relieved to hear that the Data partition isn’t needed for the OS update.

I have a Samsung S9. I would say the command line update ran for a minute or less. Then I think it rebooted.
It seems to be running alright, so far so good :blush:

Hi. V0.17 working well on dipper. Thanks very much. OTA update failed as it did for the past few releases. Completed without issue via Sideload. Many thanks.