When phone is trying to connect to known or open wifi, it already terminates the mobile connection

I’m running e/OS 1.21. But I have had this issue as long as I’m using e/OS, hoping it will be fixed with the next update.
So I am using the internet over a mobile connection, but each time when I come in reach (while riding, walking etc ) of an open or known wifi connection, e/OS tries to connect. This is ok. But often such a connection still requires some consent or info through a login webpage that opens. So as long I am not consenting or providing this info I am not connected to the wifi, but e/OS already drops the mobile connection.
I find this annoying. I am surfing while on the train or walking and when briefly in reach of a known or open wifi (which I don’t want to connect to as I am just passing by), I loose my internet connection. This doesn’t resolve itself quickly, I even feel e/OS gets confused (wrong icons). I generally have to manually disable wifi. Or toggle the mobile connection.
I feel this is standard behavior so others should have the same experience. Correct?
Why doesn’t e/OS wait until a wifi internet connection is successfully established before dropping the mobile connection? So when I don’t want to go through the trouble of filling in info on a login webpage for the open wifi, I am still using mobile and don’t notice any interruption.

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

I do not see this behaviour but I have set Network preferences

  • Toggle on Turn on Wi-Fi like at home.

  • Toggle off Notify for public Networks.

Settings > Seach feature > Network preferences.

1 Like

You could try the following …

If not done already, make the Developer options visible by tapping on the Build number in Settings - About phone a few times until you are being declared a developer.

Then enable Settings - System - Developer options - Mobile data always active … in case it’s disabled.

The description of this switch is “Always keep mobile data active, even when Wi-Fi is active (for fast network switching)”.

1 Like

@AnotherElk Thanks. “Mobile data always active …” was/is active.

1 Like

@aibd Thanks. These settings were already as such.

This topic was automatically closed after 30 days. New replies are no longer allowed.