When trying to use wifi calling while connected to wifi, phone asks to connect to a wireless network

I have a strange problem with wifi calling.
/e/OS 0.20-20211215151800 Android 10 Motorola XT1965-T
/e/OS 0.20-20211216151963 Android 9 Le X522
Both phones have the wifi calling option, and I am using T-mobile network using Red Pocket MVO in the U.S.(which worked fine on my Googled XT1965-T.)
Both phones give me the same error:
“Mobile Network is not available. Connect to a wireless network to make a call.”
I also tried using wifi calling on Red Pocket MVO on ATT network, but neither gave me the wifi calling option, nor did I have the option on my Googled XT1965-T phone.)
It didn’t work on the previous versions of /e/ either, but I didn’t have time to verify all of the settings like I did today.
Any help would be appreciated.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I have the same issue with a Fairphone4 on /e/OS 0.21-20220112156786

Unfortunately, I have not found a solution, nor have I got any suggestions to try.

I have the same issue with a Fairphone3 on /e/OS 0.21-20220121158536

Is the development team reading this or would it be better to create an issue on Gitlab?
Unfortunately, I can’t create issues on Gitlab because Gitlab doesn’t accept my mail address.

Hi @waldhaus, welcome to the /e/ forum. Just that point, “I can’t create a GitLab account” is known and answered here I can't create a GitLab account - #2 by Manoj

Getting Started on /e/OS

Hi @aibd, Thanks for the tip, but with a different domain the registration worked.
Issue is open:

I would like to add my device to the mix…exactly the same issue with a Sony Xperia XA2 Pioneer on the latest V1.0 build of R /e/OS 1.0-20220527188878
I have had e OS on this phone for several builds of the Q release and only recently updated to R.
WiFi calling has never worked and I was not all that worried as I have an EE signal box in my house so always have a signal if broadband is up. However, EE are shutting down the signal boxes and telling me to use WiFi calling instead!
I have gone through all the posts in the forum touching on this subject and this one is closest to my issue. The phone does not seem to be aware that it is connected t the WiFi network when placing calls as it asks me to connect to a network :slight_smile:
Other than this, the R build works well.

Good report @jpirie.

There is a choice of issues on which you might report it. It would help many users to get this to become a resolved issue.

See also WiFi calling not working

Hi albd,

Thanks for the reply. I went to the suggested link on GitLab but, it seems I cannot register an account to comment as it tells me, and I quote:

1 error prohibited this user from being saved:

  • Email is not allowed for sign-up. Please use your regular email address. Check with your administrator.

I am not sure why it say this because I only have one email address…unless I am expected to use my e.email address for this site?

Just thought of that but, you would think it would say so on the form?

Any thoughts?


Please follow the further guidance here Report an issue #error message


I saw this a little too late and just registered with my e.email address!
Means to an end I guess. Thanks for your help.


Hello again,
I have tried three times to add my issue to this “project” on Gitlab and there is still no sign of it. I am obviously doing something wrong but I have no idea what.
I click on the “add an issue to this project” link under the other reports. I am given a special email address to send my issue to, I send the report I have placed above to that address and…it sends and never gets bounced back. However I do not see my report in the list when I go back days later?
Someone, somewhere is receiving multiple reports from me and I know how annoying that can be!
Anyone got any clues what I might be doing wrong?


Is it because the link above is a “search” ?

If you were to read each open issue in the search, then decide if you want to add a comment to one issue. Adding a comment to the closest issue to yours is probably the best way to go.