Where do I find Murena's Terms of Service?

Is your wifi name hidden? I do that on mine, and Id like to say there was some weird setting I had to change to get the internet to work on mine. Reaching back a ways because it was a while ago I set it up.

I’m running a terracube 2e though. Different phone.

Are the date and time correct? – it is said to be a frequent cause of “connected, no internet” and cycling the toggles may be a fix in itself.

I never had a problem removing a device blind! But you do get a clue if you can see if the device is active. Sometimes a router can reissue an IP address in error, and that IP address needs to be deleted.

I don’t think you need to worry about backing up the router – after all, it is designed to “just work” when any new device is introduced to it with correct password.

Together with your router manual you might follow up if this is an exact match with your device.

On your phone go to Settings > Network and internet > Internet > Select your Wi-Fi service provider.

Here you will find Network details (you probably already did this) but there are a number of things that may or may not be a fit with your router, so you might write down all those details from the phone and check they are either an exact match with the router report, or are part of the router “way of doing things”.

Some further details which you could change on your phone are revealed after you “Forget the network” now under Advanced options before you re-enter password.

One variable to check with your router manual is does the router offer DHPC or static. As long as you remember what you changed you can experiment with changing this before you enter password, to see if it changes anything.



According to published builds https://images.ecloud.global/stable/starlte/ you are not even on latest Android 8 (Oreo), there was an e-0.20-o-20220118158074-stable-starlte and then being a stable build you should have been offered an OTA Android version upgrade.

So I think it would be worth checking out this suggestion

Issues with the Updater and a solution.

if only to check what changes … :slight_smile:

@Manoj, please could you clarify, when an OTA upgrade (from quite a long time ago) is marked “completed” does this mean that the OTA service itself is no longer available? Thanks.

To optimize storage space, the images server keeps only last few builds. It is usually last 5-6 builds for most devices. When new builds come up the last ones are removed.

1 Like

Yes, I checked the date and time, and toggled these options - they seem accurate.
I have removed a device from the router that I don’t recognise (probably my neighbour’s device), and that hasn’t changed anything to my phone connection.
The IP address on my phone matches the one the router shows. It’s on DHPC, and when I tried to change it to ‘static’, I then wasn’t given the option to ‘connect’ after I put in my wireless password, so I couldn’t try using the static.
I was going to try resetting the router, but what you’ve written about versions and builds has gone over my head. Are you thinking the issue is not about the router? I have just toggled on my mobile data, to see if I can access the internet, and the LTE sign comes on, but with a ‘x’ next to it, and when I go into my browser it tells me there is no internet connection.

The connection issue is something to be fixed for sure, one way or another.

But there comes a point where it might become too difficult to debug a “no longer maintained” build, so I was starting to look ahead to the next options.

OK, I’ll try a factory reset in a short while, and report back. Thank you.

Factory reset has made no difference. My phone continues to be listed as connected to my router’s wifi, but ‘no internet’ is still there. The ‘x’ next to the signal emblem still there.
Yet - and I didn’t try this before, even though at the top of my phone screen, when I am in my browser, it says ‘No internet connection’, when I look at the pages already open, such as my email accounts, I can see new emails, sent just a few minutes ago. I’ve just sent myself an email just now, and I can see it on my phone. Weird? Does this mean we can try and upgrade my phone after all?

Sorry - you did ask me to see if I could access the internet with my phone browser, and I just assumed I couldn’t because of that message at the top of the screen. I realise now I should have tried.

Great, you got there! Now back up all your stuff!

You’re probably best updating using the easy installer.

https://doc.e.foundation/devices/starlte

I upgraded by using the system updates in my phone. The first page to present itself is ‘Debug info’. Below that it says ‘ZIP archive, contains debug info and logs’, then ‘share archive’, and then an excalamation mark with ‘InterruptedException, An unexpected error has occured. View debug info for details’. When I ‘view details’, and open with ‘Browser’, a page appears that says ‘Your file couldn’t be accessed’.
So I don’t know what to do about that.
The good news is that my phone is showing as connected, and the emblem for that is clear with no ‘x’ next to it.
It also looks like it’s kept some of my stuff (contacts, files etc.).
Before I upgraded, I kept getting a box appear, that said that ‘microG Services core has stopped’. I now have a message about microG Services Core: An app on your device is trying to sign in to a Google account. If this was intentional, use the Sign in button to connect to Google’s sign-in page. If not, press Cancel to go back to the application that caused this diaolg to show up.
I don’t know what microG Services Core is, so don’t know what to do about that either.

I had that this morning, don’t worry unless it becomes frequent, it may happen from time to time, in your case, if you just upgraded suddenly this could explain “an unexpected error”.

There is a surprise! So to what level have you upgraded as shown in Settings > About phone > tap on Android version > long press on /e/OS version in order to "Copy to clipboard.

It is an important part of the /e/OS system, very loosely speaking, to avoid direct contact for the user with Google, but still allowing sufficient “filtered” contact to allow the system to run the way it does. Better explained here, microG - What you need to know, A conversation with its developer : Marvin Wißfeld.

If you have upgraded two or more Android versions you may have apps that cannot survive the change, so you should be prepared to have to uninstall one or two if you get indications that they are failing, then install them again after the phone has been restarted.

Quite a few people use the app Cache Cleaner directly after an upgrade to automatically clean the cache of both system apps and user installed apps. Again this would be useful to you if you you have jumped two or more Android versions.

Thanks for the reassurance, and the tips.

I’ve upgraded to Android 11. The version is 2.0-r20240506399551-stable-starlte

I’ve chosen a Cache Cleaner and installed and opened it, and followed it’s instructions, but I’m not sure if it’s doing anything.

1 Like

It will be clear when Cache cleaner is working! The app is very careful in getting you to give all necessary permissions and it may not seem very intuitive the way you are led to give a certain permission, then you have to use the back button to get back to the “main event”. Now you are guided to give several more permissions and find your own way back before work can start.

I have clicked a bit more, and I now have a page with ‘Clear cache’ at the top of it, followed below with a list of everything on my phone. Then there’s two buttons, one with a tick, which when I click on it, it adds ‘(1.09 GB)’ next to ‘Clear cache’, and ticks all that is listed below. And a broom button.
I don’t really know what a cache is, or how to proceed. Sorry.

A rather simplified view. Cache is a store of incidental data used by the app to produce its results. It is often reused when you perform the same task next day. However it can become time expired and the store is no longer called upon but fresh data downloaded and added to the cache. In the natural cycle of things the cache will help the app to work faster. However many apps when you upgrade might almost abandon the previous cache and start straight off adding more data without deleting the old!

The tick button selects apps to clean. I just select all. The broom icon starts the clean of all selected apps. I have found no downsides to clearing the cache of everything.

The cache is not the same as stored data, it is transient data that might be worth keeping “for a while”.

Thank you very much for your time and help, aibd (and others here). I’ve done the cache clear-up now, and I suppose I will just have to see how things go over the next day or few. I’ve switched off the phone and switched on again, and it all seems absolutely fine. I’m relieved it went as smoothly as it did, and I will be keeping things updated/upgraded from now on (I hope!).

I next want to find out how to keep my electronic ‘stuff’ safe and in good order, both on my phone and on my PC, but without having to spend loads of time learning the technical side of things. I am a light user after all. I am thinking along the lines of one password for all my passwords, which means finding ?apps? that are compatible between both my e/foundation phone and my PC (currently MS Windows, but that I hope to change to Linux Mint). If you can point me in the right direction (perhaps there’s already a thread on this forum about this - but I am not sure what the jargon is to look it up myself), please do let me know.

Thank you again so very much.

So pleased to hear that it worked out ok in the end!

So I think the subject here is a password manager, not a thing I use, but here is a forum Search for password manager.

Did you resolve the “original issue”,

Seems important not to have your cloud account deactivated now! The Murena cloud will provide a useful backup of a number of things not found by Windows by USB cable.

Windows is currently finding things in Internal storage but not the saved contents of apps. I am not a Windows user but I have noticed this being recommended.


Here are some suggestions for some reading on Murena cloud.

Search Support topics unsure, maybe this is useful? https://doc.e.foundation/support-topics/e-cloud-e-email-account

Search community HOWTO List of HOWTOs & add your suggestions perhaps starting especially at the section /e/cloud & /e/mail & account.

While at first sight this is the opposite of what you want Disable /e/Cloud's automatic sync of Contacts and/or Media (Photos and videos) images show some of the settings to turn sync on and off. I suggest, if some sync is currently off, you do not turn everything on all at once.


I think you can have this dealt with automatically using:

Alternatively, the best way to deal with it is to share the .zip archive with your PC by email. On your PC you can unzip the file the read the enclosed text with maybe “Notepad” or your default text editor.

Lots to read through, think about, and do. I will try and get it all sorted over the next week or few.

Regarding the original issue with Murena, I wrote to them last week and am awaiting a reply. I only rarely used the Murena email because I found the emails I tried to send either never arrived to their destination, or arrived after weeks of sending. I’ve just sent myself an email from Murena to a different email account I have, and it is showing in the Murena ‘outbox’ rather than ‘sent’. I will read the links you have sent though, and try and work things through.

Thank you again. I really appreciate your expertise and the time and trouble you have gone to.

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.