Which default Weather service in /e/?

However, the Yr.no app has a load of trackers, mostly the Google arsenal (AdMob, Firebase, Crashlytics, etc), plus one called ComScore.
But the API is just that, a public API, by a publicly funded, scientific institute. No strings attached.

I just updated to /e/OS 0.11 (appeared yesterday) and weather seems mostly fixed!
The widget gives plausible results, the app is not flying to London anymore but was properly located upon update reboot. Pushing the localisation button still gets the app to spin forever, but heck! I see considerable improvements already.

Hmmm, I might have been overoptimistic above:
The temperature of the day does not evolve in neither the widget nor the app. It sticks at early morning value… (sigh)
The app seems to update if I do it manually (refresh), but the updated value does not propagate to the widget.
I’ll see tomorrow whether the 5-day forecast gets updated or sticks to whatever it shows today.

Weather in 0.11, continued:
Temperature of the day is still broken in the widget, it never changes. As for the forecasts, the jury is still out, I’ll see during the next days.
The app seems to give better results for both current weather and previsions, but its automatic refresh does not: Set to refresh every hour, its “Last update” time shows it is not. It has to be manually updated.

Thank you for the news @Filofel.
I will continue using my national weather app, as a lot people do!

Yeah, looks like a good strategy: :slightly_smiling_face:
I confirme the widget is still completely broken.
The day names shift, but the data stay exactly the same from day to day…

At home, I normally use a combination of the Norwegian YR.no, Swedish SMHI.se and some US weather service, which together gives a fairly good prognosis. Still, I would like to be able to choose from more than only one. Those Scandinavians have never given a very good prognosis for, say, the Latin Americas.

Hmmm… Strange.
This morning, the widget showed proper current temperature and valid 5-day forecasts.
I haven’t done anything special.
Looks like the widget randomly updates once in a blue moon…

Hi @GaelDuval,

You have opened this topic and received a lot of opinions and advices. I feel that most people are not satisfied with OWM since it is not accurate at all. As I said earlier, each national weather service probably has more accurate forecast than a “universal one”.
I am not familiar with how decisions are taken within e.foundation but I would appeciate if you communicate something as you have firstly asked a question. Any answer will be good, i.e:

  • we think OWP is good and will keep this app
  • we are too busy on other subject at this moment and may not reply
  • we have chosen another app for a future release
  • we will remove weather app et let users choose one
  • we will keep OWP and help them to make it work
  • those thinking OWP does not work just don’t know how to parameter the app correctly
  • we never give any type of answer on this forum (read this “link” to understand why)
  • etc.

Thank you in advance for any message!


The open weather app is different to every other weather provider I can find for my city so, yes, it isn’t accurate. Also the default e app is useless to me because it doesn’t provide an hourly forecast. People need to know roughly what time it is expected to rain or how long it will be sunny for etc. This is why hourly forecasts exist. Why you don’t have it in the app is beyond me and the fact that there isn’t an easy way to delete it and its widget is very frustrating.

To my surprise, I couldn’t find this question is this or any other topic (but maybe I’m not very good in searching the forum).:
Why is the Wheather Widget/app obligatory?
I don’t want to know anything about the wheather and it’s annoying to have to see it om my startscreen all the time. It appearantly uses data and energy on my phone and I want to get rid of it, but that doesn’t seem to be possible. I can’t imagine that this app is needed by the OS to work properly, so can anyone enlighten me please?


See this post for details of how to remove the widget

Yeah, but why are a weather app and widget there in the first place?

I’d like to have the smallest number possible of default apps, and certainly no weather app nor any weather widget.

1 Like

Because /e/ (according to the /e/OS page of their main website) believe that, for their target audience

…apps and online services are crucial components of our everyday experience, too.

So, /e/ includes

… a set of carefully selected default apps to cover your most common needs, personal and professional: get you email, plan your week ahead, chat with your friends and coworkers, browse the web, check the weather, check your itinerary for your next meeting…

Yes, but you are not who /e/ see as their main target user. You are clearly capable of removing stuff that you don’t want, and this is pretty easy to do with a little bit of technical knowledge and experience

1 Like

Disagree; it’s certainly a lot easier for anybody to add an app/widget than it is for me to go through the pains to disable one.

1 Like

I disagree completely. I bought a Refurbished Samsung S7 with /e/ preïnstalled on it, because I wanted to support /e/ in this way. I don’t usually root phones . Having to install ADB (whatever it means) on a pc is not my cup of tea. /e/ wants to be an os for others than geeks. A widget most people don’t want and that can’t removed without more advanced knowledge of how mobile operating systems work, isn’t helping that objective. It is simply annoying.
By the way, thnx for your reply, Petefoth. I’ll see if I can find someone to help me with this.


OK, I tried installing adb on my laptop and when I allow USB debugging on my device, connect it to the laptop and run the command adb devices it finds a device:
List of devices attached
ce021712214b7e1105 unauthorized

I’m not sure if something is wrong with the fact that it says “unauthorized”, but when I run the command line: pm uninstall -k --user 0 foundation.e.weather
I get a failure message:
‘pm’ is not recognized as an internal or external command,
operable program or batch file.
After a Google search I find suggestions that ADB is not running, but then my device would not be recognized or would it?
Any suggestions?

Look at your phone, it should be prompting for a confirmation :wink:

Thnx, I think I did confirm, but I’ll try again.