WiFi calling not working

I have two Emerald 2e’s, one with stock Android and the other flashed with /e/.
I’m using T-Mobile through Red Pocket and the same Red Pocket APN for both phones.

WiFi calling is working on the stock Android phone, but not on the phone with /e/.

I have a good WiFi connection, WiFi internet is working well.

WiFi calling is provisioned and enabled under WiFi calling.

When I check the IMS Services Status on the phone with /e/, it shows IMS is registered, VoLTE is available, VoWiFi is unavailable, and both Video Calling and UT Interface are available.

Has anyone else had issues getting VoWiFi working on their 2e?
Is there a setting or something that I’m missing here?

Any help is appreciated,


A post was merged into an existing topic: I’m pissed off with /e/

Update: I have opened an issue for this on Gitlab.

I was hoping to get back here before the thread closed.

I mentioned before that I had no internet from 2014 to late 2020. As a result all of my phones used just cellular data, so never had a chance to do WiFi related stuff (other than occasional tethering). After the last conversions and me not knowing much I figured WiFi calling just didn’t work on my phones with custom ROMs or maybe non-certified devices. Not sure.

Fast forward to a few days ago. Went to the T-Mobile website to pay my bill. Decided to check out their help and support section, just because. Under WiFi Calling there was mention of needing an e911 address associated to a device. That was the case for my old daily driver but not for the other devices. So I did that though not sure it’s really mandatory. Figured it was now time to really figure things out.


  1. OnePlus 8T+5G, Android 11, Carbon ROM. (A T-Mobile purchased device - KB2007 kona. “Rebranded” to KB2003 kebab, allowing for flashing ROMs and recoveries). Carrier T-Mobile.
  2. Moto G5 Plus potter, Android 7 Nougat, LineageOS 14.1 Unofficial. Carrier T-Mobile. Daily driver. Multiboot with three other ROMs so also tested Tesla and Carbon.
  3. Essential PH-1 mata, Android 9 Pie, /e/OS. Carrier Mint Mobile.
  4. Teracube 2e, Android 11, /e/OS. Carrier T-Mobile.

Last time I tried WiFi calling I thought it was working. In the feature’s options I had WiFi preferred for calls. When a call went out I thought it was good. Read recently that if you have a strong cellular connection then calls would still go through that and not WiFi.

Tried the tip of turning on airplane mode then turning on WiFi (LOL, didn’t know that was possible. Always thought airplane mode was an all or nothing thing). In this mode the OP8T clearly had WiFI Calling working. Outgoing and incoming calls were so noted.

Checking the phone hidden settings (still recommend using the Network app for quick access) I see that the Data Network Type is IWLAN and the the Mobile Radio Power was still on. On the other devices, going into airplane mode turns that off.

Data Network Type is not to be confused with Preferred Network Type.

The mata is the only other phone that shows IWLAN but any attempts at making calls quickly fail because the radio power is off. Turning it on immediately changes the Data Network Type to LTE. Plus the IMS Status is not registered with features unavailable. On the potter and T2e the DTN is unknown when the radio power is off, LTE when turned on.
Interestingly, when DTN is IWLAN, the Current Network is shown as T-Mobile. Once radio power is turned on it changes to Mint.

On a side note more applicable to the Samsung S9 VoLTE thread @Taurus mentioned that when dialing out, if the signal icon changes to H or H+ then VoLTE is not working. That was the case on the mata. It uses Mint Mobile. I took a look at its APN. Near the bottom is MVNO Type. Knowing nothing about that setting I checked the choices and saw IMSI. Selected it and saved. Lo and Behold, my IMS Status was now registered and Voice over LTE was available. Tested outgoing calls and they no longer changed to H or H+. Good.

Back to WiFI Calling testing. Knowing the airplane mode on / wifi on method won’t work I turned off mobile data and turned on wifi. The switching around made the IMS status unregistered but toggling off WiFi Calling, waiting a few seconds, then turn back on re-registered it. VoWiFI is shown as available but can’t seem to dial out. The dialer clearly shows it trying a wifi call but after awhile it fails.

After constantly playing around I seem to have lost the ability to get IMS registered again. No VoLTE. Wonder if it’s because I add all my networking stuff back after the initial tests. I’ll see later.
Also noticed on the mata and potter, if I change the preferred network type to LTE only and there’s no VoLTE, it is not possible to make any calls as the lesser protocols are not available.

For the potter, tested things on the three ROMs. No VoLTE or VoWiFI. T-Mobile IMEI check page says the device is fully capable yet T-Mobile has sent me emails telling me otherwise for that phone number.

Teracube 2e. Not much to say. No WiFi calling. Only feature unavailable under IMS status.

Wonder if SIM age matters in some cases. SIM used in the Moto may be my original going back to 2013/2014 I think. From Samsung Galaxy Light running Jellybean, to several LG G3’s running KitKat thru Nougat, then to the potter.
SIM in the Teracube is from my Axon 7. Originally purchased as a replacement for a bricked G3. Android 6 / Marshmallow era.
A call to T-Mobile maybe and see if there’s some updating needed or if I’m out of luck.

tl;dr this mess of a rambling post. Four devices, three Android versions, six ROMs. Only the OnePlus has Voice over WiFi it seems. Not good.

Don’t mind the ugly contact photos. Have no idea who that guy is. :grin:


Interesting stuff!
I don’t have wifi calling on mata at the moment because it’s running DivestOS, locked booloader and the dev has specifically removed the proprietary blobs for it. He runs surveys to see what users want, I didn’t know.
Before that I was running MikuUI which is kind of AOSP12, installed over 0.90 stock. Wifi calling was provisioned and working with carrier 3UK. It was a pretty good os once tweaked to replace some of the undying stuff. I might return to it later. The maintainer seems to keep up with monthly security patches too.

According to the spec sheet of the Murena Teracube 2e:

VoLTE Yes, if supported by your mobile provider
Vo-Wifi Not supported by /e/OS on this phone

FWIW, I’m using a Sony XZ1 Compact on Ting (using T-mobile’s network), and VoLTE, VoWIFI, and messaging over WIFI are all operational.

TIP: After 3G is fully retired, if users don’t want to give up certain nonworking-VoLTE phones, you could just add a JMP.chat account, install a recommended Jabber client (e.g. JMP’s own Cheogram app, from F-Droid), and use that in conjunction with your carrier’s SIM (just for the data connection) to get calls, SMS, and picture messages over the internet through the Jabber client.

In the few weeks I’ve been testing it, I’ve able to receive 2FA SMS codes from financial institutions and eBay (but not Netflix). Calls and messaging work flawlessly. (For me, it’s just a way to have an additional phone number; as I said, my phone already has operational VoLTE.)

Vo-Wifi Not supported by /e/OS on this phone

And yet it’s apparently supported and working with the 2022 2e and LineageOS 18.1.

Interesting. It would be good if /e/ would explain why that’s so.

IMNSHO it’s always ambiguous what device sellers in general mean when they say “supported” or “not supported.” They should use terms like “operational” or “working” instead. “Support” can mean many things.

What do you need to set up for messaging over WiFi to work?’ It doesn’t seem to be working on my XZ1 Compact

I simply had to enable “Wi-Fi Calling compatibility mode” within my SMS/MMS client (Silence).

I know that Silence hasn’t been updated in a couple of years, but I still use it. :slight_smile:

Thanks. I use QKSMS (the real one not /e/'s fork) and it doesn’t have such a setting. I’ll live without it

There may be a different client that offers it, other than Silence.

I agree, a little more info would be nice. I wasn’t aware of what you posted when I bought my 2e’s from Teracube.

In the case of Lineage OS18.1 and 2e emerald, the dev says it was tested with a few carriers and they reported it worked fine.

If that’s that’s the case, then I wonder why not /e/?

1 Like

The silly thing for me is that I have no actual need for WiFi calling. The dialer has always been the least used phone feature. I don’t call anyone and don’t like talking on the phone. In any monthly phone bill there is probably no more than five minutes of talk time if that much.
Back when I was a ROM tester I would neglect testing phone calls. Would be all ready to give the the thumbs up for build release but another tester would find problems with calls. Oops. :grimacing:

My messing around recently was out of curiosity about whether or not certain features work or not.

@Taurus , yeah I saw your mention of jmp.chat before. Will look into that.
Before I got internet I was paying for five phone lines. Afterward I removed a couple of lines and then realized how isolated the devices were. Wound up setting up Linphone on the devices. Nice but using sip addresses instead of numbers (free accounts).

Regarding the Moto G5 Plus potter not having VoLTE, I may move the SIM to a Moto G5s Plus sanders (running Oreo ROMs) and see what happens there. That device was also a candidate for LG G3 replacement.
Despite eventually getting bigger, better, faster phones, the G3 (several) and the potter have been my daily drivers. The OnePlus is too big and the Teracube, to be honest, seems a bit laggy and not as responsive / quick as the old 32bit potter.

Regarding the Teracube emerald’s lack of VoWiFi, maybe some necessary blobs were removed? Seems like given that LOS 18.1 has it working. :grey_question::grey_question:


Just an FYI. I finally decided to upgrade my Essential PH1 mata from /e/OS 0.11 Pie to 1.0 Q.
Things have changed on the networking side. Voice over WiFi now works. Tested and verified. Using Mint Mobile. Nice.

Now let’s see what to do with the Teracube.


I’m currently running 1.0 r, VoWiFi is still “Unavailable”…:frowning:

@Manoj, do you know why /e/ doesn’t support VoWiFi on the 2e?

Checked with the porting team reg this. The response is that VoWIFI should work on the emerald, the 2e version that came in 2021. On the Teracube 2e version released in 2020 it does not. There have been no updates from Teracube for almost the last one year for this device. The team was working on upgrading the 2e (2020) to /e/OS R, but there is a lot of work still pending around this, including VoWIFI. No ETAs as yet for this.

1 Like

Thank you for the info, I had the impression it wasn’t supported for any of the 2e’s since the Murena 2e spec page says it’s not supported by /e/.

I have the 2021 emerald version, but I still haven’t had any luck with getting VoWiFi to work.

If you have any suggestions on settings to check, etc. I would be grateful.

Though not directly related to the Teracube…

I mentioned earlier that T-Mobile sent emails telling me my main phone doesn’t have VoLTE. Moto G5 Plus potter running Nougat ROMs via MultiROM.
Finally called them to see if the issue is with old device, old Android, or old SIM. Spent a long time with the rep before he admitted he wasn’t really sure what he was doing and would transfer to tech support. Transfer took too long so I hung up, planning to call the next day.

However, I decided it was time to move away from multibooting Nougat. Flashed the last OEM stock ROM (Oreo). In that I had full working VoLTE and VoWiFi. When I turned on airplane mode and turned on WiFi I immediately got an icon and notification letting me know calls are now via WiFi Calling. Tested and confirmed.
In the hidden phone settings it showed Data Network Type as IWLAN, Voice Network as unknown. When I turned off airplane mode the Data Network type stayed as IWLAN and Voice changed to LTE. WiFi Calling was still in use.

Now it was time to test custom ROMs. Literally went through about ten ROMs covering Oreo, Pie, and Q. Besides the failure of two OmniROMs (no IMS registration, no VoLTE/VoWiFI) all the others had VoLTE. Some ROMs, like ViperOS automatically showed the VoLTE icon. Some have to be explicitly toggled on if it has the option. For those with no icon I had to test by setting Preferred Network Type to LTE only and attempt to make a call.
For ROMs that only give you three choices ( LTE Preferred, 3G, 2G) then one has to use the hidden phone settings to explicitly set LTE only. Otherwise calls may be using GSM/UMTS/CDMA really.

Now for the relevant part. Not a single custom ROM had WiFi calling. Data Network Type is either unknown (airplane mode on, WiFi on/connected) or LTE (airplane mode off, WiFi on/connected).
The radio/modem power gets turned off in airplane mode. No calls can be made. When the power is enabled (airplane mode is still on) calls can be made but it’s not via WiFi.

Once again, I rarely if ever make or engage in phone calls so none of this (VoWiFi) is an issue for me but was still curious enough to test.
Wondering what’s missing in custom ROMs compared to OEM in this case.

ROMs tested on the potter and Android versions.
ArrowOS (9).
OmniROM (8, 9).
crDroid (8, 9, 10).
GZOSP (9).
Validus (9).
ViperOS (8, 9).
OEM Stock (8).
OEM Stock, debloated (8).

I’ll have to reconfirm that VoWiFi is working on the mata with /e/OS and Mint Mobile. Seems iffy.
Carbon ROM on the OnePlus 8T has working WiFi Calling.