XA2 is hung at animated /e/ splash screen after attempted update to 1114

This morning as per notifications, I attempted to update my 1108 phone to 1114. The update downloaded properly, and seemed to install okay. However, when I went to reboot, it is hung at the animated /e/ splash. Several soft reboots later (VOL+ and PWR) the behaviour is exactly the same.

Is anyone else experienced this? Any suggestions on recovery?

Many thanks.

Hi, I experienced something simulair with my update to 1108. The download and install went okay but when it reboot, I just get the word “Sony” in my screen for a few seconds and then a black screen and nothing more. Whatever I try, I’m not getting furher then “Sony”… For now the phone is not usable :disappointed:

I’m not getting the phone into bootloader…
Sony Xperia XA2 model H113

As a temporary workaround Pl can you try and download the previous build version manually from here
The flashing instructions for the device are over here - assuming your device is the XA2 Pioneer.
Hi @rhunault two issues reported with XA2 latest build ver 1114

Thanks Manoj for the suggestions. As outlined on Telegram channel, I ended up having to use Emma to restore my XA2 to factory. Went through the install procedures, and kept going into the reboot cycle even with 1108 (which is what I had initially installed successfully).

Finally took a video of the startup with another phone, and saw that there was the briefest of popups regarding RECOVERY: “Can’t load Android system. Your data may continue to get this message.”

Eventually, after hovering my finger over the “Factory data reset” button I am now back to successfully booting into 1108.

Should I try to load 1114 or leave it for now, I wonder?


I went ahead and tried it (1114), first with the image on the microSD card (failed), and then via ADB Sideload, which also failed, but this time with an error code:

On Step 2/2 the following error was raised:

Error applying update: 5 (ErrorCode::kPostinstallRunnerError)
E: Error in /sideload/package.zip (Status 1)

Restarting adbd...
E:Failed to open driver control:  No such file or directory
Installation aborted

At least I am back into 1108 successfully, though.

1 Like

If you need some other specific diagnostics, I would be happy to try and help. Although since this is my production phone, I do have to be careful to ensure that remains up.


Thanks @usonianhorizon or debugging the issue in detail
Hi @rhunault the error message is pasted above. Any idea why it comes up.

@Manoj @rhunault In the meantime, I would like to recommend that 1114 be pulled from the downloads page for Pioneer to prevent others from ending up with a non-functioning phone.


Sorry for the inconvenience. I removed the 1114 build for pioneer.

ATM I can’t explain why it causes some error, as there is no modification in source code for this device. Build logs are not helpful neither. I can’t find anything interesting with the error code.

Now I will wait the next build to see if the same error persists.

1 Like

Thanks @rhunault. As it shows up under OTA System Updates, users might be tempted.

I will await the next build. Happy to test, but will have to back up as this is my primary (and essential :slight_smile:) phone. Is there a prescribed backup+restore procedure before trying to update? New to Android and /e/.

Thanks and regards.

Just wanted to give an update regarding the latest pioneer update: I wanted to wait until there was some distance between 1114 and current available upgrade before attempting. Plus I wanted to have a bit of time in case something went off the rails.

I am happy to report that my 1108 > 1224 upgrade OTA went without a hitch!

Just in case there might be other XA2 users who are contemplating the same.