Xiaomi Mi Note 10 / CC9 Pro

I would really like to be able to use the OS /e/ on my Xiaomi Mi Note 10 / CC9 Pro smartphone. I want to regain control of my data so I find your initiative very interesting. Thank you for offering this kind of OS.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


You could use the arm64-b GSI image for the Mi Note 10.
A GSI image is not a phone specific image, it can be used for many phones that support this system.
It can be that everything works great, but it can also be that some things do not work as they should.
On my Xiaomi Redmi Note 9pro, the fingerprint sensor goes crazy, and the reception strength is not displayed in the car, even though there is reception on the phone.
I had noticed that so far. It could be that this is not the case with the Mi Note 10, or something else.
But it’s worth a try in any case, better than with the crappy Google on the phone.
Here is an installation instruction from the Redmi Note 9pro, should possibly work for you. GSI Installation on Redmi Note 9pro with Super Partition and root
Here you can find the latest images: https://android.l1nux.org/index.php/s/tNyG9ZcrjGBPrdH
You need the …arm64_bvS.img.xz file.

Hey, thanks for the info, I’ll try to take a closer look at it. Only, is it possible to go back if it doesn’t suit me or doesn’t work?

What about the Xiaomi Note 9s device sir ? what i can use for it ?


Hey, a little feedback on my experience, so I tested and failed miserably.

First the command: “fastboot reboot fastboot” was not recognized. And once I managed to reboot in fastboot I had no /d/ after the fastboot, I still had the Xiaomi logo with the fastboot rabbit. So I still flashed the image you shared with me. I only got OKAY’s in return during the flash process. So I finished with the reboot step in recovery mode to delete the data and restart the phone.

All right, I’m thinking I’m going to have a brand new OS, well, nope. My phone stayed on the MIUI logo and that’s it.

Finally, I reinstalled the original ROM of Xiaomi but it’s not what I wanted. I want to try again to install the GSI ROM /e/.

I don’t know what went wrong in the process.

Hello, you wrote it yourself, the mistake was probably that you were not in fastbootd.
Did you use the original USB cable that came with the phone? That could be the error.
If so, use a different one, it can be a USB3 cable, it just has to be connected to a USB2 port.

Then it should also work with fastbootd.

Indeed, I used the original cable on a USB2 port.

But in powershell (from platforms-tools) the command “fastboot reboot fastboot” is not recognized. I may have to try again.

Do you use Windows or Linux? It never works for me under Linux, unfortunately I always have to use Windows…

Normally I use Linux, but for handling, I followed your recommendation to use Windows. So, windows.

When I type the command “.\fastboot reboot fastboot” it only restarts my phone. And it doesn’t reboot in fastbootD.

Yes, as already written, use a different cable, it can be a USB3 cable, the only important thing is that it is plugged into a USB2 port, alternatively into a USB3 with a USB2 distributor.

AND, it must be a data cable, not just a cable for charging, there are also differences.

I use these cables for this purpose and it works without any problems.

I already use a data cable. I tried again with another one and still the same, the phone turns back on instead of entering fastbootd.

Then I don’t know what to do either…

OEM Unlock is active?
Latest platform tools downloaded?
Original recovery installed? No TWRP or something?
When entering “fastboot devices”, the phone is recognised correctly?
Have you tested other USB ports?

I don’t know what to do anymore either… Yes the OEM is unlocked as well as the bootloader.

I checked and I have indeed the latest version of platforms-tools.

The phone is recognized in fastboot. And yes I tried several USB ports and cables.

It remains a mystery to me. :thinking: