Xiaomi Redmi Note 9 pro crashes and reboots seconds after boot (loop)


I have a problem with /e/os on my redmi note 9 pro.

I installed /e/ on it following this page: Install /e/ on a Xiaomi POCO M2 Pro / Redmi Note 9S / Redmi Note 9 Pro / Redmi Note 9 Pro Max - “miatoll”
and this worked so far.

After half a day the phone rebooted and keeps crashing seconds after boot.
I have barely enough time to enter the sim unlock pin.
Can’t even power off, because the device hangs before it shuts down to power off.
I can only power it off by going into recovery and selecting power off there.

any ideas what i can do here?

Hi @mavu welcome to the /e/ forum.

So this is a new install, just a few hours old?

I would recommend a Factory reset. Perhaps First boot was faulty in some way?

Following Factory reset (which will bring you back to /e/"!) you will launch the First start wizard. In the first instance I suggest you do not set up wifi.

Does the phone work without wifi; will the device make and receive calls and texts; will the device work on mobile data; test any other specifics; lastly will wifi work.

This might narrow down the cause of the problem.

Everything worked (wifi, calls, bluetooth, etc) on first setup.

I’ll try a factory reset and see if that makes it run stable.

Ok, new information:
I decided to try to install LineageOS just to see if that made any difference, and the phone reboots as soon as I enter the Wifi Password.

So, wifi worked at first, and then stopped working and now leads to a instant reboot when connecting/enabling.

Your issue sounds quite similar to Xiaomi Redmi Note 8 reboot all alone, the thread contains many links to issues, mostly unresolved.

It would be great if you could follow through and collect some logs Create a log @/e/ and ideally Report an issue

A similar sounding Xiaomi issue has cropped up in Testing, Testing @/e/, but I did not yet see an /e/ issue filed last week.

Interesting. Although collecting the logs might be tricky. the device hangs after a couple seconds, and I’m not sure I can even connect with adb in that time window. i’ll try.

currently i’m trying to install miui again to be sure to have the very latest official updates.
I’ll try again after that.