Zenfone 8 keeps rebooting in bootloader after flashing recovery

Hi All

Hoping somebody can help me out here as I appear to have the same issue as this thread.
I’ve just bought a Zenfone 8 specifically to install e/os as it’s been my daily driver on a now broken Samsung S9.
I followed the install page instructions and completed the install vendor_boot.img step.
Now I can’t get out of “fastboot” or even poweroff. It just loops all the time so assume i will have to wait for a flat battery before it will even turn off?
I completed the next step and installed the recommended recovery via Fastboot but this made no difference.

I don’t know what to do now if as suggested the Vendor_boot image is not suitable.
I can still see my phone from terminal using “fastboot -l devices” so can I do something like install a different vendor_boot image so that I can get back to stock or maybe try Lineageos?
I don’t have a copy of the original vendor_boot image to roll back.

I’ve only got very basic tech skill so am lost at this point and any help much appreciated?


Just in case, can you check your fastboot version. You need to always use latest platform tools.
If you still get the same result, I suggest you try installing LineageOS to test.
If it installs OK but /e/ OS not, then we should remove installation packages from the website until the issue is fixed.

1 Like

Please follow the advice from /e/ support first!

However …

When you get stuck with “Fastboot mode only” for the first time it can be alarming. However Fastboot is like the communication channel for flashing the device safely with latest platform tools. So that is the mode you need most.

Boot does not succeed, so /system is not bootable (for some reason) this is the space which we want to get populated by /e/.

The usual fallback when /system boot fails is Recovery mode, so we deduce here that Recovery is also compromised.

Another complication for this device is mentioned in the install instructions https://doc.e.foundation/devices/sake/install:

Tip: Outdated fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot. In this case, you must update fastboot to a release newer than or equal to 31.0.2. Alternatively, you can manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a, you must flash to boot_a.

I would prefer to see this worded as :warning: or Alert.

Meanwhile please continue reading. Including the links in this thread from the start! This, I think, is the issue filed by @fraksken

The following thread reads as somewhat complex but may contain some insights for you.

That would work, I do not know the device, but you may find a hardware key combination to Force stop, usually involving a 10 second press of Power key. If this results in reboot, then back to Fastboot, you will still need to try to find the combination that is Force stop rather than Force reboot.

An issue has been created on GitLab and the dev team has been informed. Feel free to add your comments to the issue.

1 Like

Hi Shenol, Aibd

Thanks for the quick replies.

FYI. My version of platform tools is the very latest.
Using Frakskens’ instructions at the beginning of this thread I’ve flashed back vendor_boot and boot from last Asus v11 Image.
This was done using payload_dumper and pushed my skills to the limit, however my phone is now booting OK into OEM Android.
I’m OK to give Lineageos v12 install a try however wondering if your team don’t simply have an earlier version of vendor_boot I can try. This is simply because I’d much rather use e/os and using Lineageos I’d have to upgrade to Android v12 making a reversion back difficult if this issue is fixed in the meantime.

Also I’m not sure if the issue raised in Gitlab (#6138) by Manoj is accurate?
It’spossible/likley that the build itself is OK and that the Vendor_boot image is the problem. I couldn’t get to the point of installing the actual e/os build.
Maybe people who already have it installed are having no problems and would like/need the updates?

Thanks again for all the assistance

Hi A,
Can you please include your comments in the Gitlab issue too.

Hi Shenol

I see you’ve already linked my comments in the Gitlab Issue so guess will see where it goes?
I have one question before I go down the LineageOS path and that is whether I should try out TWRP first.
I see that Fraksken mentions it but not sure if was tried?
Any thoughts/advice?


Hi @aaa007 ,

Sorry for not having participated earlier. I was aware of your plight, but away from my keyboard for several weeks.
As @aibd mentioned correctly, vendor_boot image malfunction for Asus Zenfone 8 (#5985) · Issues · e / Backlog · GitLab is the issue I’ve filed for this problem. As far as I understand, the vendor_boot is build by Lineageos, and they follow their own versioning. Since they do not build for Android 11 anymore, but uniquely for Android 12 (for this phone at least), the provided vendor_boot is one for Android 12.

@aaa007 Don’t worry, I don’t think you’ll brick the phone this way. I’ve gone through the stress and through the stages of grief, but still managed to get it working in the end.
At first I thought it was faulty hardware and sent it in for repairs. It came back all right (although I think they just gave me another phone, the ID changed).

I’m sorry to say that at the moment I’ve had to go with LineageOS. I needed a phone and that OS was better than the stock OS. I’m still looking forward towards a resolution for this issue, because I do prefer /e/ OS over Lineage.

Additional, it’s a great phone. You’ll love it once you get it working. I do recommend looking around for a better camera app to get the full power of the camera.

TWRP did not help the problem unfortunately.

Hi Fraksken

Thanks for the response. Very much appreciated.
I’ve pretty much accepted that Lineagos is my way forward and have been looking into the process.

The issue I’m having now that you might have some advice for is how to upgrade my phone (on Asus OEM) to v12 from v11. Apparently I need to do this before installing LOS v12
It won’t do an OTA update and if I place the latest download from Asus onto the phone as suggested it doesn’t seem to register?
The file I’ve been trying to use is UL-ASUS_I006D-ASUS-31.1010.0411.122-1.1.25-2208-user.zip which is dated 07/09/22
Some of my reading suggests that as I initially unlocked the bootloader on my phone at v11 to try e/os then I can no longer do it this way.

Some suggestions seem to be to use payload_dumper on the zip file and use “fastboot flash” command on all the individual .img files.
I can try this but don’t seem to be able to find any clear or specific instructions. As I’ve stated before I’m no techie and don’t want to get it wrong.

Any advice would be really helpful.

There is now an R build available on the testing channel, for a brave user who feels like joining https://doc.e.foundation/testers; see specifically the paragraph How do I join the testing community?

Hi @aaa007

I’ve gone through the same issues and also had to conscript help from friends and quite a few channels in order to get anywhere.
There is no upgrade path from 11 to 12 in the state your phone currently is in, At least none that I’ve found.
I did found I could downgrade from 12 to 11 by using the ASUS Android 12 Beta programme, and also figured I could install 12 from the ASUS Android 13 Beta programme.
I did this and it worked. Follow instructions at the bottom of the page titled “opt-out” Android-13-Beta | ASUS Global
It will overwrite all images on your device and bring it back to a factory-reset state on 12, no matter what your current state is.
Note you’ll need to upgrade one-by-one after that until you get to the latest upgraded version before installing Lineage.

@aibd I appreciate the community and all the effort that has gone into getting this already to the testing channel. Unfortunately, at this present moment, I can’t risk compromising my main phone.
Despite the phone is on sales, At the moment I also can’t afford to buy a secondary for testing purposes. Please be assured that if I could, I would.

1 Like

Hi All again

Thought I’d update anyone interested in the latest happenings in my Zenfone8 journey.

After taking on board all the great advice from Fraksken and aibd I managed to install MicroG-LOS 19 (v12). I got a couple of errors but over-rode them from Phone and installed successfully. I did minimal testing before deciding I’d wait out a fix for eOS.

I Didn’t have to wait long as eOS have just posted v12 Install on their normal webpage. (e-1.5.1-s-20221103231515-dev-sake.zip)

I’ve successfully installed this without any of the issues I had with v11 although I did get the same errors I got with the MicroG-LOS install as follows

E:Signature verification failed.
E:Error: 21

E:Update is older than the current build, expected a build newer than timestamp 1667534820 but package has times stamp 1667488983 and dowbgrade not allowed

I once again over-rode these error on handset without any apparent issues.

I guess a question I have is whether I should be concerned about these Errors?

Regardless initial testing looks really promising and I’ll continue to do further over the next week or two. I’m still using my old S9 until such times as I am happy.

Once again thanks for all the good advice to date and I’ll add further here when I get a chance.



Hi @aaa007

That’s wonderful news! Thank you for taking the time and effort to test the v12 version of /e/.
I’ll see when I got a moment to do the same.
I don’t think the errors you’ve seen would be critical, but please do report if you see any strange behaviour.

Looking forward to be back on /e/!

hi I’ve been careless I think
see here
i tried to go to S today

I bought the cell phone with A12 (a half year ago)
I downgrade to A11 because this was necessary for installing e

I followed this: Install /e/OS on a ASUS ZenFone 8 - “sake” for installing S and 1.5
but I did something wrong … I went to a12 first
and then followed the instructions ,flashing vendor_boot ,recovery = OK then with recovery uodate /e/ adb sideload… ok but:

Signature verification failed error 21
Target SPL:22-10-05 this is considered a downgrade
E: denying OTA because it’s SPL downgrade

after reboot ==> always bootloader

my english is not so good
what is the best step to take?

Is rather urgent

I can easily go to stock a11 and a12 , I think a13 also (with the beta programs of asus)
help please.

It is really simple:

Get ADB/Fastboot drivers, for example from here:

Downoad and extract this RAW image from ASUS:

Turn off your phone

Reboot to fastboot mode by pressing and holding the Volume Up and Power keys simultaneously

Connect your phone to the PC

Run the flashall_AFT.cmd from the extracted archive

When finished, reboot if not already done automatically

It could happen, that the system still won't start now, but don't worry, just wait it out.
After several reboots it will offer to do a factory reset. Do it and the system will boot properly afterwards.

Hi @eboelens,

I have the same issue as you, did you manage to make it work ? i have current SPL : 2023-01-05 target SPL : 2022-11-05