Zenfone 8 vendor_boot

Hi everyone,

I’ve tried to install e/OS on my zenfone 8 and i got a similar issue as many people on this forum : I can flash the vendor_boot and the recovery, I sideload eOS and during the installation i got the error

E: denying OTA because it’s SPL downgrade
current SPL : 2023-01-05 target SPL : 2022-11-05

by searching online i’ve found that’s it’s probably a mismatch between the vendor_boot SPL and eOS SPL so i’ve downloaded the oldest vendor_boot from the link in the install doc, reflashed the vendor_boot and retried the installation, this time I got :

E: denying OTA because it’s SPL downgrade
current SPL : 2022-12-05 target SPL : 2022-11-05

So i guess the issue is the vendor_boot ? Simplest solution that i can see is to wait for eOS 1.8 to be released and that should do it, but that means every time someone want to install eOS they have to download the oldest vendor_boot and wait for 1 or 2 month that eOS catch up with the SPL ?

What I was wondering is if I could use the vendor_boot.img contained in the eOS-1.7.zip → payload.bin → vendor_boot.img ?
I dumped the vendor_boot from the latest lineageOS.zip → payload.bin and compared its md5 with the md5 of the latest vendor_boot from the link in the install doc ( here ) and it’s the same file. So i guess i could use the vendor_boot from eOS.zip ?

As I’m not sure I’ll wait if no one confirm me this, but I think it could help everyone trying to install eOS on their zenfone if they don’t have to wait for a month or more

I’ve often wondered the same thing and would try it if I had a relevant device. Even if it throws the same error it would at least point to something else being the error.

Actually I don’t understand exactly what this SPL is anyway but I’m beginning to think it may relate to the dates of the os that resides in the other slot.

Did you do a downgrade of stock just before starting this, btw?

Hi @chrisrg,

Didn’t do any downgrade I bought the phone less than a week ago, done all the updates for Android 12 and stopped when the next update was to upgrade to A13. After that I tried to install eOS.

From what I’ve read and understood it’s the SPL contained in the eOS.zip (and if that’s the case does it get the SPL version from the vendor_boot inside that zip ?). Didn’t think about it but I could try to install eOS-1.6 and see if the target SPL change

But what is SPL? Can’t seem to find that out…
Be careful about flashing it too much. I seem to recall issues with that device getting full and causing issues.

Oh sorry, just don’t take for granted what i’m saying cause i’m not a mobile developer, but looks like it’s Security Patch Level and so you cannot downgrade to avoid to reintroduce previous security issues

Ah, I see. Kind of obvious now you’ve pointed it out! :joy: Security Patch Level.

Now I understand your previous question and that seems to be the correct question. But I don’t know the answer.

But thinking out loud: why is it that others have got around this with older vendor_boot.img’s and is it, as you suspect, because the SPL is inside that .img.

I’m too confused at the moment, actually. Sorry. :joy:

Just looked at my old Sony XA2 running 1.7-s 20230111 and indeed it is Android security update 5 Nov 22

So surely it should work with the vendor boot extracted from the eOS payload bin?

That is what I think, but I’m scared to brick my phone and I guess eOS1.8 will include the SPL from 2022-12 so I prefer to wait a week or two before trying that, if I don’t have any confirmation that it wouldn’t break anything

I don’t blame you; that’d be safe.

But there is a simple solution here, I am sure; but the e dev’s seem to be either ignoring it or unaware of all the problems being caused to people.

I’ll leave you alone now! :wink:

May have a look into this thread:

I think you are having the same problem with the vendor image version. I got the sideloading working, when I was using an old version of vendor image that eboelens provided and keeps luckily alive: https://www.dropbox.com/s/872i2ygwhs7fzwr/vendor_boot.img?dl=0

1 Like

Hi @demux,

Thanks for your reply, I’ve read this thread but not correctly… So this vendor_boot has been used by @eboelens to install eOS-1.6 but you’ve been successfull to use it for installing eOS-1.7 ? I thought his vendor_boot wouldn’t work cause too old

@demux Thanks, it worked but I agree with your point : “why is /E foundation not retaining working vendor images on their server?” Or if we can used the vendor_boot contained in the payload.bin maybe this method should be prefered