Adb sideload failed (error 7) warning: no file contexts

Hi, I’m trying to install /e/ in a Xiaomi Mi 6, but got the error in the image.

I’ve seen that it’s a common error, however, all the cases described previously in this forum, even if they all throw Error 7, don’t match exactly with the error message that I get: “Warning: no file_contexts” / “Xiaomi verify trustzone…”

I already tried to change the command lines in the ROM (the solutions that have been given, but nothing. I here (method 2) it says that it is the bootloaders problem, that it’s outdated. But how can I update a bootloader??
The phone had Pie ROM, but was downgraded to Oreo before I got it. I assume that the /e/ ROM version is also Oreo, but correct me if i’m wrong.

(by the way, I already tried wiping system and data)

Hope someone can help

Thanks

Hi @graz did you try flashing the LOS 16.0 build on your device. The roll back from Pie to previous versions is known to cause issues on most devices. Can confirm this because we have been testing Pi/e/ builds the last couple of weeks. The way we are flashing the test Pi/e/ ROM’s is first flash the latest stock ROM through Miflash which would be on Pie and then flash the Pi/e/ ROM ( format + wipe system + data + cache).

Hi @Manoj, what I did was flashing the latest version of /e/ on top of the Oreo equivalent of Miui. Was the last version of /e/ Pie?? I thought it was oreo, that’s why I asked the phone owner to downgrade to Oreo, to match both versions, but maybe I made a mistake on that.

So if I understand correctly, I have to flash the Pie ROM (Xiaomi’s one?) and then flash /e/ (which I don’t know anymore which version it is…)?

By the way, while trying to find a solution I wiped ‘system’, but that doesn’t mean that I removed the stock ROM, right?

Thanks for your help

Hi @Manoj, I installed the latest stock ROM (Pie) and flashed the lattest /e/ ROM available for Xiaomi Mi 6 (which I think is not still Pie), but have the same problem yet.

PD: I also tried installing lineage (last version) and have the same problem.

Hi @graz you can figure out which OS version of /e/ you have by looking at the name. For e.g. the name
could be
e-0.7-n-2019070315439-dev-mata.zip
or
e-0.7-o-201903224905-UNOFFICIAL-tissot.zip
or
e-0.7-p-20190702-UNOFFICIAL-tissot.zip
Look for the alphabet after e-0.7-x It could be n or o or p which means Nougat, Oreo or Pie.

Sorry I should have been clear in my post above . On Pie phones you have to flash Pie ROM’s only. That means a Pie /e/ ROM built for your device. Then the phone would work correctly. Flashing Oreo builds on Pie build will not work. Pie makes changes to your phone partitions which then render previous OS useless. You can request @Unknown who is building Unofficial ROM’s for various phones to build a Pie ROM for your device if not already done.

Dont use ADB sideload, install latest oreo stock rom via fastboot method, install twrp, download /e/ rom, copy to your phone and install it by choosing install button.

Thanks, that is really helpful :slightly_smiling_face:

thanks @unknown, i will try that

thanks @unknown, I tried your method and it worked! but as soon as the set up wizard shows, it throws a message saying: android.process.media has stopped. Then I can go a little bit further, but in the middle of the wizard the system keeps crashing the whole time and the wizard starts again. Any help?

Did you wipe all in twrp before flash /e/ zip?

Sorry, I haven’t read all answers do it could be that someone has written the ssme.
Why using the sideload? If you are in twrp you can ‘see’ your device in file manager of your pc and you can use copy and past the copy the zip the internal storage of your device. So no need for adb siteload.

Just system and cache, just as the installation guide says. Should i wipe something else?

if you dont have any data needed left, wipe all you can.