Android T stable for FP4?

Stable T builds will be planned for devices which are already on stable S or R. Will share dates and ETAs when there is any update. The development for the FP4 OS OTA upgrade to T should start soon, most probably in the next week. Since I do not have an exact date, not sharing any ETA.

6 Likes

There actually now is a stable 1.17 T image available for download here:
https://images.ecloud.global/stable/FP4/ Filename is:
https://images.ecloud.global/stable/FP4/IMG-e-1.17-t-20231109350751-stable-FP4.zip

I downloaded it and tried to sideload it manually with the official instructions (https://doc.e.foundation/devices/FP4/upgrade). When I reboot to sideloa it just puts out this error though:

C:\Users\dino\Downloads>adb sideload e117t.zip
error: protocol fault (no status)

I have not unlocked my bootloader, not going to experiment with this again just to send in my phone to unbrick :confused:
Did it work for anyone?

This file is not suitable for ADB sideload, it gets installed using fastboot as given here … https://doc.e.foundation/devices/FP4/install

Install files suitable for ADB sideload don’t have filenames starting with “IMG-”, as things stand currently.
Edit: You can just omit the “IMG-” in the filename and try https://images.ecloud.global/stable/FP4/e-1.17-t-20231109350751-stable-FP4.zip … this is a sideloadable OTA file, at least formally when you compare the contents of the different ZIP files (I don’t have a Fairphone 4).

1 Like

I see, thank you very much, I’ll try it out later today.
Was the file without the IMG you posted in the repository but somehow not displayed on the page at https://images.ecloud.global/stable/FP4/ ?

As far as I’ve seen /e/OS download pages will display only one install file format, consistent with the install documentation for a device (ideally).

/e/OS supports a lot of devices, with more than one general way to install.
In case the OTA format (which can also be used with ADB Sideload) is somehow not chosen for the official install documentation and the respective download pages for a device, OTA install files still have to come from somewhere, else a device couldn’t be OTA updated via the updater.
Over time there were some hints here and there on how to find working links to them in such cases. I just chose a possibility and tried.

Sadly I cannot sideload this file either. I guess there is a reason why they haven’t included it into the official files yet…
Edit: Am I supposed to unlock bootloader for this?

What happens?

What exactly is installed currently? Please refer to [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc.

I don’t think this is necessary for ADB Sideload.

I want to upgrade my FP4 from 1.16s to 1.17t stable without unlocking the bootloader. When I enter the sideload command in adb sideload mode, I get the error: protocol fault (no status).

e/Os version: 1.16-s-20231013341147-stable-FP4

But no worries, I realize it just isn’t done yet and will wait until the stable version is announced.

2 ideas from the internet:

  • Use the adb command from current Android SDK Platform Tools to try again. Check adb --version to make sure the latest command really gets used.

  • In case an adb process is still running, kill it before trying again.

I did a little research myself. The reason was the ancient adb I was using (from 2014). I actually had to delete the file and manually move the new one to my adb folder, until then Windows used the old version for some reason. Update is installing now :slight_smile:

Thanks a lot for your help AnotherElk!
Update: Flashed your image, no errors during update. Now it boots straight to bootloader. Recovery still worked so I downgraded back to s.

Thanks, the ZIP without “IMG-” works!

Do you have any news about ETA, @Manoj? :slight_smile:

According to the latest Week 50-2023 statement, it is expected to be OTA released with 1.19, ETA mid January 24, if all goes well.

2 Likes

The plan is to target in the Jan mid v1.19 release. Will get a fresh assessment once the teams return from the end of the year vacations.

2 Likes

Thank you very much for the update, I’m really looking forward :rocket: enjoy your well deserved holidays and keep up your amazing work :muscle:t2:

It has been there but now it’s gone… :man_shrugging:

The current plan is to release the stable /e/OS T build for FP4 along with the v1.20 release. ETA is mid February :crossed_fingers:

…seen this while downloading " IMG-e-latest-s-FP4.zip " via easy-installer …
Your warning includes this version/way of installing /e/, right?
Is it possible to use " IMG-e-1.18-s-20231207360611-stable-FP4.zip " as further version via easy-installer?

grrrz,
Bric

(sometimes heaven sends procrastinating offers…i rather wanted to flash the FP4 yesterday, but the wheather was too fine…and now your today’s notice)

oh, sorry…
“T” comes after “S” …
Sunday’s mistake.
Will flash the FP4 now.

http://www.head-table.de/