App Lounge installation on LineageOS

Hello, I’ve installed App Lounge on Lineage OS.
Every function works great: able to log in successfully, able to search for app, able to download app, but it can’t install the selected app. After downloading any app, App Lounge tries to install it, but it shows “Retry” label (where “Open” label should be shown).
I given all the required prmission to the App Lounge, tried many versions, tried Anonymous login, PWA/open source login, but no success.

Phone: OnePlus 5
OS: LineageOS lineage-18.1-20230426-microG-signed-cheeseburger los-legacy build
Tried App Lounge versions: 2.4.6/2.5.0/2.5.1/2.5.2 releaseStable/releaseDev

What can be the reason of denied installations, and how could App Lounge get to do the installation?

I’ve experienced the same: copied the whole App folder from priv-app from /e/os Oneplus5 to LineageOS Oneplus5, and App Lounge not worked.
As an alternative I’ve disabled package installer and split installer on /e/os, and AppLounge still able to intall apks.

So my question remains the same: What can be the reason of denied installations, and how could App Lounge get to do the installation?

Hi, have you tried Aurora store? It worked for me on graphene, but I tried it on a stock samsung device, it launched, I was able to download apps, but I was unable to install any apps, same as described.

I’ve played a lot with Aurora store, tried many versions (3.2.9-4.2.2)
Aurora has problem with searching, older versions just simple doesn’t show any search results, newest 4.2.2 version shows: Oops! You have been rate limited! (even if you not used Aurora for so long)

May be out of topic, but this Aurora store bug is known and devs are working hard to fix it:

1 Like

And there is a workaround mentioned in the IodéOS forums:

Unfortunatelly the above workaround not works (at least on LineageOS).

But even if Aurora works, this doesn’t help on App Lounge. Where can a bug or issue report can be taken to let this problem know to dev group?

You can report an issue by following Report an issue.

You can check out existing issues Search backlog Issues - App Lounge

I am not sure that devs will have an interest in making their product more portable.

What i have done is search for the App within a browser, then “Open link in another App” will open it up Aurora. With all the recent issues, one reason i switched over to /e/