Authentification failure

Dear /e/ community,

I recently switched from Android to /e/ OS (build 0.13-2020121490323) on my Fairphone 3 and I am very satistied of it.

Nevertheless, I keep receiving notifications such as “authentification failure” (in French, “échec d’authentification (contrôler vos identificants…)”) every 2-3 minutes and it is becoming extreneky annoying.

This seems to be mainly related to my gmail accounts (I have no choice but to keep them for work) and their respective address books.

When I dig deeper into the synchonisation issues of each of the 2 gmail accounts, I see that mainly the Agenda is not able to synch.

I already tried to delete the accounts and reconfigure them but nothing changes.

The problem seems to be completely random, as in rare cases forcing the synchronisation (i.e. switching off-on in account settings) works but the problem keeps coming back after a couple minutes.

Do you have any advice?

Best,

Corentin

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You need to setup the google account password

Search for ‘google account password’ in the forum, sort by Recent post, and look at the second reply. (Sorry I can’t link directly to the post using my phone)

Many thanks for your reply, I found another working solution following this thread:

Nevertheless, this fixed the “authentication failure”, but I am still having other issues related to gmail accounts, but I will open up a new topic

Dear community,

New /e/ user here, I face the same problem as mentioned in this topic. The address book from Google does not synchronize and I receive frequent “authentification failure” notifications. The calendar and e-mail are working fine.

I tried to use the different methods proposed in the replies of this message but so far it has not worked.

Does anyone else has faced this problem and found a solution ?
Thank you in advance!
best regards
Sebastien

What version of /e/ OS are you using?
On my side the problem was fixed with latest /e/ 0.16.

Also try removing your accounts and logging back after updating to latest OS, should technically work.

Best,

Corentin

Thank you for your answer!
I am using the latest version 0.16 (my fairphone 3 is one week old, bought at e.solutions).

I tried removing the google account and logging again but the same notification appears again.

I also see the same symptoms. FP3, latest /e/ 0.16.

In my case, authentication for the mail app fails occasionally. Sometimes I can receive and send mails, sometimes not.

For the calendar, things look more predictable. I do have several calendars in my google account. The app see all of them, but cannot sync the primary one due to failed authentication. All other calendars seem to be OK.

My google account is protected with 2FA. I used the “Login in other session” method to authorize the /e/ apps.

Is there any chance to debug this?

Cheers,
Michael

One more piece of information: I had two google accounts in the settings (one “g on blue square”, one “multi-color G on white”), plus an additional one for the address book. I deleted the two non-address book accounts and re-added a “white” google account. I did not touch the settings in the mail or calendar applications.

After these actions, the mail and calendar applications seem to have a lot more stable access, and the address book only fails very rarely.

Can anybody reproduce this?

And what is the difference between the “blue” and “white” google accounts anyway?

Cheers,
Michael

D’oh. I spoke too soon. Just while I wrote the message, the latest e.OS update to 0.17 came in, and after the reboot, the situation seems to be back to the bad state. :see_no_evil:

This is just for the record. I’m not claiming that it’s related to the upgrade.