Synching issues with gmail accounts

Dear /e/ community,

this topic is a follow-up from a previous post, related to the “Authentication Failure” after setting up gmail accounts:

The “authentication failure” related to the accounts was fixed, but I am still receiving a lot of error notificaitons still related to the gmail accounts, mainly to the Adress Book (TA) and some of the Agendas (not all, strangely). See an example below:

I Could retrieve two of the logs, maybe they will be of any help:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


We had a maintenance activity in progress which ended just now. Pl can you check again if the issue is still there.

Many thanks for your prompt reply, unfortunately the syncing errors are still there:

1 Like

It seems that I am not the only one with the “HTTP 404” calendar synching issue:

Again, people are complaining about the same “Adress Book (… TA) Authentication Failure” error as I do:

1 Like

I relied above, the error is still there, do you have any other advices?
Many thanks

@Wichtc91I don’t really know how it could be exploited but I would definitely not post logs containing your google account along with some authorization tokens and a dump of your local database… Maybe I’m wrong and you are one of the developers (which I’m not) and perfectly know what you’re doing, the tokens are unrelated, read-only, whatever but in doubt…

@Manoj I have this same error for months, so definitely not related to the maintenance activity.

Thanks for your reply, I am new to /e/ and I uploaded the log and screenshots of the error just in case it might be of any help. If you think this is a relatively bad idea, I will remove them.

Glad to hear that I am not the only one facing this issue, I am currently receiving so many error messages (every 2-3minutes) related to these issues that I haven’t been able to turn the sound on yet (way to annoying)…

I think it depends where you put your security/privacy standards.

From your logs, I can already link 3 of your google accounts with your account (that’s for the privacy side of things). Now is it feasible to use the tokens present in this log to hack into your accounts… I don’t know, they may (should) have a relatively short-time validity. I wouldn’t just take the risk (that’s for the security side of things…)

For the problem we face, I am new to this forum, so reading around… On my side as I do not update my address book every 2 min, I did set the update interval to its max (don’t remember where I did that), but that’s just clearly a (bad) work-around…

Initially I think I did at some point remove the notification permission to the app, but that’s even worse as completely masking the real problem.

Okay thanks you for the precision, I wasn’t aware that it was this risky to update the log, I will remove them straight away.

I will also temporarilly adjust the update interval, but I hope the developers find a workaround to this issue…

Is it also the case for you that it only relates to specific calendars but not all of them (from one of your G accounts) ? In my case only 2 of them are returning the errors.

I have the exact same issue: I receive “Address Book […] Authentication failed” for both my GMail accounts.

Apparently, the notification comes from an HTTP PUT request to attempting to put the VCARD data of a new contact I created on my phone. But the HTTP response code is 401.

How can I help resolve this issue?


Do you also have similar issues with synching specific calendars?
The only way for me to synch one of my google calendar is to remove the account and add it back again…

the error also comes from:

Request{method=PROPFIND, url=, tags={}}
<?xml version='1.0' encoding='UTF-8' ?><propfind xmlns="DAV:" xmlns:CAL="urn:ietf:params:xml:ns:caldav" xmlns:CARD="urn:ietf:params:xml:ns:carddav"><prop><resourcetype /><current-user-privilege-set /><displayname /><CARD:addressbook-description /><CARD:supported-address-data /><CAL:calendar-description /><n0:calendar-color xmlns:n0="" /><CAL:supported-calendar-component-set /><n1:source xmlns:n1="" /></prop></propfind>

while the HTTP response code is also 401…


Calendars sync also fails both ways. I tried using a Google “app password” but it won’t let me. Somehow it’s like the Google Auth fails after some time.

1 Like

@Manoj could you please raise an issue on GitLab, it seems that I am not the only one encountering this issue?

Many thanks

@Wichtc91 issue created here:


I updated my Fairphone 3 to /e/ OS 0.15-20210317106351 yesterday and the problem is unfortunately still there… no synching is happening upwards or downwards with my gmail calendars.
Was it supposed to be fixed in this new build @Manoj ?

Many thanks

Resetting my gmail account fixed the synchronization issue, but I lost all my calendar data (locally on the phone, not synchronized earlier)… Is there a way to retrieve it?

The latest update fixed the calendar sync issue as far I am concerned.

The address book sync issues with the errors notifications ate still a thing though.

having encountered the same notification issue about contacts sync, I ran into the following advice, as a workaround :
set up google contacts sync via the app DAVx⁵ … and it is currently working for me.

The guidelines to perform this are here.

In DAVx⁵, you will be able to disable the calendar sync, if only the contacts are concerned.
To complement these steps, do not forget to disable the google contacts sync in the account settings of your phone.


1 Like