Bank app stopped working after update to 0.19 (regression)

I am having on-off problems with my banking app. What is weird is that it seems to be depending on the version of the app and the version of /e/OS. It the official Slovenian UniCredit bank app, so I suspect other UniCredit banks across the world use the same app as well and are similarly affected.

The app crashes when I when either enter the PIN number to unlock it, or when I try to activate the app with the bank – so in both cases during authentication

What happens is that the screen flashes white and then returns to the welcome screen of the app. And if I do that a few times, I am greeted with the “your app is regularly crashing, do you want me to kill it” system pop-up.


  • hw: FP3+ (bought from, can replicate also on FP3 (also bought from
  • OS: e_FP3-userdebug 10 QQ3A.200805.001 eng.root.20211027.184504 dev-keys,stable-release
  • app: Mobilna Banka GO! (

When it works and not:

  • the above/current app version works fine on /e/OS 0.18 – this is why I suspect the bug occurs with a combination between the app and OS versions and how 0.19 might have introduced a regression in this context
  • there were some combinations of /e/OS and app versions that worked in the past and some that did not – I did not keep notes, unfortunately. OTOH:
    • an older version of app worked on /e/OS 0.16, but did not work on 0.17
    • the current version of app does not work on /e/OS 0.17 (I think…)

FAQ of what did not work:

  • restarting the phone
  • deleting cache, storage and app and reinstalling it anew
  • (I am also in contact with the app’s IT support, but so far nothing new)

A logcat and a GitLab issue may help.

1 Like

Well, that was extra weird… I played around with the debug tools and if I enable the Interactive Report, as described in [HOWTO] Get a log from your phone - #4 by Anonyme, then the app does not crash on PIN entry (it may crash later though).

Without the Interactive Report running, it always crashes at the PIN entry.

Thanks, I submitted the bug now: