Black screen, don't start

I installed via Easy Installer (Gigaset GS290) and everything looked fine until the end when the phone went completely black. I can’t start it now.

Edit: I’ll send it to Amazon for exchange to a working phone

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Same problem here. Wanted to install /e/ on a Gigaset GS290 with the easy installer. Did not succeed. New phone, completely black screen nothing happens anymore.

I did all the single steps. Did an update as described, too. After the installation the phone does not reboot and remains off.

By the way, please let us know what happens with your phone and if you will be able to change it.

Yes I will. I have sent it back to Amazon.

Hi @clacri, I hear your pain.

Please can you try to find the Easy Installer log and add it. Use this page to help find the log.

Hello @aibd,

Thank You that you are willing to have a look at my problem and help. I guess I found the relevant logfile as you described. But I wasn’t able to upload my file here, just click on the link please.

I would like to tell you, that command lsusb (Linux) shows a device only when I plug in the phone to USB port AND push the power button for a longer time. The phone then appears for a short while and then disappears again from the list:

Bus 002 Device 017: ID 0e8d:2000 MediaTek Inc. MT65xx Preloader

I am reflecting on that log, but paste it here for others!

I also have a MediaTek device, Xiaomi, where lsusb and adb commands do not always give expected results. I usually work round them in the knowledge that I have a backup factory ROM.

Can you get into Bootloader manually? Can adb devices or fastboot devices show a result? If no, does changing cable make any difference to the output of adb devices or fastboot devices ?

Unfortunately, there is no change in using another cable or port.
Both adb devices or fastboot devices do not show any results, I installed the newest version of adb and fastboot from one hour ago and used the Ubuntu version before that.

This is an output of comand dmesg | grep usb

[ 4714.391869] usb 3-2: new high-speed USB device number 4 using ehci-pci
[ 4714.548814] usb 3-2: New USB device found, idVendor=0e8d, idProduct=2000, bcdDevice= 1.00
[ 4714.548822] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 4714.548827] usb 3-2: Product: MT65xx Preloader
[ 4714.548830] usb 3-2: Manufacturer: MediaTek
[ 4717.219244] usb 3-2: USB disconnect, device number 4

Maybe it will help.

Currently I don’t see how I could possibly escape from this situation, because the phone doesn’t start at all and behaves at described. I am far from being an expert, but on the other hand I never had this situation before and successfully installed Ubuntu Touch, Android, /e/ and Lineage on different kind of mobile phones and one really reluctant tablet, too.

I think all this means that I should try to send the smartphone back to vendor to see if we can agree somehow.

I am relatively sure I did all the necessary and right steps with a brand new Gigaset GS290 while using the Easy Installer. So it is probably interesting for the /e/ community to have a closer look at the log (thank you @aibd !) and current behavior of the phone, before I send it back - just in case s.o. else would fall into the same trap.

So, is there I should or could do to help with that ?

Hi again @clacri, I expect you already read the other black screen thread. When my Xiaomi went “black screen” I re-read that thread, people reported it was actually “black screen but on”, not OFF. In my case in a darkened room I could tell that I could actually power off, but then the phone would silently boot back to “black screen on”. Another clue is whether the phone reacts at all to a charger.

You might see parallels with this thread?

I cannot actually offer a way forward, nor from the log, can I see what exactly made Easy Installer fail.

I can very much see the argument for returning it to sender on the basis that it did not meet your reasonable expectations and is therefore no use to you.

Had you already decided to send it back, you might decide to have one last throw of the dice and see if a PC (or Easy Installer) could make any sort of connection with it while pressing the Power button, or Power and Volume buttons.

Edit. Good morning @clacri, I woke up with this thought. Could the log be explained by low battery charge condition at the start? It just run out of juice?

Taking it a bit wider (I have no GS290 - I cannot check) my Xiaomi does charge in Recovery. I would be interested if there is anyone who can tell us if GS290 closes charging while in Recovery.

I have now received a refund from Amazon but am unsure if I dare buy a Gigaset GS290 again.

Is it safer to install according to these guidelines:

Thank You, it is good to know you have been successfull in this.

Hello @aibd

it took me a few days but finally it seems I have been partially successfull.
I changed the PC I was using an went for Windows instead of Linux and SP Flash Tool.
I followed these instructions
It took a while and I had to repeat a few times but then it finally started downloading…

So now I have Android 10 again !! Thank You so much for helping me !
What would be the best thing to do now ? I still want to install /e/ on the phone, should I follow the instructions @Jan_E recomends ?? I wouldn’t like to repeat the same thing again …

Good that you managed to restore the system. I am also interested in a working installation of e/os.
I have ordered a new GS290.

Hi @clacri, well done, so pleased to hear. I think that the downside of the installer is when you don’t know exactly what to expect!

I would be inclined to investigate the downloads that the easy installer already made for you. I would compare your log with the instructions, and become more comfortable with the process. I am so over cautious that installs used to take me several days of study!

If you become comfortable with the method you might be drawn to doing it manually, if it feels right? Equally Easy Installer.

Do ask if anything looks difficult!

I think it depends on your background experience. I quite like to learn and to work one step at a time! On the other hand Easy Installer automates things.

I would study the instructions a lot before deciding.

I am a fairly experienced Linux user and installed via Easy Installer according to the instructions and it went completely wrong. The question is how big the risk is that the same thing happens again. It might be safer to install manually without Easy Installer.

It worked ! I now have e version 16 installed on my Gigaset GS290. I am very happy and really would like to thank you, guys.

It wasn’t easy: after the manual installation (link above in @Jan_E s message) this time the phone went into bootloops. But the recovery mode worked both with /e/ recovery and I was also able to install TWRP. After that I tried to install older system versions, but it didn’t help. Until I got the idea to try again with the Easy Installer, and this time it worked !!! Hard to believe.

So what has been the difference compared to the first time: the only thing I can think of is that the first time I installed the latest Android update, because both the phone and the description in the Easy Installer asked me to do so. BUT the description differs for the manual installation: you are only asked to check if Android 10 is installed or not and if yes one should go on with the shipped version, not making any updates which in fact I didn’t. Maybe that was the deciding factor, I am not sure.

It’s time to do a donation to /e/, I would say.


That is great news @clacri.

This is a very interesting observation.

Could you possibly share your successful Easy Installer log. We so often see “fail” logs it would be informative to see an “ok_log”.

It might be really helpful to others to offer your best description of the “black screen” and how did you initially regain control!

Thank you for documenting your success, sorry to bug you further! Enjoy your /e/ phone. :sunny:

1 Like

Hello @aibd,

I would like to post a link to my cloud where you could download the log but am apparently not allowed to do so ? on the other hand I can’t upload it. Community restrictions…