Bluetooth usage leads to hard lock (Fairphone 3 / Android 9)


I’ve got a Fairphone 3 (non-plus) running on 0.23-20220412177701.
I recently purchased a smart watch (Garmin Fenix) and these devices require a bluetooth connection to the phone, meaning I’ve got bluetooth now turned on most of the time.
However, for me that results in problems. Occasionally, the device will hard-lock, showing a black screen and not responding anymore, neither by touching the screen, nor via buttons (and also not being available via bluetooth ore wlan).
I have to remove and re-insert the battery to get it boot again.

I think it happens more often if multiple devices (e.g. the watch and some headphones) are connected via bluetooth, but I think I’ve also seen it happening with only a single connection.
e.g. it also happened when I tried to send a file to my computer via bluetooth at least twice.
Currently, this happens about twice per week for me.

Any idea if this is a known bug and – if possible – how to fix it?
Would an upgrade to Android 10 (or 11?) help? (I’ve tried to avoid that for “Don’t change a running system”-reasons.)

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Any idea if this is a known bug

many months ago I had a FP3 “black screen” involving the mobile modem. This was solved by new modem firmware from Fairphone (all on Android 10). The Bluetooth issue is new to me. There is a 2019 fp3 entry for what you describe at

Are you still on Android 9 / Pie? it seems to have some speed/battery benefits, but black-screens sure aren’t welcome and you will only see firmware updates for Android 10 and up. If you can accomondate it, backing up your photos and stuff you might want to upgrade?

none of these fit your description (ordered by issue id) but you might give them a read. Some are rather long

Yeah, I saw that issue, but it doesn’t make sense that mine is related to the mobile connection, since it was clearly triggered by bluetooth in some cases.

Yes, still Android 9. The data isn’t actually my biggest worry. Most of that is already on the SD card anyways.
It’s more about the apps and apps setting.
Getting everything working (including the push notifications) was a big hassle, and I have zero interest in doing all of that again.
I was hoping that the /e/ devs get the proper upgrade path working, but well … I’ve been waiting now for approx 2 years. :frowning:

Thanks for the links. :slight_smile:
Some of them I have already seen, but there are also some new ones there.

You could skim the fairphone update changelogs for mentions of “bluetooth” / “+stability”. There’s a long thread in their forum. Just for confirmation. The OTA tests seem to be in the works, but they test 10->11, not up from Pie I think. Seedvault is present in dev builds, only slightly hidden, you can use it to get quickly back up to speed. While it’s missing some functionality that will only possible once it’s used in an Android 12 though, it will recover all Apps (sans settings/data at times). Good luck

1 Like

Thanks for noticing this bit. I asked for clarification on this.

If I have to upgrade by flashing, I’ll upgrade to Android 12 anyway, I think.

Still, would prefer a cleaner route, so thanks for asking about that @AnotherElk on the other thread.

The cleaner route always is to install from scratch. OTA upgrades are convenient, but more complex regarding the internal process and more error-prone regarding the result.

From a dev’s perspective yes. But keep in mind that doing the setup of the phone can also lead to mistakes and therefore, from a user’s perspective, it’s only partially true.

1 Like

Setting up your stuff is under your control. If you see a good chance to fail there, I won’t argue, there’s no clean route then, and the OTA upgrade will be just as good :man_shrugging:.

So, I did upgrade now and of course it was trouble.
Don’t get me wrong, the install itself is done quickly, but so was the original installation of /e/ OS.
But now I’m locked out (hopefully only for a week) of my Signal account even though I did everything the right way to migrate it. Possibly a fail by Signal, not sure, but that’s the way it is now. Can’t contact most of my contacts …
Also for some other apps the migration failed and now I have to gather activation codes again.

Understand now, why I am very reluctant to do a fresh installation?
My phone is not a toy …

Anyway, I’ll try to checkout if this issue here also happens on the new OS version and report back.

I did a backup and restore of my Signal stuff two times a short while ago … once when I switched from Signal to Langis, and once again when I installed 1.5-r from scratch because of microG trouble with 1.5.1-s.

Did a Signal/Langis backup, kept the long number given by Signal/Langis at hand, did the restore with entering the long number, everything was back, no trouble to report.

I don’t think it’s trouble with microG. It’s a problem with the registration lock. Signal doesn’t ask for the PIN and just tells me the account is locked.
There are a couple of reports on that issue and afaics, it’s not bound to Lineage.
In any case, I’m not trying to solve the problem here, that has to be done over at the Signal side.
Just wanted to point out (again), that a fresh installation of the OS is not quickly done, it comes with a shitload of problems and requires a lot of time. Not because of the OS, but because of all the stuff around it.

It has been reported that Nougat version of the Signal app is not compatible with the Q version of /e/OS. Not an FP3 thread but you might cross reference this in case it helps.

No, it’s a fresh installation and I’ve (un)installed the app several times.