Bootloop after updating Samsung Galaxy A5 2017 (a5y17lte)

Hello everyone,

today, I tried updating /e/ from 0.13 to 0.16 with the system app. It prompted me to download the system update and to subsequently restart the device. I followed the instructions and the device rebooted into TWRP and (accoording to the log) applied the system update. Unfortunately, it’s stuck in a bootloop now. I still can enter TWRP by pressing Vol up + Power + Home, so it wouldn’t be an issue to completely reinstall /e/ (I have backups of all relevant data), but I was wondering whether this issue was already known and if maybe there was a simple fix I could apply without having to completely wipe all user data.

Thanks in advance for your help,

Hi, the update from 0.15 to 0.16 worked on my a5y17lte and it’s running smoth! No bootloop here!

1 Like

It makes a lot of difference if I just update from version e-0.15-q-20210311 to e-0.16-q-20210414 OR upgrade from e-0.13-p-2020120789008-dev-a5y17lte to e-0.16-q-20210414110657-dev-a5y17lte.

@alyaeanyx’s updating /e/ from 0.13 to 0.16 is in fact an upgrade, that means. an OS change from /e/ OS 9-Pie to 10-Q and usually does not run via OTA update.

Using the “usual” update procedure, I was able to recreate @alyaeanyx’s “bootloop” and thus bconfirm.

Yes @alyaeanyx , there is a simple solution.

The Updater app does not support upgrades from one version of /e/OS to another and blocks installation on an update for a different version. A manual upgrade requires similar steps to the initial installation of /e/OS.

1. Download the /e/OS e-0.16-q-2021041 install package.
2. Make sure your computer has working ADB. 
3. Enable "USB debugging" on your device. Additionally, open Settings, then "System", then "Developer Options", and finally "ADB Only". 
4. Run "adb reboot sideload" on device.
5. Run "adb sideload
6. If you have successfully installed everything and the system does not automatically reboot, run "adb reboot" on Host Maschine termial.

Note: The device may reboot to a blank black screen, fear not, this is a known bug on some recoveries, proceed with the instructions.

Thanks to 'The LineageOS Project' for the text template.

Also, when upgrading OS from LineageOS 17.1 (Android 10) to LineageOS 18.1 (Android 11), a manual upgrade is necessary. There is a HowTo page for each supported device in the LineageOS Wiki. LOS also recommends select “Root Access Options”. But it also works without root.

Well okay, but shouldn’t the installer prevent the user from doing an upgrade then?

1 Like

For this the installation routine would have to be adapted in the source code and is the task of the /e/OS Build Team.

At least a clear communication on the part of the /e/ responsible persons would be appropriate, so that the user does not fall into this upgrade trap.

Hm yeah, I think I’ll file an issue on Gitlab later then
Edit: There already is a merge request draft for this feature, but apparently, it was last updated 5 months ago. Maybe it should be given more priority given that it basically damages the OS beyond repair when attempting to upgrade?

The one discussed here is indeed not an isolated case. I try to help in individual cases. On gitlab I do not invest time. There is no herb against the inertia of /e/. It is a (futile) fight like against windmills.

you are right. missed the fact that it’s about upgrading.

I do have another question though: As far as I’ve understood, the update app just loads the zip package to /data/lineage_updates/ and then reboots into TWRP to write it to the file system. How exactly does that differ from manually downloading the zip package on your computer and then writing it via adb sideload?

TWRP ‘Install’ *.zip and adb sideload *.zip do basically the same. But - and this is the crux - the result is not identical in the way I described.

I tested it explicitly: installed /e/OS e-0.13-p- twice, once with TWRP ‘Install’ and once with adb sideload /e/OS e-0.16-q *.zip.

TWRP ‘Install’ /e/OS e-0.16-q *.zip causes the bootloop we both encountered. It also deletes my apps.

adb sideload /e/OS e-0.16-q *.zip installs the upgrade for me and does not delete my formerly existing apps.

Curiosities there are more: Dirty flash /e/ over LineageOS for microG - all apps and data still present

Thanks a lot SuzieQ for your post, since I tried to upgrade OTA from v0.13 to v0.14 on my a5y17lte and ran into a bootloop, I was quite unsure about trying a new update again, moreover involving an Android P to Q upgrade.

However, I just performed the upgrade from e-0.13-p directly to e-0.16-q (without any AOSP stock ROM upgrade) using the method you described, and everything went really smooth with no data or configuration loss.

Thanks again !

Thank you @Baziluz. Feedback like yours is valuable for me, too, because it lets me know that my successful upgrade was not a fluke but has a system, even if it seems misleading at first glance.

Dear all,

I also had a boot-looping Samsung Galaxy A5 2017 (a5y17lte). However, it occurred after updating from some recent e-0.15-q-202103… to e-0.16-q-20210423112062-dev-a5y17lte. I did the sideload as described above by SuzieQ. This worked very well and it’s fine again.

Thank you!