Build fails building APPs

Hi. I am trying to build an unofficial Nougat ROM for Moto E condor. The build fails while building APPS. This is the part of the log where it fails. I’ve looked in the forums but not found anything. Please can anyone help?

[ 89% 31034/34785] target R.java/Manifest.java: Settings (/srv/src/NOUGAT/out/target/common/obj/APPS/Settings_intermediates/src/R.stamp)
FAILED: /bin/bash -c "(rm -rf /srv/src/NOUGAT/out/target/common/obj/APPS/Settings_intermediates/src/R.stamp ... <snipped>

Error: No resource found that matches the given name (at 'icon' with value '@drawable/ic_audio_ring_notif').

nothing matches overlay file suw_navbar_ic_back.xml, for flavor anydpi-v21
nothing matches overlay file suw_navbar_ic_more.xml, for flavor anydpi-v21
nothing matches overlay file suw_navbar_ic_next.xml, for flavor anydpi-v21
nothing matches overlay file suw_progress_bar.xml, for flavor v21

Thanks

How are you trying to build the ROM - Docker or the repo sync way.

Because the APPS v2 ?

Building with docker using a run command that worked a couple of days ago

Not sure what you mean. I’m building with docker which does a repo sync to pull in the source for everything including APPS

The previous time when Docker worked were you building for the same device with the same OS branch

Same device and same build (nougat). Might have been using "latest’ instead of " community "

This is the latest command to build using Docker.
Now the command ends with community and not latest.
Get the latest Docker image as well in case you are still referring the old one.
I will try to test this over the weekend. There are some users who are complaining that the Docker build does not work. Will run it to check if there are issues.

Thanks for your quick responses Manoj.

Yes. Today’s built used community. In previous builds I had to change DEVICE_LIST to DEVICE, and remove OTA_URL line for the build to work for the build to work. This morning I had to change back to DEVICE_LIST.

At least I learned that when the last thing you see is a line saying
Set cache size limit to 50.0 GB
this means there is something wrong in your docker run... command line` :slight_smile:

Is there any way to track functional changes to the build tools (e.g. the docker image or the official docker run command) or get notifications when they happen? Is there a particular gitlab project I should be checking more often?

That’s another change :slight_smile: I used community this morning because using latest failed.

Thanks. I may have another go too, using the ‘official’ script.

Tried again and failed at the same place:
[ 89% 31034/34785] target R.java/Manifest.java: Settings (/srv/src/NOUGAT/out/target/common/obj/APPS/Settings_intermediates/src/R.stamp)
Full details of the error output at https://pastebin.com/U31nL2Sz

I got the docker image with this command copy/pasted from the ‘How to build’ wiki
docker pull registry.gitlab.e.foundation:5000/e/os/docker-lineage-cicd:community

My docker run command was copied from that page, and I made the following changes:

  • added condor,surnia to DEVICE_LIST
  • removed the OTA_URL line, as I don’t have any value to put in it
docker run \
-v "/srv/e/src:/srv/src" \
-v "/srv/e/zips:/srv/zips" \
-v "/srv/e/logs:/srv/logs" \
-v "/srv/e/ccache:/srv/ccache" \
-e "BRANCH_NAME=v1-nougat" \
-e "DEVICE_LIST=condor,surnia" \
-e "REPO=https://gitlab.e.foundation/e/os/android.git" \
registry.gitlab.e.foundation:5000/e/os/docker-lineage-cicd:community

The surnia build is still running, but I expect it to fail at the same point :frowning:

Time to take the weekend off I think :slight_smile: Thanks for your help