Can’t install Brave and Firefox Focus


I tried to use Brave browser but I couldn’t get it to install.
In the App, when I open the page, it fails to load the content, gives me a message “Something went wrong” and closes before I can even get to know the privacy score (lot alone try to install)

I then tried to install Firefox Focus. It downloaded perfectly, but then it’s stuck on the “installing” step (still as I write this and I started it about 10 min ago). Store says that it needs Android 5+, and I’m running 7.

Has anyone got those issues? And resolved them?

For the record, I’m using /e/ on a Motorola G4.

Thank you


I think you are talking about the good know and several posted issue of apps store.

You can download f-droid via web browser and on f-droid there are much better (for privacy) browsers than you have named.
You can also install aurora from f-droid for installing apps full of trackers

Wow. Sarcasm. That was fast.

HI @elise I just tried installing Brave and Focus from Apps Installer. As you mentioned Brave shows the message ‘Something went wrong’ and does not install.
Firefox focus I was able to install.

You can try again if not install from other sources.
The issue with Brave we have a few other applications which just refuse to install.
Have asked the dev team to if possible add a message as to why an app does not install to avoid confusion.

1 Like

Thank you :slight_smile:
I will try to find another solution. (FF is still on “installing” status in the app store, can’t even cancel…)

Normally, when you stop and restart the apps store, the install will work. Or you can check and install via file browser in androit/data/foundation.e.apps/files/Download/

Thanks for this info.
I checked through the file browser, but couldn’t install FF because it’s not compatible with my phone apparently.
I’ll try to find another browser (or just use the stock one)

a goof browser is ‘qwant browser’ from aurora or better ‘jquarks’ from f-droid.
I don’t like brave. see here

I’ll check these out.

I think I have a related problem:
I also get the “Something went wrong” error with Brave but I already installed it. It haven’t been able to update it since the version “1.5.2 (390410801)” which is currently installed.
The /e/ app store tells me there are apps ready to be updated.

According to the API I believe /e/ uses, two new versions have been released

I also get a “Something went wrong” error for another application that is installed and cannot update:

Those two problems do not prevent other apps to update.

This is not the first time it happens (for Brave) and I tried the following which did not work:

  • Clearing the cache and the data of the app store
  • Clearing the cache and the data of brave
  • Uninstalling the brave application (which lead to the impossibility of re-installing it)

The second time it happen, I just waited for a week or two (can’t remember exactly) and after trying once a day it finally worked.

I hope this helps.

As a workaround download from other repositories. Apps Installer has some issues downloading certain apps and still needs to be optimized.

Would it help you if I keep my installation in this state for later feedback ?
I do not mind to wait a few more weeks if it may be valuable to the development.

Best options is to raise an issue here with a log that would be helpful for the developer. There are other such errors which have been reported so the developers can use that log to debug.