CUSTOM BUILD - Android 10 (Q) eOS GSI

well okay… :smiley:
tried mini and full now (20200808 bvN which I guessed to be the a/b version?)
none were successful… and the device does not have any custom ROMs / TWRP, yet - and the original recovery fails at mounting the system partition… :smiley:
I therefore also used fastboot erase userdata instead of TWRP format.

Do you know whether any original Android 10 device (aka system-as-root partition layout) has been using this successfully?

Never installed a GSI on a device without custom rocovery. I think.bootloader is unlocked, right?

Search ‘project treble’ on.xda. there you will find a lot of GSI. But I can’t imagine that any will work.

By the way, which device are you using?

I have just uploaded a new full arm64-a-only version. Arm64 a/b is on the way

1 Like

Thanks! Half of me wants to try this on my test XZ1 Compact. The other half says ‘It’ll probably just boot loop again’ :slight_smile:

If I get some time before I go away, I’ll give it a try.

I have heard that on my last build the Bliss Launcher was the problem for no booting (that’s why Minimal was booting) Now I have removed it and hope it will boot on all devices.

August, 25th: after some tests I have found that MicroG setup is not working and some apps don’t find any internet connection (but internet is working fine)

August, 26th: Issues from 25th are solved. Internet connection is still show ‘sign-in required’. Bit you can ignore. Internet connection works fine

Maybe that’s because some services are down?

no, it’s because I have cut the goolag calls. But it’s not perfect in the moment.

/e/ shouldn’t use google to check for internet connectivity anyway isn’t it?

Yes, but there todays eOS Q sources are not changed in that way. So I have done it be my own

Nice. Maybe you can take this out too (I presume /e/ accepts patches for their software on github): Connections to . It’s somewhere in vendor directory. Or at least sanitize the request so it doesn’t leak your serial number and the many other things listed there.

Can can’t disable it. i is needed by qualcom devices

It isn’t “needed”, it does help with getting a GPS fix faster for the first time but it also leaks a lot about you. Even if we say “the hell with privacy, I just want a faster GPS fix, it doesn’t matter that my phone is connecting to this company without me knowing or accepting” it’s just downloading a file, there is no reason to leave it make a request with all the private data you can think of about your device.

I think you should be a little more kindly. I have read a lot of your posts and you are always unpleasant if some has the same opinion as you.

If you you can try blocking it via trackercontrol.

I am just stating facts, I’m not sure what bothers you. Blocking it in user-space won’t block it completely (as the VPN won’t be up all the time). Even blocking it in hosts won’t prevent it from calling home, at least at boot time. Now I might be a bit biased about this issue but I fail to see why people are much more outraged about more tame things that are off by default (and clearly presented) while this one which is totally hidden and can’t be turned off is just put under the rug.

by the way, a GSI is a system image and is vendor independent. So there is no way to remove it in GSI builds

New Mini-builds added.

1 Like

How would I be able to build this rom for my device that doesnt have lineage os. Is it possible to convert my samsung rom into e?

it’s a GSI. GSI is a Generic System Image and should fit for ALL treble supporting devices. If your device is treble supporting you can find here Device support (Project Treble)

Android 10 based GSIs didn’t work on the FP3 so far, but someone found a way to fix some libraries on the vendor partition:

Following that I was able to run the LOS 17.1 GSI so I assume it will also work with the Android 10 based /e/ GSI.

As the FP3 is scheduled to officially receive an Android 10 update on Sept. 7th my hope would be that with an updated vendor partition the Android 10 based GSIs will run out of the box.


on my phone the latest full version does not work the resent button