Device is corrupt, can't be trusted - FP3

I used the easy installer in oder to flash /e/ and selected to lock the bootloader at the end of the process. When the phone starts booting I get the error “Your device is corrupt. It can’t be trusted and will not boot.”
After spending hours with searching for solutions and tryand trying solutions that worked for people with similar issues ( Device stuck in fastboot mode after oem re-locking, FP3 installation : stuck in fastboot mode, FP3 latest update corrupt, doesnt work, /e/ fp3+ - fastboot only & device locked), my final hope are you guys. :face_with_head_bandage:
It seems that, without unlocking oem, I cannot flash anything. How can I unlock flashing (oem) in fastboot?
Thanks for help.

i did this trick once a few month ago:

fastboot oem 8901_unlock

And it worked. It is also mentioned in many of your links. So what have you tried and failed?

1 Like

Thanks for replying. It looks like this command used to work on the FP3. I have the FP3+ and I assume they added some restrictions for fastboot as this command (fastboot oem 8901_unlock) does not work anymore. :expressionless:

What does fastboot flashing unlock say now?
What does fastboot oem unlock say now?

Or maybe fastboot oem unlock-go

(remote: command not allowed) with both

unfortunatelly did not work :-/
I’ve tried all commands that were mentionend in similar threads. None did work.

I fail to see how this should be impossible to do once the bootloader was unlocked correctly for running the Easy Installer, and if it wasn’t unlocked correctly in the first place, then what could the Easy Installer even do?

Are you using the current Android SDK Platform Tools? What does fastboot --version say?

Some fastboot operations may need a valid boot slot being set. What does fastboot getvar current-slot say currently?

If it returns “INVALID”, it might be worth a try to set a slot before running an unlocking command … fastboot --set-active=a or fastboot --set-active=b
If it returns “a” or “b”, it might be worth to activate the other slot before trying again. Might even be worth a try to boot the phone on the other slot.

Yes, I was using the latest version and I tried switching slots from a to b and vice versa, same result. So I decided yesterday to send it in and hope that the waranty will cover it. I might be lucky, as the bootloader is still locked :innocent: