Document App isnt working

Hello There.

I have an issue with my Document App it doesnt have any name anymore

Also if i try to delete my PDF documents in it, it allways says that it closes continiously.

I waited for the new update but it didnt help.

Im greatfull for every information

Hi @Nurkoyiz, welcome to the /e/ forum.

Edit, I think to a certain extent you are referring to the Document App within ecloud.global_apps_onlyoffice, but this is not the app shown in your image. I worded my explanation on the basis you are showing us a download from that app. Please correct me if I’m wrong !

I can get a similar result when I use the built in LibreOffice Viewer to open an OpenOffice produced .docx download. When I delete Data (see below) the app just fails to open the “unnamed” document.

However when the download is an OpenOffice produced .pdf the PdfViewer Plus fully opens the correctly named document.

You might check the App-Information in your image to see which app is misbehaving.

Often when an app fails like this the best first course of action (which I just did on both apps !) is to Clear storage. (There is a less robust action, simply clear transient data with Clear cache. Often one will Clear cache on an app that is storing its own settings – these settings would be lost with Clear storage.) These are found from

Settings > name-of-app > Storage & cache > Clear storage | Clear cache

Edit. Regarding delete; I expect either app to open a document Read Only, so I do not expect to see a delete option. I expect to delete the file (which you show within Downloads) using the Files app.

Hi Thanks for replying

Here’s the screenshot of witch app i mean its the one that doesnt have a Name, its the App with the documents, images, download etc. In it.

I dont have a problem to read the pdfs and/or look at the pictures in that app, i just have the problem to delete the stuff in that app.
I tried to delete the storage and the cache before but it didnt work. Even tried to restart after i dod that. Every time i tried the screenshot of my first post happens.

So I now think you are describing the Files app. The file explorer.

The Files app, when first opened displays Recent.

The upper row of icons and all of the view below are “Android shortcuts”. Files app does not work like an old school file explorer in this mode. (Maybe it works in “Safe mode” !)

Using the three bar menu top left opens a navigator, the top part of this panel continues to link to shortcuts, while a small lower section (one or two entries only) links to a regular file explorer:

  • :iphone: Device (by name)
  • sd-card1 SD card (if correctly installed as external storage).

So now tap the Device.

This view still has the Android shortcuts along the top. Disregard them.

This view occupying the rest of the screen is now more like a regular file explorer. Only now can you delete and rename, hopefully more as you expect.

In addition, the view is toggled by a switch in the upper part of screen, below the shortcuts, on the left.

Support topics
[HOWTO] Use the Files App

This may be a bit unlikely but you could try clearing storage for Bliss launcher to see if the Files app label can be restored. This will put all your app icons back to the default positions though.

Thanks for the tip with the bliss launcher but it didnt work.

And thanks but i know how the Files App work and how and where to delete the stuff in it.

If i go in these Categories and want to delete something in the Files App it allways does the thing like the screenshot in my first post.

i even did a factory reset. And the same problem appears.

heres the info of my app i hope it helps in someways

Hi, thanks, so just to clarify, do you think it is the case that the Files app is failing to send this notification?

This would sound like a match with FP4 can't copy move or delete files with the default "Files" app (#5383) · Issues · e / Backlog · GitLab

@chrisrg I think the lack of “title” to apps is a language based thing. I cannot find the issue in a quick search. This could be verified by changing language temporarily.

no this notification is allways there

but you know what. i changed the language to englisch and now i can delete the stuff again.

this is really strange.

Cool, I think you should add this to the link above ! It will be interesting to see if the creator of the issue can reproduce it … and I assume the “title” Files shows in English?

When you attempt to add to the issue you may need to be aware of Report an issue #Error

Edit, I have added a comment there myself #5383 comment

Thanks for adding.

i see the problem now.

when i delete in english i get a notification that the app is deleting the thing i choose.

if i change back to german it wont work anymore. and there is no notfication that something is deletet theres just the text that the app closes again and again.

so i will stay with english now.

Thank you for clarification about the Notification; this had not actually been observed on the linked issue, bit this may help triage the problem.

Does the title of the Files app now display correctly on the Home screen ? Again this might be a linked issue and help triage.

Shall I leave you to more fully document the issue for the devs ? (we cannot assume a conversation here will help inform the necessary fix)

yes it has the correct name now.

i dont think i have the time to do so, im sorry.

No problem, I will follow up at this point. The originator of this issue has initially confirmed the same issue as you.

I have linked within the gitlab issue "Files" app crashes upon delete (#5218) · Issues · e / Backlog · GitLab, which in turn links with

1 Like