/e/ Drive app in overdrive

After updating to Q-0.22 on my FP3 two days ago, the /e/ Drive app has started uploading about 65 GB per day, and is still going. My eCloud account has grown a bit, from 7 to 9 GB in this time. Any idea what’s going on or what I can do to troubleshoot this?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

/e/ Drive seems to work now.
It syncs some Folders. Have a look at Settings → Accounts → …@e.email → Accoint sync
Here you find Pictures and Videos. Which synces the DCIM folder.
Switch that off.
I think also Documents is synced, but there is no switch in the account settings on my /e/ OS v0.21.
This should be the two Folders.
Maybe you have a look at the ecloud website to see what files are lately been synced to verify if there are some other folders.

I have a total 35 GB in use internally and 76 GB on an SD card. /e/ Drive has now uploaded 158 GB in three days since the update, while my eCloud storage has grown by about 2 GB.

I know that syncing has been broken for quite a while, but there is no way that this amount of data has changed on the phone since then.

I have now disabled mobile and wifi for /e/ Drive and will continue to rely on the NextCloud app for auto-uploads.

It’s just a guess. But the upload may marked as failed. And therefore it
was tried again and again.
/e/ Drive may not get the free space on ecloud right or something like
that. It just should stop uploading, when no space is left and notify
the user about it. Also it would be very nice to have a message about
/e/ drive and how sync is controlled. Or better they should switch off
syncing pictures by default. And give a message to the user how to
switch it on.
I thought they improved it.

I noticed even with nextcloud app, that big video files failed in the
last third of the upload. One file was, I think 5 GB and had 7 or so
attempts. Let’s say it gone to 4 GB and failed and that 7 times. I think
that’s why you have so much upload.
But nextcloud notices if ecloud is full.

I have more than 11 GB available on ecloud, and there is no file that big on my phone. So it’s not about running out of space. I have taken a couple of photos these past few days and they were synced quite nicely.

What’s even worse: /e/-Drive tries to sync on cellular data as well. I was out with the kids on Saturday when my cell provider informed me that I’ve run out of high speed data. As I updated /e/ just the night before and haven’t had the problem before I could easily rule out anything else.

On Sunday a new billing period started which granted me another 3 GiB of high speed data, of which 1.9 GiB are already used up by now. I had not realized that /e/-Drive automatically syncs pictures and videos and would have immediately turned that “feature” off - let alone for privacy reasons.

So, my bad I guess.

Or better they should switch off
syncing pictures by default. And give a message to the user how to
switch it on.
I thought they improved it.

It is horrible UX and I can only agree that it should be explicitly OPT-IN.


OK so my /e/ drive went nuts as well, and I dont have an account. what did you do to get it under control? And did your SMS messages go nutty too? Mine tells me my phone has sent too many messages and asks if its ok to send one when I try to send a SMS text.

I have had to disable mine as well. I did not sign up for an /e/ drive account, but it uploaded all my pics as we. but to who and where i have no idea. I’m not liking this very much. You find out any new info?

All I did was to disable wifi and mobile data access for the app. It’s been over a week now, so I should probably turn it on again sometime soon and see if I can figure out what it’s really doing.

Hi everyone,
I had the same probleme today, it’s the first time something like this happen and I’m on /e/ since nov. 2019.
Did anyone have an answer ?
What do we have to do to make it stop ?
I turned off every sync on /e/ I could, but I’m “afraid” of turning things on again.

Same/same here. Complete runaway mobile data usage, possibly WiFi data too. I restricted the /e/ Drive app’s access to mobile data, as mentioned above. Do we have any comment from /e/ on this? @Manoj ? Is this something that is being worked on, Would it help to have more information from users?

I am on a Teracube 2e (2020 model) running /e/ Android version 10

This issue has been reported here
Suggest all users with this problem to add their comments and any additional detail on the bug thread.