/e/ installation on galaxy s9 plus can't get into Teamwin

what do you think of this video .
https://www.youtube.com/watch?v=BywY99aq_Lo

So this is the method: https://forum.highonandroid.com/t/how-to-install-android-10-or-11-gsi-roms-on-galaxy-s9-s9-plus/332.

The question you are asking is can you make a GSI ROM flash onto a Samsung which is showing as RMM State Prenormal. I do not know!

Edit: Except can you get past Step 1? You will need to unlock the bootloader, make sure “OEM Unlock” is checked ON in Developer Settings. That should be enough but if you are on newer firmware, you might have to reboot into Download mode and actually unlock the bootloader.

phhusson is highly respected. You will find him at https://forum.xda-developers.com/, perhaps you could find a suitable thread to read about that and/or even ask a question.

1 Like

/e/ OS ‘Q’ GSI and AOSP 11 GSI ROMs already ran successfully on my S9+ (star2lte).

the ROM booted without a hitch.

The basic requirement for installing a GSI ROM is
you guessed it
an unlocked bootloader aka OEM unlock.

1 Like

@SuzieQ I’m curious if I flash a stock Q image and try to do the same what would happen to my RMM status. Makes me nervous.

I’m now having issues with a Moto G7 Plus, I can’t even get the key from the device to submit at the Motorola Unlock Bootloader URL.

@egx470, we have gathered plenty and valuable information here by now. As things stand, my guess is that if Stock Android 10 ‘Q’ can be installed on your S9+ ‘star2lte’, nothing will change your RMM status.

Only when this manufacturer blockade can be eliminated will it be possible to unlock your bootloader respectively activate OEM unlock.

1 Like

Thanks. So what you saying is that because we already have an unlocked bootloader (TWRP flashed) flashing stock Android 10 will get the dev to Android 10 and RMM should not return to “prenormal”. From this point I can flash star2lte based on Q (beta), correct?

I cancelled the Xiaomi Mi 8 as the phone does not support all the bands for TMobile here in the USA. Working on these Moto G7+s and eyeing a OnePlus 6T A6013. These 2 phones support all of TMobile’s bands (2G-4G, ext range 4G) here in the USA. These S9+/S9 SM-G965 & G960 F/DS phones also do not support all of TMobiles bands so coverage is sub par.

4G bands

G965F :: 1, 2, 3, 4, 5, 7, 8, 12, 13,     17, 18, 19, 20, 25, 26, 28,     32, 38, 39, 40, 41,     66     - Europe/Global
G965U :: 1, 2, 3, 4, 5, 7, 8, 12, 13, 14, 17, 18, 19, 20, 25, 26, 28, 29, 30, 38, 39, 40, 41, 46, 66, 71 - USA

If the few non-existent frequeces in the European model of the Galaxy S9+ SM-G965F/DS are the deciding ones for you, then it is not the right model for you, otherwise the ‘star2lte’ is still a potent phone for which there is not only /e/OS ‘Q’ as the current OS.

1 Like

I am using the G965f on T mobile and while yes it does not have all the bands it is in my case so far still usable . I do loose connection here and there but I’ve honestly gotten used to it now and it doesn’t bother me very much .

1 Like

@Redsidriver @SuzieQ

I am overall happy with both the G965 and G960 (both are F/DS) I do notice that the coverage is not as good as my previous iPhone 12 which covered all the bands TMobile utilizes (I wonder how these Galaxies fair with AT&T/it’s MVNOs’ bands?). I am unsure if this is due to missing bands or something else. I am assuming it is due to the missing bands seen below. My coverage is a bit more spotty when I get out away from urbanized areas (thinking it is the lack of band 71 which is “4G Extra Range” thus the lower MHz for further propogation). This is why I have started work to flash /e/ on a Moto G7 Plus XT1965-T (if I can get the bootloader unlocked :slight_smile: ) . But again, returning to a Googled Android device or iOS is not ideal for me since I regard the right to privacy more than missing coverage which I am sure will only get better as /e/ matures in the US. :crossed_fingers: :crossed_fingers: :crossed_fingers:

But yes, I agree, this loss of coverage here and there would not sway me from utilizing /e/ with these two Samsung Galaxy phones…I simply am trying to get the best of both worlds and it appears the Moto will do the job, not as robust hardware-wise but plenty good for my needs. :slight_smile: :+1:

Screenshot from 2021-04-17 16-46-18

We probably should move this discussion to another thread. I don’t know how to move existing submissions

1 Like

At what URL are you getting this diagram? Very nice :slight_smile: :+1:

Did you happen to get /e/ on that phone (G965f) or are you still sitting RMM prenormal (blocking the flash to the bootloader)? I am curious if the prenormal will leave with extended regular use on the stock ROM.

Still on the RMM prenormal .

I just bought the g7 plus for my daughter as her first phone . I also bought that one because I could potentially flash /e/ on it once I figure it out . Not a bad phone but the speakers and the cameras are just not on the same level as the Galaxies .

1 Like

I had always been hoping that prenormal might lift after 7 days, your status is prenormal after all not “locked”. I wonder if you switch your phone off from time to time? I read that the 7 days might only be valid if the phone was on, and on line, constantly during the 168 hours.

1 Like

Hi everybody,
I have the same problem than @Redsidriver with my Samsung Galaxy S9, G960F.
I don’t find a way to get into Teamwin with the easy installer.

At first sight this looks like Easy Installer Samsung users fail to boot into TWRP (#2678) · Issues · e / Backlog · GitLab

There is some help for this here Your first boot into TWRP

Edit, you can read here how to find the log and you could post it here if you like.

@aibd Thank you for your answer. I still don’t find a way to boot into TWRP with my S9-G960F. My phone is right on Android 10. Here, you cand fing my logs of my last attempts : hastebin

I will make a very quick reply now and look at your log on a bigger screen later. I see libusb error -12. There is a comment today on a post with a similar title - this error is discussed.

It is described as a non-specific error – somewhere in the USB chain. So, first call, try a different cable, avoid USB hubs, avoid secondary ports on a PC or laptop. (On a PC often front ports are secondary, similar some laptops include an internal hub.) In the end, try a different machine.

I will look at the log again later, just writing this to encourage your to read the other post which seems close to your issue.

Later update from the log:

Connection is established ok with adb:

device product:starltexx model:SM_G960F device:starlte transport_id:20

Downloads proceed and script moves on … from the time when Heimdall is first deployed we see:

C:\Program Files\easy-installer>"C:\Program Files\easy-installer\bin\heimdall" detect  1>nul 
ERROR: Failed to detect compatible download-mode device.

Final error (and repeated)

C:\Program Files\easy-installer>"C:\Program Files\easy-installer\bin\heimdall" flash --RECOVERY "C:\Users\Jf\AppData\Local\easy-installer\sources\starlte\twrp-3.2.3-0-starlte.img" --no-reboot 
Heimdall v1.4.2
Initialising connection...
Detecting device...
ERROR: Failed to access device. libusb error: -12

I have looked for new sources for information on libusb to see if I can find a better guide to the error codes – not much luck so far.

It could be that we see this error on Windows (as you use @j-f ) and I was drawn to:

It would be interesting if a Windows driver is required on some machines.

Easy Installer was always believed to be self sufficient. However (you probably know the trick) if drivers are thought to be an issue open a Windows device manager window while the program is running and see if any :warning: device appears. Windows update may find the driver or you might try to offer the recommendation in the link above.

Good luck.

1 Like

@aidb Thank you very much for your help. I finally managed to install e OS on my S9 phone. It is working well. Using a different laptop and try different ports has finally worked.

1 Like