/e/OS S10 compatibly (SM-G973F vs SM-G973F/DS)


I am brand new to the world of e, so please forgive me if a similar question was already answered; I couldn’t find a 100% answer after extensive searching.
I want to get a Samsung S10 and install e OS on it. For this I want to order the correct phone. Unfortunately, the single SIM model (SM-G973F) seems really difficult to get, new, second hand or refurbished. There is however a ton of phones available with dual sim. Depending on how accurate the vendor is they are called SM-G973F DUOS, SM-G973F dual sim or SM-G973F/DS.
So my first question would be: Are all these phones the same version?
And more importantly, are they all compatible with e os?
I know there are a couple of threads about the F/DS version and it seems like it works. I am not an advanced user - I can follow tutorials just fine but if there is any troubleshooting to do that is not for me. So I need it to work as is.
Can someone please confirm if it will work with these dual sim versions?

Thank you so much for your help!


Hi @hoellenschwarz welcome to the forum.

The way I checked the answer to your question is to check Smartphone Selector search for Galaxy S10, click the link to the info page … scroll to the foot of the page … to this section:

Models Supported
Other models are not supported

I would really take that as the answer … but … then I checked the LineageOS wiki for the device

where we see

Models Supported

/e/OS is a fork of LineageOS but with, loosely speaking, added more complex components; it is not a given that if a device variant works on LineageOS it will work correctly on /e/OS.

If you have seen threads on the forum here mentioning the SM-G973F/DS model you might directly ask there about their experience.

(Another possibility … beyond1lte is supported by https://lineage.microg.org/ … another OS closer to /e/OS but significantly different in that /e/OS offers https://murena.com/cloud/ … but in this case I do not find a “Supported models” section … so this offers no certainty.)

1 Like

Hi aibd,

Thank you a lot for the welcome and the input.
It is good to know that in the worst case I could install lineage instead of e, I didn’t know that.
I’ll also look into the microg solution just in case - of course I’d rather have e os.


If you are minded to “have a go” … I think it is worth linking two threads

It is something of an unknown, did the early adopters of SM-G973F/DS in the first link suffer from a “dual SIM issue” or simply from the more general difficulties of this “newer generation” of Samsung ? The second link is worth careful study.

This generation of Samsungs is beyond my hands on experience; I have a feeling users following Install /e/OS on a Samsung Galaxy S10 - “beyond1lte” might have underestimated the great importance of the Pre-Install Instructions.

Please be aware of the advice at the start of the page …

Please read through the instructions at least once before actually following them.

I prefer … Please read through the instructions at least three times … :slight_smile:

Good luck.

Your device is supported,
don’t forget the network connexion when unlocking the bootloader,
don’t forget the vbmeta step,
be precise with finger timing when rebooting from dow’load mode to recovery mode for the first time…

Some illustrations here

1 Like

Thank you for all the answers.
I ordered what is supposed to be a F/DS. For some reason it is surprisingly difficult to get clear information about the model number; I ended up with a US version two times. Let’s see if third time is the charm. If it the right phone this time I will report back how it goes with the installation.


I have got my phone and I managed to successfully install /e/OS on it. It was not exactly straightforward and took a couple of hours, but I have it now. So I thought I share my experience if someone is trying with the same device. And to be clear, it is only my experience; I am no expert in any way so take that into consideration.

Phone: Galaxy S10 dual sim, Model nr: SM-G973F/DS
Other software used: Windows 11, Odin v.3.13, TWRP 3.7.0

Since I use a Windows PC I decided to follow this tutorial instead of using Heimdall, which does not seem to work well on Windows: [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

The short description that worked in the end for me is as follows:

  • upgrade the stock OS to Android 12
  • enable wifi (I wanted to keep the phone offline but it seems that certain follow up steps do not work this way)
  • enable developer options and USB debugging (I am not sure if it is necessary for this tutorial but didn´t hurt)
  • did not get the option for OEM unlock so I followed step 3.5 in the tutorial
  • downloaded and installed ODIN
  • phone was not recognized by ODIN so followed point 7 to install drivers
  • restarted Phone into Download mode (Vol down and Bixby and connecting USB cable)
  • downloaded TWRP and moved it to the phone as described
  • now this may be interesting for others: Here I came across a problem that was not described in the tutorial. Odin said it was successful in installing TWRP; but my phone was stuck in Download mode with an error message “recovery error validating footer”. Restarting the phone and any of the possible button combinations did nothing but throw it back to Download mode with the same error message. After I while I found the solution here: https://forum.xda-developers.com/t/recovery-official-3-6-1-x-twrp-for-galaxy-s10-e-5g-exynos.4180287/ , more specifically point 10 and 11: A file called vbmeta.tar must also be downloaded and moved into the CP tab of Odin - started ODIN again and this time I could boot into TWRP
  • rest easy as described - wipe, move the e-os file, install, restart

I might have skipped steps but I really mostly followed the tutorial except the additional file for TWRP that was necessary.

I have not tested the functions of the phone yet; but will do that over the next days/weeks.



does not cover recent Samsung since Galaxy s8 or (android 8 based)


1 Like