/e/ update 0.19-20211023142277

Hi folks,

EDIT: 0.19-20211023142277 is the current showing update.

Just updated /e/ and it has killed most apps on my phone. Using a Samsung Galaxy S9.

Specifically, when I open ANY app that has a text field, such as using a messaging app or writing an email, I get Bitwarden has stopped, even for text fields not related to credentials, such as an SMS. Also, when typing any text, I can see in the Swiftkey predictive text that what I am typing is being recognised, but nothing is appearing in the text field, thus I cannot send any emails, SMS, add calendar events, etc. I had about 30 apps to be updated from the Aurora store which continuously showed a package read failure, too.

This update seems to have been catastrophic for my phone and I’m sure the S9 would be common enough for rigorous testing to have been done.

Is anyone else experiencing this issues or have done in the past/have solutions?

It’s difficult to justify staying with /e/ if an update is going to make my phone useless, but I like the project and hope there are fixes for this.

Please can you provide the /e/ version from:

Settings > About phone > Android version > long press on /e/ version to copy to clipboard.

What method did you use to perform update?

Method of update was via the inbuilt systems updates in the settings menu. I received a push notification that an update was available.

System Version


Android Version

Build Number
e_starlte-userdebug 8.1.0 OPM7.181205.00168aa90536b dev-keys,stable-release.

I see that you already reported this Decryption Option with no replies! Did you resolve that issue? as of course it would impact your current situation! :slight_smile:

So you have the latest build listed available for starlte https://images.ecloud.global/stable/starlte/e-0.19-o-20211023142277-stable-starlte.zip.

Trying not to sound defensive e-0.19 was tested unusually thoroughly resulting in the stable build being released very soon after the dev build - the errors you report are not expected.

So we have to look for some sort of error in the install. Please can you recharge the phone to 100%. Please can you boot the phone into Recovery mode:

With the device powered off - hold Volume Up + Bixby + Power. When the blue text appears, release the buttons.

As this device is on stable channel, please can you confirm you have /e/ Recovery installed, and that the phone happily boots back to system.

Assuming prior issue above is resolved.

Now please retry the update by trying:

  • Download the update to the device, (internal storage or SD card is ok)
  • Boot into recovey mode, select update from your storage location,
  • Install update.

Here is an older, TWRP based, HOWTO Update - if you chose to follow this method you could [HOWTO] Verify a checksum using Windows 10 for extra assurance.

If uncertain about anything, please ask again. :slight_smile:

Footnote. Unlikely fix: you might be able to try to Wipe > Advanced Wipe > Wipe Dalvic/ART Cache and Cache (two items), but I do not really expect that will work. This option is offered by TWRP, but, I think not by /e/ Recovery. (There would be no loss of data.)

1 Like

Hi, thanks for your response. No I was not able to fix the encryption issue. I ended up reinstalling /e/ to fix the problem and did not revisit encryption due to this issue.

I am able to access TWRP and rebooted back into the system fine, but when I enter my passcode I get a bunch of ‘x app stopped working’ prompts. I am unable to access my bitwarden or duo accounts, which is rather problematic.

I tried your footnote of wiping dalvic/art cache and cache, but not a lot came from that.

I will re-download the update and reinstall from recovery to see what that may do. I assume this will not affect apps/data.


Just one very specific issue. If you are saying that TWRP asks you for Pin/Password, and you never set it … then press cancel when asked for the password. It is odd but as long as you never changed the password, TWRP will now use the correct default password.

You are in a different password situation please say!

this will not affect apps/data.

This update method should not touch the data partition.

Apologies, I meant my passcode for logging into my phone after rebooting - the normal passcode for everyday usage.

I just reinstalled the zip you linked me to via TWRP and rebooted. Still having crashing apps. I suspected it may have been my launcher no longer working, but tried to use another launcher and it would continuously crash.

My current launcher is Total Launcher and I tried both Bliss and a few others with no luck.

I am not good on this subject. I suggest you try to redefine your issue on your other post (unless someone jumps in here!)

I’m not sure how else to define it. I have given all related info.

I just tried to roll back to 0.18 to see if that would restore previous functionality and now I can’t even get past my lock screen. I enter my pin and it just loops back requesting my pin again.

So now, would you not be able to reach this?

Settings > Security > SIM card lock - OFF

Edit, @sierraechogolf, it is a subject I had to read up on, this article gives a lot of the basics (sorry the site contains 9 assorted trackers!) https://www.howtogeek.com/141953/how-to-encrypt-your-android-phone-and-why-you-might-want-to/. A truncated encryption session, perhaps due to lack of battery capacity, might be the cause of your problems, do you think?

You probably know that the only way to unencrypt is to Factory reset. This can be done from TWRP.

Hi again,

I have a sim lock intentionally, when I input the code it goes to the regular screen lock and my pin there seems to be accepted, but then the screen switches back to requesting the same pin again. It’s clearly a bug after auth as it’s not counting them as failed attempts, which would ordinarily lock you out for a time.

I don’t believe I had a truncated encryption session, besides I did a reset after the encryption failure and the phone worked fine ( I chose to remain non-encrypted after that) for several months until this update.

I guess I will have to attempt a factory reset again. I will report back with a success/fail status later today or tomorrow.

Alright, so I did the factory reset option via TWRP and am currently reinstalling my previously problematic apps without issue.

I didn’t lose data (photos, docs, etc), but obviously had to reestablish all customization to the launcher and auth services. This seems to have fixed the problem though, which is good! No idea what caused it, but happy it has been resolved.

I might actually attempt a full encryption again and see if that is working properly now. I will update later with success/failure status on that.


1 Like