Easy installer error FP4 partition could not be flashed

I tried to install e/os on my FP4 using the easy-installe on Linux (OpenSuse).
At the end, i got a message a partition could nout be flashed. I don’t remember the exact words and didn’t take a foto (sad but true). I searched the log files, but couldn’t find the proper line, no “partition” to be found there. Now i’m stuck in fastboot/recovery. What can i do now?
Seems that this: Easy installer error FP4 describes the same problem, but unfortunately, there is no solution given…

Which, or you have a choice of either mode.

Please can you show an image of your Bootloader screen. Does this show that the device is still locked ?

For the log: Howto troubleshoot issues with the easy-installer

Sorry for my late reply.
I have the choice of either. When not going to fastboot/recovery, screens will toggle between (fairphone - powered by android) and (The bootloader is unlocked…) indefinitely. See pics: https://murena.io/s/yMJyFaPPcKR6EW4
So no, the device is unlocked. The installation process was way beyond this point.
In the given link there are the log files aswell. I think it was during the shortest log file, but i’m not quite sure of that. The rest wa fiddeling around - sorry for that.

I have not done a full analysis of your logs but the most recent log spends the whole time waiting for the device.

One of your images shows fastbootd.

fastbootd is quite different from fastboot

In this thread Documentation error? With Stock OS running Installer Script while entering fastboot mode for fairphone4 does not work as stated, which was solved this whole issue was explored in depth.

I am purely guessing … that at some point the device got stuck in fastbootd mode … and maybe you did not realise the significance … and did not later explore your way back to the bootloader ??

I suggest you check the manual instructions https://doc.e.foundation/devices/FP4/install and go through these sections to ensure you have full control of the bootloader.

Before install

  • How to Boot into bootloader mode

  • Unlocking the bootloader Log 2 below suggests this was completed by Easy Installer.

I guess you then would have to decide if you want to try Easy Installer again, or if the above page was not too daunting, the final flashing of the device is not so hard as it is done by a script.

Some brief notes from your logs. I have numbered your logs chronologically using the time of start of Easy Installer.

Log 1 2023-08-26 19:39


2 x Could not resolve host: images.ecloud.global

Log 2 2023-08-26 20:18


(debug)Critical unlocked!
(debug)fastboot mode detected, phone is critically unlocked


all OKAY until FAILED at this point:

(debug)Sending 'core_nhlos_a' (111884 KB)                 FAILED (Write to device failed in SendBuffer() (Bad address))

Log 3 2023-08-26 20:37

Seen throughout the log:

List of devices attached -- waiting

Only if you are unable to return to the regular Bootloader menu, with big coloured START at the top, then this thread explores the standard advice for “failed to flash a partition” Help i think i bricked my phone

1 Like

I am purely guessing … that at some point the device got stuck in fastbootd mode … and maybe you did not realise the significance … and did not later explore your way back to the bootloader ??

And exactly that was the poblem! To make things worse, when in recovery mode, you are given the option “fastboot mode”, but this will start fastbootd instead. In fact, this made me think they were the same.

So, as per your recommendation, I went through https://doc.e.foundation/devices/FP4/install (easy installer wouldn’t work) and now my phone runs on /e/. Thank you so much!


This topic was automatically closed after 180 days. New replies are no longer allowed.