Easy installer error FP4

Hello im tryed to install e/os on my FP4.
I paid exact attention to all the instructions. At the end of flashing i got an error that a partition could not be flashed (i don’t know the exact wording anymore).
Now im somewhat stuck in a bootloop. I can only access the fastboot/recovery option anymore.
What can/should i do?
Can i try to rollback to the original FP os. Did i somehow brick my phone?
Im a bit tense at the moment so im glad about any feedback so far. I don’t want to rush something on my own and make it even worse by mindlessly flashing the original os again or something like that.

Hey there,

the same happened to me yesterday. I’m lost.

I bought a new FP4 and wanted to change the OS to /e/ with the easy installer. After doing all the required steps, the /e/ installation failed, with an error message “partition could not be flashed”. Now the phone is stuck in a reboot loop, with the only option to stop it.

I chose /e/ and the easy installer, because I didn’t want to get into the command line coding etc. and just wanted to have a google-free working phone. Any advice on what’s next or potential solutions are very welcome.

Many thanks!

Im glad, it’s not just a user error from me. Acctually yesterday a dev reached out to me and helped me fix it, but as far as i know they haven’t found out why this happens. So be calm it’s fixable and if you know what to do it’s somewhat easy (i didn’t know myself). I don’t know if they have always time to help ppl with this. But i can try to guide you throught it a best as i can.
I’m assuming it would be very valuable to document how exatcly it happen so the dev’s can fix the easy-insaller.

Good to hear that you are getting help. I seriously suggest you edit your post to remove your email from the forum.

In this image I show how I would direct message you – tap your icon, tap the Message button.

An automatic feature, new users do not see this feature until they build a little “trust” with software.

Absolutely please feel free to share your journey – it is disturbing for users to have issues like this with Easy Installer.

Good luck

1 Like

email? i dont know what you’re talking about LUL. I mean wasn’t my real after all^^. But thanks for the suggestion and the guide on how to pm.

Yeah i’m happy to share my story. I just don’t want to engourage ppl to much to ask for personal support, you know. The thing is i wanted/was reporting a bug (that wasn’t known about yet) and wanted to get this massage to dev’s asap because i misstakenly thought it would acctually hard brick you’re phone.
I never asked for personal support but i am/was very very happy to get it.
Do you want me to share the information about this here, from my point of view it seems unnessesary because i was acctually in touch with a dev that helped me fix it and they are for sure working on it.
So i mean i don’t think anyone would check if the possible triggers would apply for them before using easy-installer and the acctual bug report would be much better directly to the dev then in this thread/to me. So it’s on the devs to decide how to handle the easy-installer on the FP4 page.
Additionally i was in a hurry this morning so i just had time to go for the most important things then.
I just quickly answered here and informed the dev about it and attach this thread to him. He already told me: “i’ll check with him too.”
So i guess the only help we still can do is calm ppl make them aware to note all details they still know about the “setup” and just hand them to the devs.

1 Like

So to come to you. As you can see a dev reached out to me and helped me fix it. He’ll reach out to you aswell.
I’m sorry that this happend to you aswell while im also glad i didn’t just messup myself and claimed personal support because of my own failures.
I’ll leave the big part to the dev but a few things i want to tell you myself.
1.I don’t think theire is still a way to avoid using comandline to get you’re phone working again. I remember when i first started to use cmd myself and how scary it seem. You can view it this way: Most of the times commandline is very strict, it only does exactly what you tell it to do and otherwise it fails with a pretty accurate error. Most likely this time you will even have a professionall at your side to do it with you.
2.I guess if you absolutely dont want to touch it you might be able to ship it to a professional pay a fee and get it back working no problem what so ever.
3.Don’t panic so far it seems fixeable and you will get you’re phone working again. To be honest for me it took a little while but as far as i know i was the first one encountering the bug and it/we took a fair while to record what happend then exactly diagnose the current state of my phone to then go the tinyest step after another to make sure i don’t make a user error (spoiler i still did a tiny one with big impact >.<). In the end we foud that misstake aswell and then got it working instantly without any more problems.
So i guess it should be a somewhat fast progress for you, still don’t rush it take you’re time so you don’t overlook something like me.
Wish you best of luck :D.

sorry, but i dont have enought trust to ask this in pm.
What is/was the problem on mentioning a email. An email doesn’t seem a big deal to me. What could someone do with just the email name?

The biggest hazard, I think, is that bad actors can trawl public spaces like this for valid email addresses and then do what they want with them.

yeah i see the crawling but what they wanna do with it? create onlineaccounts? That shouldn’t hurt me.
Also aren’t theire not like a million public email adresses like in contact infromation on website from companys and so on. Sorry i dont quiet get it :s

I had an issue a week ago installing with easy installer and tried to fix it using command line but the phone is still stuck in Fastboot. I have tried factory reset using commands and flashing with the stock OS but still bricked. I can’t access recovery mode. Any idea what to do?

Have you tried to revert back to stock?


Yes and its still stuck in bootloop. If I could even get into recovery mode that would help but it won’t.

What was the issue?

It would be helpful if you could try again and give us the exact commands you are running and any output (nothing, success, error messages).

If you happen to have Fairphone Angels in the vicinity (community volunteers offering help), you could ask them whether they have perhaps done something like this before and would perhaps be able to help in person … https://forum.fairphone.com/t/the-fairphone-angels-program-and-map-local-support-by-community-members/33058

I’ve flashed the drive probably between 5 and 10 times already. I have been using the mac terminal so the command ./flash_fp4_factory.command. In addition I have unlocked the bootloader using ./fastboot flashing unlock and ./fastboot flashing unlock_critical as I was getting an error before if I didnt unlock the critical drive. As I can’t enter recovery I did a factory reset using delete userdata and delete metadata. I got no errors doing any of this and it says SUCCESSFUL when I flash the drive.

I’ll just add my results for get_unlock_ability

(bootloader) get_unlock_ability: 1

OKAY [ 0.000s]

Finished. Total time: 0.001s

For me, the easy installer also got stuck after I booted the phone in fastboot, there was a text “OEM unlock” or such with a green bar that filled, and once it was filled, the installer did not continue.
I can absolutely recommend copying the downloaded zip to a path, extract it there, check that all necessary files are present, and run the script to continue installation. The script only worked with sudo, so maybe the problem was that my installer was not running under sudo, as well.
I really appreciate the easy-installer for guidance, but at that last step, consider adding the manual commands as an alternative :wink:

Initially my phone worked after installation… for about an hour and upon turning off the phone and on the problem started - stuck in fastboot I mean.

Are you able to unlock using command prompt both general unlock and critical unlock ?

I was in the same situation, my phone got into bootloop as i tried to lock bootloader while security patch was no good, all i had to do is to unlock both usual and critical via command prompt and then manually sideloaded the fairphone os original image and then easy installer worked fine

Yes I have unlocked the bootloader both general and critical and no errors. How do you sideload the fairphone OS image? Do you mean you flashed the stock OS?

Yes i went back and flashed to the original stock fairphoneOS