Email app without notifications after Update

Above is the Version i updated to.
Since then im not getting notifications for new Mails anymore.
Below that is the Test build which i came from.

Other Standard Apps are working with notifications e.g. the Calender.

Device: dumpling

That’s true. Same on my FP3.

Same on oneplus3T running the Q alpha build. Mail arrives but notifications completely absent. Tried changing various settings in the app, but no change yet.

I did notice in settings>account settings>notifications : the “Blink led” option is unchecked. This was the same for me on the pie test builds where I was getting notifications but no blinking led.

Please add your comments and logs where possible to this gitlab issue

1 Like

I tried to configure a workaround using another mail app. Not easy, because this is what I need:

  • no trackers, no routing over own servers, no advertizing banners
  • multiple user defined mail accounts
  • IMAP push messages and proper immediate notifications
  • sending plain text messages, not HTML.

I would indeed pay for that, but there seem to be only a few.

Fairmail makes a good impression and seems to work very well but sends only HTML messages. Sorry, I know system administrators who put HMTL messages directly into the spam folder. Fairmail has a clone, SimpleMail, but it’s the same there: only HTML.

LibreMail can’t receive push messages (or I wasn’t able to configure this).

ProtonMail needs a Proton hosted mail account. This is a start condition (perhaps you can still have some others).

K-9 is often called. The first thing one must know is: there seem to be multiple versions of K-9. The one in Apps is different from the one in F-Droid. Didn’t check version numbers until now but the K-9 from Apps can’t receive push messages at all. It doesn’t even ask when I configure a mail account and later, when I want to setup it afterwards, there’s the entire option page missing. You can configure to synchronize never but you can’t switch on any push mechanism.

OK. I tried also the K-9 from F-Droid which is different. Indeed I could setup push messages correctly and it did even work in all my three mail accounts. Everthing was fine, the result was so good that I disabled receiving push messages in the ordinary Mail app (which doesn’t notify anymore).

But then, after an hour or so, K-9 crashed somehow, it just disappeared from the screen. When I opened it again it was exactly like the K-9 from Apps. No push options anymore and the synchronization has been set by witchcraft to 15min in all three mail accounts. And indeed it doesn’t receive push messages anymore. Damned.