Fairphone 3 with pre-installed /e/ gets no system updates

Hello folks,

I have been super happy with my Fairphone 3 that came with /e/ pre-installed, ever since July 2021 (or thereabouts). I must admit I never even thought about system updates, and I never got any alert for them.

Now I am one of the many people whose internet connection isn’t recognised properly, so I checked my system updater manually. It lists two updates from July 2020, and I can either “delete” the one from July 1st or “download” the one from July 29th. No other options, tapping “download” gives me an error: “Die Update-Überprüfung ist fehlgeschlagen” (“the update check has failed”).

I tried deleting the updater app’s cache as I found that piece of advice somewhere on here, but it makes no difference. What can I do? Do I have to reinstall completely? I’d much rather not…

Thank you!!

First of all delete not just cache but storage too.

You can establish your actual build from

Settings > About phone > Tap on Android version > now try to long press for “copy to clipboard” or try to copy the exact version you are running.

1 Like

Thank you for your quick reply!

So here are my screenshots:

Deleting the updater’s storage only removed the first entry (that had the delete option).

However – I just realised that I’m nearly out of space (97%). That can’t be good. I’ll clean up a bit and then see if updates are downloadable…

Update. got 5 GB free, no new updates, can’t download the one listed. :confused:

Definitely. I suggest you aim to get below 85%.

Agreed … that was a non-runner.

But with your fp3 Pie build from 2020 … e/OS + Android OS version names and numbers? - #3 by aibd … I think you are in a similar position to this … if you can follow the links :slight_smile: Issue with no connectivity for users still on old builds post release of v2.0 - #91 by aibd

1 Like


Unfortunately, you can’t upgrade your FP3 to the last version with automatic upgrade.

That sometimes that have been explained in the footer of weekly development news like here: look for the title OS upgrade info specific to the FP3.

Here is a quote of this section:

  • The FP3 OTA OS update from Pie to Q/R is not possible as encryption method changed on FP3 between Pie and Q/R. It is not possible to change the method while updating.
  • The team spent a great deal of time on this, but has not been able to resolve this problem. For now, the manual process is the only way to upgrade the FP3 from pie to other OS versions.

I also have a Fairphone 3 bought from the /e/ OS store. I used the easy installer to make an update to the latest version.
:warning: This require you to backup all your files before since it will wipe everything !

You can get more information on easy installer here.


Thank you all for your tips and help!

Long story short… I backed up my files and committed to wiping the phone, so I was thankfully relaxed about things not working straight away. I’m on Linux (Debian) and tried this how to guide first – that resulted in the error message fastboot: error: cannot load '/home/anna/Downloads/FP3/tz.img': No such file or directory.

That made sense to me because the file wasn’t there; I had however checked for file integrity after the download so I thought that something else must be wrong. (I just thought to check whether I had unpacked everything properly, and I HADN’T – so the missing file was actually in the zip. D’oh. :laughing:)

Next I tried the snap easy installer, which got hung up on detecting my phone’s fastboot mode in step 2. Others have had that problem, but only under Windows, so I was stumped.

End of story, I did a factory reset, and after that I had ALL the updates available in the updater, including the latest 2.0-something version. I downloaded that and installed it successfully, and after a reboot it said my OS was corrupt and the only option was another factory reset.

And now after another factory reset it just booted into version 2.0, my internet connection is working perfectly again, only 22% of disk space are in use, and I will now spend so much time reinstalling apps. But I am very happy :smiley::smiley::smiley:

Thanks again, I wish everybody who comes across this post good luck with their updates!


Thanks for not giving up and finding a path to get it done in good spirits.
This is the way :muscle:.